Liteon LH-20A1H firmware update fails

When I try to update the firmware with the latest from the liteonit site I get the following error message.

Does anyone know what I’m doing wrong?

If this is a double post, my apologies. It gave me a wierd message on the first one. Thanks in advance.

Welcome to the forum, [B]dpilot83[/B] .

That message can happen if you are trying to flash from a newer firmware to an older. If you are using the one on the U.S. website, which is LL06, you already have a newer firmware, LL0A, which is causing it to fail. But there is firmware LL0C on the Lite-On IT Global Website (search for your drive as you would on the US website). The firmware is also available here , should the one on the global website also fail. (The firmware located here will be packed in a .rar archive).

The firmware on the US site, although posted on the same date as the one on the Global website, is actually much older. That is always the situation, and the dates may be a little misleading. If you are in doubt, you can look in the filename of what you download and see which firmware version it actually is. :flower:

Heh…Well, I guess it’s alright to feel like a newbie…since I am one. I gotta admit, I feel pretty silly though. Thanks for the info. I just assumed that what was posted on the US site was the latest and greatest. Is there anything that’s going to hurt me by using the Global release since I’m in the US? Thanks again.

Alright, this is becoming a frustrating experience. I tried to update to LL0C from the global site and it said unable to flash firmware, please contact your vendor. So I went to the one that was in a rar archive and it did the exact same thing. I tried to play a regular DVD I bought at Wal-Mart (Tombstone) and it didn’t play either. In fact the first time I tried it totally froze my computer and I had to restart (this was with VLC media player). I then tried again and it gave me an error message and shut VLC down. I then tried with PowerDVD and it froze as well, I had to do ctrl+alt+delete to close PowerDVD out. I’m at a loss. Did I get a bad drive?

Do you know if the drive worked properly before you tried to flash the firmware? There might have been a slight issue with how you installed it.

Another set of questions I would like to ask: Is your drive master or slave? Is it on the primary or secondary IDE channel? Is the jumper on the back of the drive set to [B]MA[/B]ster, [B]SL[/B]ave, or [B]C[/B]able [B]S[/B]elect? If you don’t know, we can help you check. :slight_smile: (This is the possible installation issue I referred to.)

[off topic]
you’re a pretty advanced newbie. :wink:
[/off topic]

Hey wallace0134, thanks for your help so far and sorry for the delay on my reply. I had to sleep and work some and now I’m on a break.

My hard drives are on the primary IDE and the DVD drive in question is the master on the secondary IDE and my teac CD burner is the slave on the secondary IDE.

The DVD jumper is set to master and the CD jumper is set to slave. The DVD is connected to the connnector that’s at the end of the cable, the CD is connected to the one that’s in the middle of the connector.

To be honest I did not attempt to watch a movie with the drive before I started trying to burn stuff. My only purpose for buying this drive is to send homemade DVD’s to a friend in the Navy as a morale booster. She has a portable DVD player she can use to view that kind of stuff. The only thing I have that records video is my fuji digital camera and it outputs the video in .avi format. I was using DVD Flick to convert it and burn it. The DVD Flick installation also installs ImgBurn which is what I wanted to use to burn the DVD’s anyways.

Anyways, the first time I used it I was trying to burn a sample DVD to see if it would work the way I wanted it. DVD Flick appeared to convert it but ImgBurn gave me some errors. I hit cancel on the error message and for some reason that let it keep trying and it produced a disc but only half of what I put on there played. So I figured I’d start hitting basics with the DVD burner before I started trying to interpret the ImgBurn errors I was getting.

lol…sorry for the story. I figured it might clear some things up. Once again, I really appreciate your help so far.

Although this may or may not identify anything, can you try to set the drive to cable select and put it in place of your Teac on the cable? & Temporarily leave the Teac disconnected from the cable altogether. Just trying to make sure it’s not the cable causing issues.

I can certainly give that a shot later tonight although I think it would be unlikely for there to be any difference. I think I failed to mention that I previously had a regular DVD player as the master on the secondary IDE and it worked fine. All I have done is replace this working DVD player (also a lite-on) with the problematic (so far) lite-on DVD burner. However, it’s a good thought and I’ll give it a shot this evening.

Ok. :flower:

Can you give me a little more info about your system? What OS, motherboard, etc.? Also, is the drive still listed in Device Manager? Is there any type of error code with it?

Sorry for all the questions, again. :o

Hey, no problem. I’m just glad for the help.

My system is pretty old.

Motherboard: Asus P4P800 SE

This exercise has reminded me that both of my hard drives are not on the primary IDE like I originally thought. This motherboard is one of the first to start offering SATA. Therefore I have an older 80 GB HD on the primary IDE and a newer SATA 320 GB seagate on the SATA and then the two CD drives on the secondary IDE.

Processor: P4 1.6 Ghz
Memory: 640 MB (don’t ask, lol) PC2700 memory
Hard Drives: 1 x Maxtor 80 GB 7200 RPM IDE
1 x Seagate 320 GB 7200 RPM SATA (I think the SATA may actually be routed through the primary IDE channel and hard wired as a slave to whatever is on the primary IDE. I had to do something to trick the BIOS to let me boot from the second hard drive when I installed it on this old motherboard from what I remember)

Video Card: Some old 128 MB ATI card
OS: Windows XP Pro SP2 with all updates

That’s all I can remember off the top of my head. Let me know if you need anything else.

edit: Almost forgot. Device manager looks good.

edit 2: I didn’t even look at the software that came with the drive. I noticed a copy of Nero and thought “meh” and just stuck the drive in and tried burning. Maybe DVD drives require software to work properly and I skipped something I needed. Just something I thought up but I can’t really get to the box right now to check…

Nah, you don’t need the software disc to at least read most discs. It should [theoretically, as you can see] work right off the bat.

Another way to narrow down the possibilities: If you have a Windows installation disc, will your computer boot from it? If so, it’s a Windows problem. If not, it’s a connectivity/BIOS/drive problem, and we can work from there. :slight_smile:

[off-topic]
I Googled the mobo, just to see if many people had issues with it, and I must say, if not set up just right, it seems like this board can cause a couple of issues. But when set up right, the mobo appears to be awesome.

[/off-topic]

Now that is a really good idea. I don’t have my windows install disc with me at the moment but I do have a Linux (Ubuntu) bootable CD with me. Before I try that test I’m going to tell you what happened when I tried opening that disc within windows. When I inserted the disc with my CD burner, it autoran fine. When I inserted it into the DVD burner it did nothing. I opened my computer and then double clicked on the DVD drive. It froze up for a second and then gave up and went back to nothing. Right click, explore. I can see all the folders and files. Double click “start.exe”. Nothing. Open a text file. Works fine. Open a picture. Works fine. Open a folder. I can see everything in the folder. So I don’t know what the deal is. Some stuff I can do, some stuff I can’t do. Anyways, I figured I’d write that down before I forgot it. I’m going to try the booting from the DVD drive here in a sec.

Alrighty. I don’t know how much you know about Linux. You appear to be very knowledgeable but just in case that’s something you’ve chosen not to explore, Ubuntu is a linux distribution that installs a trimmed down version of the operating system directly to system memory so you can test it out when you boot up from the CD, decide if you like it, and then if you do, you can install it from there.

Anyways, I took that CD, booted from it with the DVD burner, and everything worked perfectly. Granted, it’s a CD, not a DVD, but it was working fine when Windows wasn’t involved, and it wouldn’t even auto load like it was supposed to when Windows was involved.

I used to have a habit of reinstalling windows just for kicks every few months. It’s now been a few years since I’ve reinstalled Windows on this machine. I’m not at all adverse to doing so now if that seems like a decent next step? I’ve appreciated your advice so far. Does this sound like a good next step? I honestly hate troubleshooting Windows problems…uninstalling drivers and reinstalling them, etc…I’d much rather just wipe it clean if I’m going to have to start messing with stuff…lol.

I was actually going to just jump straight to the suggestion of reinstalling Windows, should it be a Windows problem. Troubleshooting any problem really IS a nuisance, especially with the lovely Windows series. (It even seems to cause more problems further along down the road, in some cases.) So we should probably try that next and see how the drive gets along starting from scratch. :wink:

Heh…sounds good. Thanks again for the help. I won’t be able to get to it immediately but I’ll let you know how it goes.

Are you using 80 wire ide cables?

No I am not. Is that required?

This quote is directly from the website:

“Supported transfer mode : PIO mode 4, DMA mode 2 and Ultra DMA mode 4”

I thought the only thing that required an 80 pin cable was ultra dma. If the problem that I’m having is due to a stupid cable…boy I’m going to feel dumb…

You can believe I would feel dumb. Although I find it odd that you could at least boot with a Linux-based CD and not read the discs in Windows (without it hanging), stranger things have happened. But if that was the cause, I would feel majorly dumb.

I would think that Windows would drop down to PIO mode, but still be able to work, if there was an inadequate cable. And that reading would have flat-out not worked otherwise.

So you’re confirming that I do need an 80 pin cable? lol…I bet there was even one in the box. I just didn’t look for anything else because I didn’t think I needed anything other than the drive. I’ll check. I’m headed for bed though. Thanks again. lol… :o

80-[B]wire[/B] cable. Anything that is rated for UDMA 133 is supposed to be 80-wire. (Anything rated for UDMA 100 should also be, but I can’t confirm that).

Both 80-wire and 40-wire cables have 40 pins, but 80-wire cables have extra shielding to prevent interference and allow the higher UDMA 100/133 modes.

Good night. :slight_smile:

(Might I ask, what old LG burner model did you have? You said this worked correctly, if I remember correctly.)