LiteOn LDW-851s - xp says driver is corrupted or missing (code 39)

vbimport

#1

Please jelp me…i am desperate…i had it working for about 1 minute…it was great …now … after about 1 hour nothing works anymore… i tried everything …reinstall …took it out…unplug it …everything …but nothing helps … please help me … i have no idea how to make it work anymore… please help:sad: :sad:


#2

need more information. Now you say it says code 39.

Do your cdroms read in safe mode? Did you try to run the “system restore” feature to go back a day or 2 to when it worked?

What burning software do you use or have had installed (ive seen that error happen from having easy cd creatore 4 installed on an xp system)

Do the drives show up in “My Computer” and do they show up in the device manager (although with ?'s)

did you happen to install any software recently that relates to burning.

If you have any bootable cd-rom disks (like an xp cd) does your system boot off them (this would mean the drive is actually working and its a software error)

One thing that could help us is to list the cdrom device drivers listed for your cdroms (if you go to your device manager, then driver, then driver file details).

Try to type out that list here (be sure to note which ones have the check mark near them as those are the whql certified ones).


#3

here is the deal…

everything was working ok

i installed kazaa to try to get a file

then comp says virus detected…

dvd driver and cd rom driver dead

i ran AVG and got rid of virus

took kazaa off
took everything having to do w/ kazaa off

since then nothing worked…

i tried everything…for some reason my comp cannot restore to any recent restore points…

here is list of drivers…

all starts like this
C:\WINNT\System32\drivers…

…Cdr4_xp.sys
…Cdralw2k.sys
…cdrom.sys (with a check next to it)
…imapi.sys (with a check next to it)
…MxlW2k.sys
…pfc.sys
…pwd_2k.sys
…redbook.sys (with a check next to it)
…GEARAspiWDM.sys
…storprop.dll (with a check next to)

thats all…

please help … i have even put the original cdrom burner device back in exactly as it was before…xp still says no driver … i have no optical drive therefore i cannot run my xp system disc … my comper sees the dvd and cd rom drives ok… but it insists that there is no driver or driver is corrupt … but i got rid of virus…ran test via pcpitstop and pcdoctor…all ckecks ok …please help…i am such a computer deadhead that i have no idea … my desk top does not see any optical drive…please help


#4

Check this Microsoft knowledgebase article.