LiteON JLMS XJ-HD166S can't read many DvD's properly

vbimport

#1

Hello,
I’ve had a 166s for 1 years now, and I’m currently using DS1E firmware (I tried both official and codeking’s firmwares). I don’t why, there are many DVD’s that can’t be read properly by my 166s but can be read perfectly by my lite on 851s@832s CG5G (thx codeking :D). Recently I cleaned the lens of the drive very carefully and it did help but there are still many DVD with which I get many read errors when I try to make an disc image with a burning software. Could a lens cleaning disc like the one sold on cdfreaks help at all ? Is it a common problem with dvd drives (that are not burners) ? Generally it happens with old DvD or with DVDs with higher average PI errors but still, my burner can read them.
Any help would be greatly appreciated.


#2

Using a CDROM Cleaner CD is not recommended…using compressed air is preferred…however “cigerette” smoke can be a enemy…I have found this out since I smoke around my computer…and found a tip that works…the only drawback is you have to open the DVD ROM…but if it out of warranty…then it really doenst matter…I use a Q-Tip and lightly applied with Isopropyl Rubbing Alcohol…rubbing the ‘lazer eye’ then reverseing the Q-tip and using the clean end to wipe dry…I lost read and write functions with my Yamaha CRW-F1 and 166s but got full function after using this method.


#3

I have the same drive and I also have the same pb with some disc brand. I cannot read Ritek for example. I think this is a firmware issue


#4

I don’t smoke but I did clean the lens with a small thing used to clean the ears lol (i guess it’s a q-tip, i don’t know the translation in english sory :p) but as bichonn said it, it might well be a firmware issue :(.


#5

I also have this drive and have been experiencing problems recently. Only after updating to the ds1e firmware did i first experience problems. Im going to roll back to ds1c to see if that fixes it.

edit: i rolled back firmware to ds1c and the two dvds i was having problems with still did not read, the same dvds work fine on the pioneer 108.


#6

My first 166 died after just barely over 1 year of hard use. At the time it was the only game in town so I bought another one and so far it and a second are still going after over 6 months. I took it apart and the pickup lense was like new, I think the spindle motor died. It wouldn’t read and finally wouldn’t hardly spin up a disk and the drawer kept getting slower.


#7

mine doesnt have any mechanical problems, its only on some new dvds that it has troubles(brought within the last month). All six discs from the “Angel season 5” dvd boxset would not play at all. All older disks work fine in it. I also encountered the same problem with “under Siege”. I have played several hundred dvds without issue until i hit these snags. The drive is not alone in having problems my dvd player will not playangel season 5 properly either itjust kicks you back to the dvd player menu when played. I suspect they are playing funning bastards with the copy protection/disc structure.


#8

I believe you can take back a defective disk and get a replacement, it will tell then either their quality control is bad or the protection they added is working too well and most units can’t play it now.
Take it back, take all of them back, if it costs them enough they have to fix the problem for newer disks.


#9

This drive Sony DDU 1612 (flashed to modified XJ-HD166S firmware for 16x SL and 10x DL rip speeds) has been absolutely fantastic, nearly 2 y/o and still going strong, best £12 i have ever spent on a drive.


#10

I have had no problems with mine.


#11

The drive could be dying, i wont rule it out. The people with no problems on recent dvd’s. What chipset are you using? I never had any problems with my nforce 2 board, and i only just recently moved to nforce3, maybe its a driver issue?

Bah i suppose i could buy another liteon drive to test with :smiley:


#12

Sometimes the problem is coming from the dvd player you use.
my powerdvd 5 or 6 & other windvd version 5-up couldnt read my 6 dvds
when i unnistalled my powerdvd & windvd v.5-up And use WINDVD 4.0.11.187 PLUS
only 1 out of 6 dvd is unreadable.

like jroc told you use a Q-Tip and lightly applied with Isopropyl Rubbing Alcohol on the laser lens.
remove ur drive from the case & dont use it for 3 hours before u clean the lens to prevent moisture.

:slight_smile:


#13

Thanks for the replies :).
I already cleaned the lens, and it’s working much better, but there are still a few DvD’s the drive can’t read properly. I guess it’s the firmware.


#14

I was able to fix my problem on troublesome discs by modifying my firmware to be region free. However my pioneer 12x reader is able to read much faster than the 16x liteon dvdrom. So there is still an issue with new dvds.

Piodata 108dx
20:26:10 Average Read Rate: 11,884 KB/s (8.6x) - Maximum Read Rate: 16,584 KB/s (12.0x)
Size: 7,885,783,040 bytes

liteon 166s
20:47:23 Average Read Rate: 7,498 KB/s (5.4x) - Maximum Read Rate: 10,709 KB/s (7.7x)
Size: 7,885,783,040 bytes


#15

LITE-ON JLMS XJ-HD166S
This RPC1 and speed patch beta is based on firmware DS1C. The patches should allow 12X or 14X reading of -R, -RW, +R and +RW media, and the package also includes RPC1 versions…

http://forum.rpc1.org/dl_file.php?site=tdb1&file=HD166S.ZIP

http://codeguys.rpc1.org/firmwares/166S.DS1A-DS1C.patched-rs.rar

http://codeguys.rpc1.org/firmwares/166S.DS1E.patched-rs.rar


#16

My 166s drive with 1 year died one month ago. First it stopped reading DVD discs, although it could read CD media. After one week it stopped reading CD media too. The drive spinned up and down and never recognized the media, and it gave up. Made some cracking noises.
I’m currently waiting for a replacement (RMA), here in Portugal we have a 2-year warranty :wink: . I’m hoping to receive at least a 167T or even the 16P9S drive :smiley:


#17

This drive works fine, but I have some issue I can’t resolve:

With stock FW ds1e it is fast with pressed dvd but very slow with burnt dvds.
With Codeguys patched FW (I tried 16X, 14X and 12X) it is very fast with burnt dvds but it kind of spins up and down between 1X and 4X when I try to rip a pressed dvd. It actually rips it but the speed goes up and down very fast between 1X and 4X ???

any Ideas?


#18

I think I was just asking too much!!!
I kept the 14-8-8 CodeKing FW and now it’s just fine!


#19

I use DS1A, never had any probs, reads every DVD I put in. Once updated to DS1C but had problems with ripping CD music so downgraded again. Never tried DS1E since its is not broken, no need to try and fix.

Ron


#20

My 166s can’t read properly (after 50% of the disk), all my DVDs that I have written with my plextor 708A at 8x.These disks have excellent kprobe scan with my 1633s and can be played without any problems with the following readers:

Liteon 1633s
Pioneer 120S
Plextor 708A
Teac 16x DVDrom (I think 516 is the model)
EXCEPT my liteon 166s…(tested with DS1C and DS1E firmwares)