LiteON iHAS122 8 3L01

I purchached LiteON iHAS 122 8 two days ago. On LiteONIT site, that burner is not listed. I upload list of suported media codes.
Can someone help with that burner?
I try to cross flash to iHAS322, iHAS422 or iHAS222 but need unscrambled firmwares.
Thanks in advance.

You cannot flash a firmware that’s not made for your drive. Even if you have a “unscrambled” 222, 322, or 422 firmware, it will kill your 122 if you try to flash it. Stick with what you have.

Really or u are just kidding?

If you don’t believe me, go ahead and try it if you can find an unscrambled one. Just note that neither I nor CDFreaks will be responsible for anything wrong that could happen to the drive afterwards. And DO NOT RMA the drive either because you would’ve voided the warranty.

Even if you can crossflash to other models,

  1. you won’t gain any LightScribe capabilities of the 222 or 422 b/c the 122 has no LightScribe hardware.
  2. you may gain SmartErase feature from the 322 or 422.

If are just curious to see if it’s capable to crossflash between different models as a “fun” activity, that’s fine. But if you want to have the feature set of the particular drive, then getting that drive would’ve been a better option.

Hi all,
I have problem with my LiteON iHAS122 8
My firmware is 3L01.
I am searching for new firmware. But for now with no success… :frowning:
Can some1 help me? Tnx

[quote=delcoske;2224302]Hi all,
I have problem with my LiteON iHAS122 8
My firmware is 3L01.
I am searching for new firmware. But for now with no success… :frowning:
Can some1 help me? Tnx[/quote]

There are no new official firmwares available as yet.

What problems are you having?

thanks for your fast answer.
the problem is that my dvd-rw can`t read setup of Win Vista.(I have tried several different installation of Vista)
Installation goes normally at the start , but some error occurs sayin
" error code : 0x80070241 " and installation is aborted. I have win XP Pro now SP3, and i have tried to install from win like upgrade and from Boot menu … same problem …
I think that maybe problem is in my dvd drive and in his firmware or I am wrong?
I checked some pages on net and saw similar problems

http://keithelder.net/blog/archive/2006/11/22/Part-3-Installing-Windows-Vista-Error-code-0x80070017-Bad-X64-ISO.aspx

You can flash firmware from iHAS322 version 3L13.
Link for firmware is http://club.cdfreaks.com/f44/post-new-firmware-tool-announcements-here-148989/index11.html#post2221208

After upgrade, smart erase is working :wink:

Gratz!

can you please tell me how you flashed your liteon 122 to a 322 firmware

IHAS122 8 3L03 on my liteon

Can you make backup of the firmware and send me .bin file?

i do not now have to backup the firmware so help me:rolleyes:

How do I back up my firmware on liteon IHAS 122 8 to a binfile i got a new one 3L03 on my Ihas122 8:iagree:

Hi netfox. Use the Flash Utility in my signature to read the firmware from your drive to a BIN file.

Please post a link or send me a copy by email (see the contact page on my site). Thanks.

Okay it is don now sent on to you e-mail C0deking
3L03.bin
Liteon IHAS122 8:)

Thanks netfox! :flower: I’ll post a flasher version later today and update the patched firmware as well.