Liteon DVDRW SHW1635s unreadable burns on XBOX

This problem has got me baffled.

My Xbox (modded evo x software) will not read any data files (i.e personal photo albums) or any DVD’s (i.e my home videos) that have been burnt on the liteon . The disk just appears as ‘unknown’

The media is fine on the disk as plays in a regular DVD player or works on a PC. The disks I am using are fine as when burnt on my USB DVD burner located in my office also work fine.

The previous DVD burner in my PC (an old 1 speed thing) worked fine with the XBOX, kinda rulling out any software or hardware issues.

I have upgraded the firmware on the liteon burner with no success.

Please any help, with does include chucking the liteon drive in the bin would be most gratefull.

Thanks in advance

book type setting to DVD-ROM and closed sessions might work.

Thanks for the tip off, not solved yet but think im on the right road.

The Liteon is a DVD-RAM, booktype field being 0001.

So with this in mind im thinking my XBOX dosent understand this format.

Next Iv have to try and work out how to change this, I f possible, looking into Patched firmware at moment ??