Liteon DVD not loading disc

vbimport

#1

I have a Liteon DVD recorder. All of a sudden it shows “NO DISC” when i put ANY type of DVD or CD in it.It does register that a disc has been inserted
Any suggestions???


#2

Welcome to the forum :wink:

This seems like a either a faulty or dirty laser unit in the drive. If the drive only seems to work intermittently, such as play for a couple of minutes and then totally refuse to play anything, then the laser unit is faulty. Otherwise, if this issue came on gradually over time or it simply stopped altogether, then chances are that either dust has built up on the lens or something is covering the lens, such as a bit of lint. If the drive is less than a year old, I would recommend getting it serviced under warranty, particularly if you cannot get it to read any disc now. Otherwise, if you can manage to get the drive to play an audio disc, then try running a laser lens cleaning disc in it to see if this helps first.

If the drive is out of warranty and the drive cannot play any disc, then the only way of reviving it would be to dismantle the recorder and internal drive to get to the laser lens and clean its surface. This can be done with a cotton tip bud with an alcohol solution that does not leave a residue.


#3

LiteOn will collect and repair your recorder for upto two years after purchase by use of the serial number and as far as i know it doesn’t cost a penny!


#4

David F: do you have a link where I could find out more about this?


#5

I belive this is the lite-on sevice number 0207 3652401
you could also try firmware update from www.liteonit.com


#6

wow isnt everyone having troubles with their lite-on dvd players/recorders!!


#7

yep. everyone his wife and his dog.


#8

I have a Lite On DVD VCR recorder LVC 9016G and I am getting the “No Disc” error message also, however, my disc tray is empty but I can’t get the door open to put one in. Also I can’t switch the machine to VCR and there is a tape in it and I can’t get it to eject to get the tape out. Does anyone have any suggestions?


#9

Odd that you would have problems with eject for both tapes and discs at the same time. They do have the power supply in common which could be the problem. I can only suggest you send it in for repair.


#10

well guys, i had bought a 511ghc a year back and havent recorded one single disc. now my recorder is not reading a single disc.

had to open the cabinet and clean the lens and then it would play for a month. I dont think LITEON is a good brand to rely on.

try searching my posts. been begging around for help and couldnt solve till this day.

hope you all have good time with this player…


#11

Liteon has major problems the dives in it’s standalone recorders that are defective or fail after 3-9 weeks of use. Serviced units work for some time then also suffer from the same problem.

Common problems are:
Failure to read or prep discs
Failure to read unfinalized discs after being ejected
Failure to Stop
Write Failure
Will not finalize

I many cases the owner can replace the drive. I have done 3 replacements on my LVW 5005s.


#12

My 5005 recorder failed after just 6 months; it would display “Insert Disk” even after disk of any type was inserted. After reading several posts where users had failure again after just another few months use after RMA to LiteOn which took a number of weeks, I decided to replace the optical drive in the 5005. Considering the wait, cost to RMA, possibility of repeated failure and inexpensive cost of a LiteOn SHM-165P6S I opted to replace the 5005 drive instead of risky RMA results. The SHW-160P6S is another good replacement choice too, but I had difficulty finding it.


#13

Hello, I am new to this and was wondering why i am having a problem burning. As soon as I load the discs it tells me to " No media inserted". My burner is a Lite On dvdrw lh-18a1p gloc.


#14

Sigh I could get my burner to eject as long as I had a disc in it…and then I tried to reinstall the firmware and had to take the disc out. Well at least it keeps me from having a hole in my tower.
Lite on DVD RW LH-18A1P


#15

[QUOTE=msj2038;1316392]I have a Liteon DVD recorder. All of a sudden it shows “NO DISC” when i put ANY type of DVD or CD in it.It does register that a disc has been inserted
Any suggestions???[/QUOTE]
Would this also apply if when trying to prepare a disc for recording I keep getting “Invalid Disc”? The manual reccommends DVD+R/+RW; DVD-R/-RW; DVD+R DL. I’ve tried them all and keep getting the same message. Any suggestions?