Liteon DVD drive not recognized by XP

:a Arrghh… almost 5 hours searching …trying… My Liteon SOHW-1693S burner gets recognized in BIOS but not in XP. I’ve tried it with my Liteon CD recorder as Master, Slave, by itself on IDE1 and as slave to my HD on IDE0 to no avail. I’ve deleted upperfilters and lowerfilters from the registry… nothing. I can boot from it and under Linux, both CD (slave) and the DVD (master) are recognized, so I know its got to be my XP installation specific issue.

I’m at wits end. Any / all help is greatly appreciated!



It doesn’t show up AT ALL? Or is it just showing up as “generic CD/DVD drive” or some such?

It might be a XP User problem. Try and go to the other user side of XP and see if its recognized.

Does not show up at all - no icon / no drive letter. I even tried to get XP to look at where the drive is (at a command prompt - “F:”) no luck. XP will not see this drive - everything around it - but not this one. Currently, I have on IDE0 (1) 80G HD jumpered as “MASTER no SLAVE present”, on IDE1 I have the DVD drive jumpered as “MASTER” and a CD drive jumpered as “SLAVE”. XP shows icons and drive assignments for “Hard Disk Drives” as DRIVE C and DRIVE D (D is not accessable as it is a Linux partition - there is no info about space used and available) and the “Removable Storage Devices” as FLOPPY A and the CD as DRIVE E.


Hmm - I just booted into safe mode as ADMIN (the only other user) and it saw the new hardware & installed it. It didn’t do that before (but may have been configured as a slave or some other way it didn’t like at the time)… So, now I guess I have to figure out how to find out what is different about MY account that prevents it from being detected. Any ideas??



i’m having this exact same problem. nothing i have tried can get xp to recognize my dvd or cdrw drive. here are the things i’ve tried -

1)update the drivers. this i found to be an impossible task because nothing on my computer can detect the drives and liteon seems to have all of their tech support pages in chinese.

2)going to device manager and uninstalling the drives and rebooting. the problem with this was that even device manager can’t find the drives.

3)opening regedit and deleting the upperfilters and lowerfilters of the cd/dvd keys and then rebooting. i didn’t have upperfilters so i just deleted the lowerfilters. i rebooted but still nothing.

4)opening setup before windows loads and setting all drive detections to automatic. they were already all on automatic. so this resulted in nothing.

5)system restore. except there are no system restore points to choose from. oh well.

i’m running windows xp w/service pack 2. i have an athlon2500xp with 512mb ram. the dvd and cdrw drives that are missing are manufactured by liteon.

i’m at the end of my options here. does anyone here please have any other ideas on how i could fix this frustrating problem before i just reinstall windows? thanks in advance.

I have a similar problem: my CD/DVDW drive is not recognized in My Computer. The device manager shows the drive with this message: “Windows successfully loaded the devise driver for this hardware but cannot find the hardware device. Code 41.” Then a Microsoft Virtual C++ box pops up saying “Runtime Error-- DISCover.exe The application has requested the Runtime to terminate it in an unusual way.”

System Restore works if I select a restore point earlier than February 14, 2007. Then the drive is recognized and works. If I allow Windows Update to run, then the problem returns. What was maddening was windows update running automatically and creating the same problem again. Even if I turn off automatic update today, when I restore to Feb 13, 2007, as of that date automatic update is enabled, and starts running upon start up. If I reboot, I lose the CD/DVD drive. I have disabled automatic update, which means doing without the security updates of Feb. 13, 2007.

I have also tried using add/remove software, clicking the checkbox, to remove the Windows updates since Feb 13, 2007, one by one. There were nine of them. A reboot after each removal, but still no luck in seeing the drive. The Add/remove tool shows no other software changes since that time.

A search for a driver says the driver is up to date. Choosing revert driver says there was no previous driver to revert to.

This unit is a HP Compaq running Windows XP SP2-Media Center.

I want to try this next:

Will also try removing DISCover.exe

Try deleting your upper/lower filters as per the link in my sig - that should help with the Code 41 problem.

As for DISCover.exe, a Google search shows that is something to do with DISCover Drop from Digital Interactive Systems Corporation - might help when working out what to uninstall :slight_smile:

I am having the same issue only worse.

I installed the drive and turned on the computer. It recognized New Hardware, and thought about it for a while, then said the hardware may not be working properly. So I restarted to see if it would fix itself, THEN both of my DVD drives disappeared. Both didn’t show up in the device manager. I unplugged the new one to see if the old one showed up again, and it did just fine, but as soon as I plugged the new one back in they both disappeared again. I even when into the BIOS setup to look for them and both were not listed.

I don’t know what to do. I don’t have any other users on my PC and am not sure how to sign in as admin like Steve did.



OK so I was reading other peoples posts about DVD drives not working and so I started playing around and found that if I go to the device manager and click on action, scan for hardware changes, I can get my windows to find the new Lite-on drive and it shows up in the device manager for a second and then it says it may not be working properly until I reboot, well I already know now that when I reboot the drive is gone, so if that gives anyone any clues. I sure don’t know what to do.



HA HA!!!

Good News ALL!!!
I solved the problem myself.
The Lite on Drive had the Drive Jumper set to Slave and i had put it into the master slot, so I switched the drives and whoopee they both work just fine. I feel like such a genius. :slight_smile:

IF you ahve similar issues look at the Drive jumper Setting to make sure you have the drives put into the right slot.