Liteon DH4O1S Firmware problem

vbimport

#1

Hi,

I have a two month old Liteon DH4O1S BD-Rom and I can’t get it to upgrade the firmware.

I have download two different firmwares from Liteon support that are both .exe files. One is CP54.exe and the other is 2P53.exe.

Whenever I run either I get:

No matched drive detected!
This utility is for ATAPI BD O DH4O1S drive.

Detected drives:

4-0-1-0 J:SATA ATAPI BD O D CP51

I have tryed this in safe mode and without any other optical drives plugged in.

I pulled the drive to verify that it is a DH4O1S - it is.

I have contacted Liteon support only to have them tell me that the only time an error like that happens is if I have the latest firmware (that doesn’t sound right to me).

Also, I have two BD movies (both Warner Bros, The Road Warrior and The Cowboys) that aren’t recongnized by the drive. I don’t know if they worked before as they are both Netflix rentals. I have had other BD movies work fine (also, Netflix rentals so I don’t have them anymore).

I also tried the Fimware Flasher from RCP1.org and it errors when I try to use the Liteon downloaded file saying there isn’t a properly formated firmware file.

Any help?


#2

CP54 should work, but the SATA controller used is important!!!

Try in SAFE MODE.


#3

The first character of the firmware revision has to match, so you can only use firmwares starting with ‘C’.


#4

Changing to a different SATA controller did the trick!!!

I have flashed to CP54 and the movies now play.

Thanks for the great help.