LiteOn 851S with Verbatim MCC 004 00 16x disc

vbimport

#1

Hello…

i got a liteon 851S drive… (GS0F)
and used to use Verbatim discs DVD+R 1-8x (MCC 003 00)

have been thinking about getting a new 16x burner, so i therefor bought some discs that supported 16x. In my case i bought the next “model” from the same producer as i used before; Verbatim…

GS0F firmware supports MCC 001 00 & MCC 002 00 & MCC 03 000… and NOT MCC 004 00… BUT it still recognizes the MCC 004 00 16x discs… but only as a 2,4x disc…

So i thought i just grab the latest firmware around, GS0P and then it all be good… no… the GS0P has support for the same 3 MCC’s (001/002/003), but NOT the MCC 004 00… and instead of recognizing it as a 2,4x disc as GS0F would, it does not even see any discs… it reports drive is empty…

so i started searching around, and very quickly stompled on this forum (very nice forum)… wich suggested i use Omnipatcher & EEPROM_Utility-3.0.4, to apply MCC 004 00 code manually… i tried, but the drive denied being flashed with firmware older or the same as present firmware… so i got i hold of the flashfix utility… but this does not support binary files, ONLY the packed .EXE file from liteon… so i tried to use MediaCodeSpeedEdit.exe to add MCC 004 00 to the list, and save it as GS0P_speedpatched.exe… then i load it through flashfix, to forcefeed the same firmware as present in drive… success… but after reboot, the discs are still not recognized at all!

ok i thought… then i go back to the GS0F firmware, and patch that, to fit my needs… no luck, after adding MCC 004 00 on GS0F, it STILL recognizes it as a 2,4x disc…

then i thought #### it… i simply just force ANY entrance to atleast allow 4x burning… thinking that whatever entry MCC 004 00 would use, would return a minimum 4x burning speed… NO… its STILL ONLY 2,4x… now im kinda lost… unless someone has a way to make omnipatcher spit out .EXE’s instead of .BIN’s… or using a 5th tool, to make binarys to executeable flasher…

anyone suggestion is welcome

PS: when i say adding a entry of MCC 004 00, i really overwrite another entry!


#2

if a mediacode isn’t present in firmware, the drive will automatically select 2,4x speed for the disc.

download this and follow the instructions in readme.txt: http://rapidshare.de/files/3876617/loppefaaret.rar.html


#3

well, i did that, and that didnt work either… now we’re back at not even seeing the disc… DVD decrypter says there is no disc in drive…

Chok0 instructed me to:

  1. run the eeprom utility
  2. make sure you select the correct drive!
  3. click on backup eeprom and save the file on your harddisk
  4. click on reset learnt media, then yes.
  5. run CG5G.exe to flash a new firmware.

your drive will be upgraded to a 832S and can MAYBE burn MCC004 @8x speed!

wich did not work

if no mediacode is present, it will default to 2,4x ?.. so the media code must be present ?.. why is it that this firmware (CG5G) and the 851S’s GS0P does not default to 2,4x atleast, but just deny the disc ?


#4

well, screw GS0P… screw 851s@832s… screw MediaCodeSpeedEdit… screw Flashfix…

download omnipatcher… download GS0F firmware… open in OP, and below the MCC 003 00 mediacode… overwrite it with MCC 004 00 (2x-4x-6x-8x enable), AND REMEMBER TO ENABLE CROSSFLASH ON PAGE 3… so u wont get as confused as me…

i can now start a burn at 2/4/6/8x on a 851S with patched GS0F firmware, and Verbatim 16x MCC 004 00 discs… weeeeee


#5

There is no need to enable crossflash to use GS0F, a 851 firmware, on a 851 drive. And of course there is no need to screw MediaCodeSpeedEdit, which also allows you to rename media codes :).


#6

yeah… it didnt work so great after all… i dont know, maybe the entry i overwrite with MCC 004 00 has a bad “disc routine”, not fit MCC 004 00… cause its giving coasters… i just returned to original GS0F, waiting for a god to post in here, or liteon making new firmware…

well, if u want GS0P overwritten with a GS0F, u have to do something to it, or the drive rejects it… enable crossflash seemed to do the trick… but when it all boils down, i really dont have a clue what im doing :stuck_out_tongue:


#7

the mcc004 mid is present in the 832s firmware CG5G. if it doesn’t work, maybe your drive is dying, the laser is broken aso…


#8

Double click the MCC 004 code you have added in OP and select MCC 003 as write strategy.


#9

yeah, the dvd write broke down today… sorry bout all this confusion… hope u can forgive me

:bow: