Liteon 52A8S, SATA CDRW drive

We came into posession of one of these “experimental” CDRW drives and thought it might be interesting to have a look at it and share our findings with the forum.

Our best information at this time is that this drive will not be released any time soon. It was under development for a large OEM customer of LiteOn, who decided they were not interested in the drive. So if LiteOn does release it, it will be probably sometime in 2005. LiteOn does not have any firm plans at present for any other SATA drives that we know of. As long as there are IDE ports on motherboards, there’s not much demand for this drive.

So this drive is mainly just a novelty at this time. But it may give a clue or 2 about the direction we can expect CDRW to be headed.
The drive’s model number seems to be similar to the recently announced SOHR-5238S which is slated to replace the revered 52327S burner. However we have other info that suggests the 52A8S may have a different chipset than the 5238S. Untill we can open up a 5238S and look inside, we cannot know.

The first thing that becomes obvious with this drive is that SATA controllers do not like it. :sad: Our source of info tells us that it seems to work very well with chipset-based SATA controllers, and not very well with PCI-based controllers. I have an onboard SIL-3112 controller (PCI-based) and also a SIIG PCI SATA controller card (also SIL-3112 chip). The drive will run on both of these controllers, but there are deffinite problems with firmware flashing and Kprobe scanning. I was able to flash firmware on the SIIG card, but not on the onboard controller.

Kprobe causes the entire PCI bus to freeze up if you try to access the drive, not a pleasant experience. LtnFW will read the firmware on either controller, but not write F/W except on the SIIG card. Whether these issues are due to drivers or BIOS on the controllers is anyone’s guess.

Another observation about the SIIG controller:
Here’s a reading curve at full speed on the SIIG card;

What’s interesting is that the drive did not actually slow down during this read, and the disc was a near-perfect CDR. So there appears to be some very strange bottleneck for data that is looking like a drive slow-down. Confirmed this oddity in DVDInfo:
also, I was getting very high CPU usage readings on the SIIG card, running upwards of 40% but only in CDSPeed, not on my system monitor.

So, I decided to put the drive on the onboard controller and here’s the result: (much better)

Again, this is the exact same SATA chip, with slightly different BIOS. I tried a number of different versions of drivers on the controller, even the driver form the SIIG card, but could not resolve the issues with the LiteOn utilities.

I noted that on the OB controller, CPU usage is reported as normal, and burst rate measurement went from 8 on the SIIG card to 19 on the OB controller.

I contacted SIIG support and was told that they have no interest in supporting optical drives, and so would not comment on this issues I see.

So the conclusion for all this is that in the near future, do not expect SATA controllers to support any optical drives, except the chipset-based controllers, and then only the Intel chip has been confirmed to work.
The drive does finction very well though, on my OB ports, as far as reading and burning is concerned.

Many of the available tests in CDSpeed do not function, but those that do work are shown here.

Let’s look at some basic burning tests. All error scans are done in my 52327S drive because the SATA drive does not work in Kprobe.
All scans are at 52x

CMC 48x burned at 52x. The drive slows to 40x CAV at about 60% of the burn.

Not as good as many other drives, but we’ve all seen worse on CMC media.

Ritek 48x burned at 52x, no slow-down:

Again not great, but certainly a functional disc.

TY 48x burned at 52x, no slow-down.

Keeping in mind that this is an exoerimental drive with early firmware, these scans are not too bad. I have noted an irregular burning glitch that for some reason causes the drive to burn at low laser power at 40x. The resulting disc is only readable for the first 20 min or so, and looks like it has not been burned at all. This only occurs randomly and is unpredictable. I write that off to the fact that the drive appears to be hand-assembled to some extent and has been knocked around a bit.

This burner takes a new, or should I say old, approach to RW burning. Namely Z-CLV. Here’s a 24x US RW disc burn:

And here’s a 32x US RW burn:

This is an error scan of the 24x US RW media:

And here’s the 32x US RW disc:

Not very far off of what I would expect from RW media, in fact it is very similar to my 52327S on the same media.

Clearly the available hardware is not ready for SATA optical drives, and the best hope for compatability is the chipset-based SATA controllers. Until a large OEM customer decides to build an all-SATA computer, there’s not likely to be any development on these burners (or on the controllers either).

But apart from the compatability issues with the controllers, this drive seems to perform as well or better than some other PATA burners I’ve seen. I’d love to see some firmware refinement, but that isn’t going to happen, as development has stopped for now.
I’m using the drive for occasional reading and burning, it rips audio at full speed with no errors, and burns my TY media very nicely.

Here are a few photos of the unit, thoughtfully supplied by dhc014

Thanks for the info rdgrimes and dhc014!

Tnx for sharing infos !

One question, rdgrimes, do you remember how long the dvd speed data rate test did last with 52x ?

Originally posted by Crockett
[B]Tnx for sharing infos !

One question, rdgrimes, do you remember how long the dvd speed data rate test did last with 52x ? [/B]

About as fast as a CD drive can get!

OMG! This thing is really fast :eek: :bow:

tnx!

Too bad the current incarnation of the Intel ICH5R only has 2 ports and a lot of folks are running a RAID array off it.

Woa, neato…

Nice speed too :slight_smile:

Also posted on our newspage.

Thanks, but no thanks. I’ll stick with my Premium, it may be using a fat ol’ IDE cable, but quality is better, and it works 100%. This thing may be bloody fast (I love that.) but no KProbe ruins the use of having a Lite-On, and the quality doesn’t even compare to my Premium, whereas the LTR-52327S can. Hopefully we won’t be seeing this problem on the PX-712SA. How long have you had this drive?

Slashdot discussions. :slight_smile:

sees that this thread already has 10K views in so short a time… looks like a /. effect to me, alright…

Originally posted by code65536
sees that this thread already has 10K views in so short a time… looks like a /. effect to me, alright…

also hardocp

There may be 10K views, but not too many posts still…

Originally posted by Sorondil
also hardocp

Yeah, it was up on their homepage too.

The flashing problem with Silicon Image controllers is fixed! :slight_smile:

tease :frowning:

explanation?

@ Dave
There seems to be some confusion. Our source tells me that the reason that the new flashing tool works is because the drive cannot accept data with length larger than 0x1000. So he has re-designed the flash tool with data length of 0x800.

I confirmed that it does indeed flash with this new tool. But I also re-confirmed that it will flash just fine on my PCI card using the old flash tool. So it seems there is something more than just the drive working against the flashing tool.

I tried the OEM firmware, and Kprobe still hangs at the pit/wob switch.