Liteon 5045 still stuck after failed firmware upgrade, HELP anybody!

Hi there,

Found lots of information here on Liteon 5045 and upgrading firmware etc…
I have bought a Liteon 5045 very recently and wanted to upgrade to the latest firmware as i have read a lot about problems with earlier FW versions.

Problem is now however that something went wrong in this upgrade (maybe I guess misunderstood the message upon upgrade on the TV screen and have disconnected the power, but on the other hand I was waiting forever for the CD to come out with the tray).
Now the only thing the setup says is HELLO, and then the TV set screen stays very black… :eek:

Is there any solutions here to get the system up again (other than calling Liteon support and yes they are away over christmas right now)? Are there other ways to get the FW on the chipset once this problem occurs?

Best regards and merry christmas!

xs4me2

p.s. comes in mind a very wise remark now: “dont fix it if it aint broken”

sigh… :o

The unit probably defaulted to the component video output (i.e., RCA plugs) after the firmware upgrade (this is common). I use S-Video, and have to plug in the RCA cable to the unit and TV to see anything after a firmware upgrade.

Hi and thanks for the reply, dont seem to have a TV that can take the component video, can i feed it somehow into a scartplug?

Not sure if this will work though as I tried this vaia an adaptor plug i had
here, zero result…

Your comments please!!!

Hi there,

Havent solved the problem yet and the only reply to my question didnt work out either. Emails and even phonecalls with liteon where also NOT very helpfull
to say the least…

IS THERE ANYBODY THAT HAS USEFULL INFO TO GET THIS BEAST UP AGAIN???

HELP PLEASE!!!

Best regards,

JC

Edit: Removed duplicate content

(I merged your new thread post with this last thread you started, since this forum has a policy against cross-posting)

As the player is stuck at ‘HELLO’, it is a clear sign that its loaded firmware is damaged. There are several things that may have resulted in this, such as if the disc did not write correctly, the firmware file itself was damaged, etc. When downloading firmware, do not use any sort of download accelerator and also avoid using a proxy if possible (if your browser uses one). If a proxy based connection is lost, the browser will automatically show ‘Download complete’, even if only a partial download has taken place. When burning the firmware disc, make sure verification is enabled as this will make sure what is written to the disc matches the source exactly.

If you are lucky, the DVD recorder may have a recovery mode where if it detects a firmware disc in the drive upon powering up, it will attempt to load this. However, this also assumes you can eject the tray. If you can get the tray to eject, first re-download the firmware, burn this to another CD with verification enabled, pop this into the recorder, switch it off, then try powering it back up and see if anything shows on the screen besides ‘HELLO’ or if anything else happens over the next couple of minutes.

If your DVD recorder cannot eject its tray, it would be worth holding down the recorder’s ‘Power’, ‘Eject’, etc. buttons for several seconds while plugging in the DVD recorder. Unfortunately, if there is no way of ejecting the tray or getting the player to recognise a firmware disc, you will need to get it sent back for repair, since the actual Flash chip may need to be removed and programmed directly, something that can only do with specialised equipment.

Assuming you were not trying to load a modified firmware, you should be able to get your recorder repaired or replaced under warranty, assuming you bought it within the past year. The best thing to mention to the store is that the recorder will no longer turn on, as it will be easy enough for them to check. Don’t mention anything about firmware update unless they ask. Then again, as there is nothing stating that a user cannot do their own firmware update, this shouldn’t void the warranty, although this is less likely the case if you have used modified firmware and they discover this.