LiteOn 5005 won't read firmware CDs

vbimport

#1

I’m sure this has been covered somewhere, but my searches did not find what I needed. I can’t seem to burn a CD that my 5005 will read to update the firmware.

Can someone tell me what I’m doing wrong. Here is what I have tried.

1). Download the appropriate FW from the Liteon site and unzip it.
2). Launch Nero (I use version 5.5.9.2 Nero Burning ROM).
3). Select New CD-ROM (ISO)
4). Under the ISO tab only the following are selected:ISO 9660, Mode 1, ISO Level 1.
5). Under BURN tab “Write” is selected. Finalize CD is not selected (Should it be?)
6). Under Multisession tab - “Start Multisession disk” is selected. (Should it be “No Multisession” instead?)
7). I click on new, find the unzipped file and drag it over to ISO1 CD icon.
8). Place a blank CD in the drive, Select File|Write CD, and then click on the “Write” button.

The CD burns, I place it in the 5005. Turn power off, turn power back on, it finds a data disk, but it opens the tray and I never get the “firmware update” menu selections. Sometimes I get a “square block” in the left hand side of the display after it finds a data disk.

I have double checked my serial number and have made four different disks from new downloads from Liteon. I was concerned that the original download may have been corrupted or something.

I would appreciate any advice as I want to eventually install hacked firmware so I can get 3 hr mode and MV protection removed. But until I’m sure I can get the firmware upgraded safely, I don’t want to try ILO Hacker.

Thanks for any advice. :confused:


#2

Some obvious points:

  1. make sure you have uncompressed the correct firmware files by Winzip or Winrar

  2. make sure you didn’t change the name of the firmware

  3. make sure only one firmware on each CD

  4. you could use good quality CDR or CDRW and verify the write (there is a check box once you start burning under Nero.

  5. you should use single session, although I don’t think it makes a difference

  6. Option under LWV 5005 for reset to default factory setting might help in the update.

  7. Sometimes just power off the 5005 and start over may help or even just remove the CD upgrade and re-insert the CD and let it read again may help.


#3

Thanks for the response. I have done or tried all of the above. I have noticed that some folks recommend finalizing the CD rather then burning as a multisession disk with only 1 session on it. Is there a way to finalize a disk “after the fact” with Nero?


#4

when using nero the software (whether in multisession or single session) will always close the session, if using a CDRW don’t use incd as the disk needs the CDFS software to mount and the liteon has no access to this software but you can use CDRWs just don’t let the PC format the disk.

It should work, I had one that wouldn’t take the drive update or rather it took one update but the new serial for the drive revealed a new update for the drive firmware, confused I was so I just left it.


#5

Thanks nickKK. From what I can gather others are also having problems with updates not being read and loaded by the 5005. I have found several threads that refer to the 5005 identiying a Data Disk and then nothing. I still haven’t gotten it to “take”. My internal S/N does not have a drive firmware update, only a general system update. So I don’t have some of the problems others have written about with the drive update not working.

Not sure what to try next. I realize I should not use InCD if using a CDRW with the 5005. I thought I might try the CDRW to get a totally different media in play. Can you use DVD+R or DVD+RW disks for firmware updates as well. I would assume so.

Any other advice on what to do?


#6

unwired

Try both the system restore/reset and make sure the source (tuner, av1, av2, s-video, etc.) is set to DVD. I have had success with single session, multisession, finalized and unfinalized discs. It sounds like you are creating the disc properly.


#7

unwired, I had the same problem. I tried to update the firmware but kept getting data disk and no firmware update on the lcd screen of the 5005 or the tv. I tried it with two different cd’s with the modded firmware on it. I shut the machine off with the cd in it. The next day I powered my 5005 on with the cd in it from the night before and got the f-up on the lcd screen and the firmware update screen on the tv. I hit ok and everything went fine. In my other post where I explained what happened I called it “gremlins”.


#8

Thanks jm1647:

I finally got it to work. I did a system restore as Guitarman1 suggested and then tried the CD. No go. So with the CD in the tray I turned off the power and unplugged the unit. I plugged it back in and turned it on. Lo and behold it read the CD and updated the FW. So this is similar to your suggestion. Strangest thing I have ever encountered. I have flashed many computer BIOSes with no issue, but flashing the firmware in this thing is touchy at best.

Thanks to all for your help.


#9

unwired, you are now a 5005 gremlin buster!

The ilohacker program by Mr, Wizard works great for 3 hr, region free and no macrovision.

It was my pleasure.


#10

Another possible way to get the firmware cd recognized:

I just had to hack the 0098 stock firmware to do a backup of my DVD that my PC based burner would not copy due to CFC errors. The DVD looked like it was in a cat fight. So I put it in my trusty Apex and tried to record it to my 5005 with the unmodded 0098 f/w. I got the dreaded protected content message.

So the hacked firmware went on a cd and I tried to do the update. No go, data disk every time. I unplugged it with the cd in and waited. Powered it on no go still. Data Disk. I did not wait over night like the last time and tried a few times waiting like 15 minutes. All no go.

I tried doing a restore to defaults with the cd in it and bingo, it did not hesitate a millisecond and took the update on reboot.

Might work for somebody else too.