Liteon 32123s firmware prob

vbimport

#1

bought the drive and everything went fine, but after upgrading to XS0U shit happens. clonyXXL only reads to 25% of a cd, can't read many cd's anyway (explorer), writing seems to be correct so far. back flashed to XS0f, works a little bit better, but same prob as before!

plz help me

maybe there's a firmware existing before XS0f
...


#2

1: it’s something wrong with your system.
2: it’s something wrong with the drive

I doubt the firmware will cause problems like this since it is working for everybody else.

How is it connected? (Primary slave? secondary master? secondary slave?..)
What OS are you running?
What chipset do your mobo have?
What IDE drivers are you using?
Is DMA enabled?
What ASPI layer are you using?
Any packet writing softwares or CD-ROM emulators installed?


#3
  1. my system has no conflicts or anything like that but maybe it’s a prob with the system anyway
  2. the drive worked perfect before firmware (and OS) update
  3. secondary slave (sec master: NEC DVD)
  4. After fw upgrade WinXP german final (before fw upgrade WinXP english devilsown)
  5. Asus K7V - KX133 chipset
  6. VIA Bus Master Driver 4.38a
  7. DMA could be the problem, my setting for the secondary IDE Channel (drive 0,1) is “DMA, if available” - device 0 (NEC DVD) is using Ultra-DMA-Mode 2 but device 1 (Lite-On CDRW) is using PIO-Mode - don’t know why!
  8. ASPI 4.6
  9. No packet writing software or cdrom emu

thx in advance, plz help me


#4

Some times you may get problems like that when DMA is not enabled.

Try to swap the NEC DVD and the Lite-On. Any change?


#5

I would suspect a problem with the OS over the firmware…


#6

just curios!

changed CDRW and DVD - Master and Slave

and everything worked fine

seems that the german winxp prof version has probs with the Liteon drive

shit thx to all you guys

fast and accurate help