LiteOn 24102B Dead - flash prob?

vbimport

#1

I need a bit of help.

I think my LiteOn 24102B has been zapped by an electricity spike.
My PC's BIOS cannot see the drive and it wont respond to the front open/close button.
The green LED is constantly ON whilst power is put to the drive.

I thought that maybe the flash has been killed and that I may be able to re-flash it. I tried the LiteOn windows flash - but it couldn't see the drive.

I used the forum, and found reference to a flash util called MTKFLASH and firmware files.

But I can't find them!!!!

Can somebody point me in the correct direction please?

Also, does it matter what IDE channel the drive is on ?

Thanks for any help given...... :bow:


#2

it is in the lite-on forum

http://club.cdfreaks.com/showthread.php?s=&threadid=42502


#3

Just take it easy ! It’s not over yet and the drive’s not dead.

All you need to do is to use the famous Jumper trick .
A picture of it is among the OC- Freak’s firmware stuff.

A bootable diskette. Add mtkflash and a .bin file for your drive there .
Put a jumper on the pins as it is on the picture and then just go through the same old flashing procedure ( as you know it or as it’s described here @ LiteOn Forum . You’re given the link there ).

If you are still confused, don’t hesitate to mail me and I’ll try to help you with that.

Just calm down first ! :wink:


#4

Well I found the MTKFLASH proggy and the .bin file (5s5a.bin).
I had a win98 boot disk.
I put the MTKFLASH exe and the bin file onto my C drive (fat32).

Used the boot floppy, ran the backup comand - worked OK, created a file 512k long (which puzzled me because the new firmware was 256k - maybe someone can explain why!!!??).

I did NOT reboot at this point - should I have ?

I tried the WRITE to flash command, lots of message whizzed past but the last few screens were FAIL messages.

I rebooted my PC and the LiteOn drive booted up OK this time, and could read CDs.

Great I thought - so I put all the kit back inside the case and screwed it shut.
Rebooted the PC - SAME PROBLEM - the LiteOn drive was stuck again!!! button not responding - BIOS can’t see it!!!

In the end I opened up my PC (again) and tried all sorts of stuff, to no avail.
I then thought about what I had done the first time it started working - the only thing was NOT have the drive powered up for 30 minutes.

I powered down my PC and unplugged from the mains power.
After 10 minutes a powered all back up and the drive worked OK, I went into windows and successfully burned a CD!!!

Very weird.:eek:

I haven’t powered off my PC since then, hehe, has ANYBODY heard of this before ???

Thanx for the replies by the way guys.
(Although I found out that the jumper trick is for earlier models only!)


#5

(Although I found out that the jumper trick is for earlier models only!)

LOL ! Who told you this ?!
It worked just fine with my 40125S. And I know another person, a member of this site, who did this thing as well.
About a month ago or so I sent OC-Freak a picture of the jumper working with the latest models, but I guess he had forgotten to display it among the firmware stuff when he got it .
Well, that’s it !

But I’m glad you’ve fixed it :wink:


#6

Thanks for the help.
I powered on my PC just now (after coming home from work) and the drive seems to be working OK.

Weird.

I wonder if it is something silly, like a loose connection?
But the download of flash worked - so it can’t have been a loose connection.

Weird again.

:wink:


#7

The LTR-24102B had problems like this with some crap quality mainboards (especially abit mainboards:Z) you may have ran into such problems.

If you disconnect the computer from the wall or the computer looses the power the problem may re-appear.


#8

Hmmmm, well I do have an Abit mobo (KG7).

Maybe I should save up to buy a new one?
How about an Asus?


#9

I’ve only good experiences with Asus and MSI (Microstar).

Abit and shuttle boards: :Z :Z :Z