LiteOn 20x drives cannot perform Full Erase on 4x DVD+RW media?

vbimport

#1

I just discovered a problem today with the LiteOn LH-20A1P and I have been investigating further with help from geno888 and Dee-27 who both have the same drive.

The preliminiary conclusion is, that the LiteOn LH-20A1P cannot perform a Full Erase on 4x DVD+RW media with KL0G firmware.
When a Full Erase is attempted with ImgBurn 2.3.0.0 the following errors are logged:

W 01:15:47 Potential ‘WaitImmediateIO’ Deferred Error - (0/4) - Session Fixation Error
E 01:15:51 Failed to Erase Disc - Session Fixation Error
E 01:15:51 Operation Failed! - Duration: 00:00:17
When a Full Erase is attempted with Nero CD-DVD Speed 4.7.5.0 the application simply hangs at 0% but no erasing is taking place.

What are the limitations of this problem?

  • Firmwares KL05 and KL0A don’t seem to have this problem.

  • CD-RW, DVD-RW and DVD-RAM media don’t seem to have this problem.

  • 8x rated DVD+RW media don’t seem to have this problem (three types tested).

What media types were tested and shown to exhibit this problem?

  • Verbatim 4x DVD+RW (MKM A02) has the problem (tested by DrageMester).

  • Philips 4x DVD+RW (PHILIPS 041) has the problem (tested by geno888).

  • Ricoh 4x DVD+RW (RICOHJPNW11) has this problem (tested by DrageMester).

The extent of our testing is not such that we can definitely say that the problem exists for all 4x DVD+RW media with KL0G firmware, nor can we definitely say that it doesn’t exist with any other firmware for this drive or with any other media types.

Please post your experiences with performing Full Erase (not Quick Erase) with this family of drives (16A7S, 16W1P, 18A1P/H/S, 20A1P/H/S) and different firmware, so that we can find the extent of the problem.


#2

Yes, I am confirming this problem with my LH-20A1H drive (FW LL0A-patched-eos-fb) and using RICOHJPN W11 001. I tried to fully erase it with Nero CD-DVD Speed and it froze. The disc appeared to be blank after that, but a try to burn on it was unsuccessful. I had to quickly erase it to be able to use it again.
EDIT: Damn, still having problems using this disc. Looks like quick erase didn’t do the job.




#3

These all stock f/w’s? None of C0deKings magical f/w’s involved :wink: I doubt his tweek f/w’s would matter anyway :slight_smile:


#4

I am using CodeKing’s FW and I’m having the problem too.


#5

I’m using C0deKings KL0G eb-eos.
I just tried with one of my RICOHJPNW11 and i can do a Quick Erase but a Full Erase is a no go using my LH-20A1P.
I can use Format with Quick and Full checked.

All these tests were performed with Nero CD-DVD Speed v4.7.5.0.
I don’t have ImgBurn loaded on this install yet.

To clarify: I can confirm/reproduce the problem using a RICOHJPNW11 with my LH-20A1P using C0deKings KL0G eb-eos.

If i remember i’ll flash around tomorrow and check the other f/w’s. I always try to help when i can.


#6

LH-18A1H perform Full Erase
Verbatim 4x DVD+RW (MKM A02)
Stock firmware
HL05 = no problem
HL06 = no problem
HL07 = no problem


#7

No problem here with RICOHJPN_W11 DVD+RW media and KL0G firmware… :slight_smile:
Attaching pics of full erase tests with ImgBurn 2.3.0.0 and CD/DVD Speed 4.7.5.0 (latest not a “full” disc erase, aborted by me).
.




#8

LH-18A1P, GL0G (stock)
I have no problem with full erase of DVD+RW (MKM A02) in ImgBurn and CD-Speed.


#9

OK. Thanks! :slight_smile:

We used stock firmware, yes.

Since flashing with unofficial firmware voids the warranty, I like to test my drive with stock firmware to make sure it works before voiding the warranty, and others use the same precaution.

OK. That would be great, thanks! :slight_smile:

Thanks for testing. :slight_smile:

Thanks for the test. :slight_smile:

It seems that figuring out this problem is more complicated than I thought. :confused:

Do you know the production month of your drive? Mine is December 2006.

Thanks. :slight_smile:


#10

Mine is September 2006, IIRC. :slight_smile:
Originally a LH-18A1P.


#11

My LiteOn LH-20A1P also doesn’t format (full) RICOHJPNW11 at all with the latest Nero CD-DVD Speed.


#12

Which firmware?


#13

I can confirm for LH-20A1P. I only have Verbatim and Philips DVD+RW at 4x - both failed with new firmware. I can’t quick OR full erase. I also can’t format brand new media from a spindle. I had to flash back to previous firmware. I informed LiteOn but no reply.


#14

Interesting that LH-18A1P do work when flashed to 20x firmware while LH-20A1X don’t :eek:


#15

KL0G


#16

My crossflashed LH-20A1H LL0A works fine with Philips 041 DVD+RW


#17

Was it crossflashed from an LH-18A1H?


#18

Yes. I’m testing now a RITEK 004 DVD+RW and it works also.


#19

LH-20A1P KL05 stock (my original dump f/w) works fine with Nero CD-DVD Speed 4.5.7.0 for Full Erase using RICOHJPNW11.


#20

LH-20A1P KL0A stock works fine with Nero CD-DVD Speed 4.5.7.0 for Full Erase using RICOHJPNW11.

Drage look like i get the same as you do.