LiteOn 20A1L Poor Performance

I just bought a 20A1L SATA DVD burner, which is supposed to write at 20x and read at 16x. I can’t get it to read faster than about 2.5x or write faster than 2x.

I have an ASUS K8V Deluxe motherboard with an onboard VIA VT8237 SATA controller. I’m running Windows XP SP2. The 20A1L is connected to the second channel of the controller. It acts like it is not using DMA, but there are no DMA options available in the controller’s device manager properties. I have installed VIA’s latest drivers for the controller.

Does anyone have any ideas?

Thanks! :slight_smile:

Here are some tests. I used a Verbatim 16x DVD+R disc for these tests.

CPU usage was high throughout the burn, and the buffer level fluctuated wildly.

It actually checked the disc’s quality at normal speeds.

[02:33:01]  [02:33:01]  Disc: Blank DVD, 4.38 GB, MCC 004
[02:57:49]  Disc: DVD+R, 4.38 GB, MCC 004
[02:58:06]  Starting transfer rate test
[03:19:52]  Speed:3 X CLV (2.60 X average)
[03:19:52]  Elapsed Time: 21:46
[03:19:52]  Starting seek times test
[03:20:02]  Random Seek: 98 ms
[03:20:13]  1/3 Seek: 112 ms
[03:20:32]  Full Seek: 189 ms
[03:20:32]  Elapsed Time:  0:40
[03:20:32]  Starting CPU usage test
[03:20:48]  CPU usage at 1X: 39 %
[03:21:03]  CPU usage at 2X: 78 %
[03:21:27]  CPU usage at 4X: n/a
[03:22:15]  CPU usage at 8X: n/a
[03:22:15]  Elapsed Time:  1:42
[03:22:15]  Starting burst rate test
[03:22:16]  Interface burst rate: 4 MB/sec (3594 KB/sec)
[03:22:16]  Elapsed Time:  0:02
[03:22:16]  Starting spin-up/down test
[03:22:20]  Spin-up time: 1.94 seconds
[03:22:31]  Spin-down time: 1.33 seconds
[03:22:31]  Elapsed Time:  0:15
[03:22:31]  Starting load/eject test
[03:22:32]  Eject time: 1.38 seconds
[03:22:34]  Load time: 1.34 seconds
[03:22:47]  Recognition time: 12.89 seconds
[03:22:47]  Elapsed Time:  0:16 

Hi Nibbles n Bits, welcome to CDFreaks! :slight_smile:

This sounds like your drive may be operating in PIO mode instead of DMA mode.

I suggest you read this thread:

Troubleshooting: Enabling/Checking DMA in Windows Vista, XP, 2000, Me, 9x

and also this article:

DMA reverts to PIO

Thanks for the suggestions, DrageMester.

I’ve tried enabling DMA mode in device manager, but my drive and controller properties have no DMA options. I ran the VB script, but it could not find any resettable channels. I also tried manually editing the registry, but that didn’t work either.

I went ahead and ordered a PCI SATA card with a VIA VT6421A controller. Hopefully, that controller will be able to use DMA. I wish I had bought the PATA version, but I thought SATA would work fine and be more future proof.

My mistake; I didn’t notice you had a SATA drive (not a PATA drive).

SATA drives sometimes are problematic due to hardware and/or software (driver) incompatibility. Plextor, for example, has a compatibility motherbord list for each its SATA drive. Have you tried to connect the drive to the first channel (also with another cable)? Is the bios of the motherboard the latest?

Do you have a Hard Drive on SATA1? Many people here have solved your problem by installing the correct VIA drivers, but that may have been with an Optical Drive connected to VT8237 SATA only. Which VIA drivers did you install (download link)?

I do have a hard drive on SATA1. I tried removing the hard drive from the controller, but it didn’t make a difference. I am using driver version 5.50b.

I have tried connecting it to the first channel, but not with another cable. My motherboard BIOS is not the latest. I usually try to avoid flashing my motherboard’s BIOS unless I really think it is worth the risk.

I’ve got a new SATA controller and a SATA-to-PATA converter on the way. I think I will get it working one way or another.

Thanks, everyone, for your suggestions.

I’d install the “VIA IDE Falcon Storage Device driver” (or an older release shown as “VIA PATA/SATA IDE Driver Package”) in addition to the V-RAID driver.

Alternatively you can use the full Hyperion Pro chipset driver package (which includes IDE and SATA drivers), not necessarily the latest 5.12a either (unless it works of course :slight_smile: ).

The most recent thread where this problem was solved is here: http://club.cdfreaks.com/showthread.php?t=224978 .

I tried these drivers without any luck. I’ve pretty much given up on DMA working with this drive/controller combination.

Thanks again for the suggestions.