LiteOn 20A1H Firmware LL0A problems

vbimport

#1

I flashed my drive to the new LL0A firmware (previously LL07) and as soon as I rebooted a " found new hardware" screen popped up asking to install software/drivers for the the 20A1H?? XP has never asked to install drivers for drives anytime previously so what gives? Firmware bug? Also, there’s a yellow checkmark in device manager before it now.

I guess I’ll just flash back to LL07 for now until this is fixed…


#2

Hi tWreCK, this is usually a Windows problem. Try using Device Manager to delete the IDE channel the drive is connected too, after the LL0A firmware is installed, and restart your system.


#3

I had similar problem, i updated the fw, rebooted, and my drive dissapeared from windows explorer and My computer, i shutdown’ed the computed and turn it on, and now everything’s fine.


#4

I forgot about this thread after I posted assuming there was no fix but I found it again today.

C0deKing - I tried your suggestion but it didn’t work. Now, everytime I reboot the driver wizards appear for the IDE Channel and the writer and it fails to install automatically. There are now yellow exclamation marks in front of the IDE Channel and writer. Instead of “Secondary IDE Channel” it just says “IDE Channel”? How do I get it back to the way it was? Rebooting does not help at all - the driver wizards appear everytime.

I’ve never had these problems before with any install of windows and with any writer before this. Firmware upgrades have always gone smoothly except for this one.

I really need to fix this since I need the Secondary IDE Channel back so my system will function properly. It doesn’t look like my system likes that new firmware LL0A…

BTW, explorer only recognizes the writer as CD-Drive now


#5

Flashing back to LL07 doesn’t work either now because the “Secondary IDE Channel” isn’t installed properly. How do I fix this?


#6

It’s unusual for this to happen after deleting the secondary IDE driver. :confused: Try re-installing the IDE drivers from the disc that came with your motherboard or inserting this disc when the wizard appears.


#7

I’m not using my motherboard (nVidia) drivers becuase they’re buggy and don’t work very well so I’v been using the std Microsoft PCI IDE drivers all along. The problem is - how do I install those drivers again? Inserting the windows cd doesn’t help at all - says it can’t find the drivers. Rolling back the drivers doesn’t do anything either - same result. Seems like the drivers have disappeared from the installation - how do i re-install the Microsoft drivers again? It’s supposed to find the PCI IDE driver automatically once you reboot if they’ve been uninstalled but that doesn’t happen since the device driver wizard appears everytime saying it can’t install the drivers?

Under IDE ATA/ATAPI Controllers in device manager I now have 2 IDE channels with yellow exclamation marks in front of them. Both primary and secondary IDE channels have disappeared however the Standard Dual Channel PCI IDE Controller (Microsoft) is present. What I need to do is to get windows to install the primary and secondary IDE drivers again because everything I tried up to now hasn’t worked?


#8

Try running this script, deleting the Secondary IDE Driver using Device Manager, and then rebooting.