Liteon 20A1H - Book Type / Bitsetting not supported!?!

Hello,

Just installed a brand new Liteon 20A1H, and was upset to find that the “Book Type” drop down list has disappeared from the Nero “Choose Recorder” dialog.

I can’t play my discs in my player unless I set the Book Type to DVD-ROM.

I thought this was one of Liteon’s “latest and greatest.” :confused: It’s replacing a broken Liteon 165H6S which did allow bitsetting with the latest firmware. It’s basically the same drive (for the most part) except it supports faster read / record speeds.

My drive before that was an LG… and that had lasted me for years. Maybe I should go back using an LG drive? :confused:

There’s no firmware downloads available from liteonit.com for the 20A1H yet.

Does anyone know of a hacked firmware for the 20A1H that allows bitsetting? I did some Google searches to no avail. :sad:

Have you tried the official booktype/bitsetting utilty from Lite-On?
Here’s a link if you need it, BookType135 : Link

worked fine for me, but i did use the bitsetting tool first.


Also the leadin times on this drive SUCK, over 50 seconds on a -R SonyD16
Anyone e-mail me the original firmware?

Also, keep in mind, Liteon drives have a history of not correctly reporting their ability to set the bit with many types of software. Almost all report that they do not bitset but if you actually look at the burned +R discs, you will see they are reported as ROM.

Thanks for the tip! :slight_smile:

Unfortunately, the Lite-on tool was extremely buggy, and destabilize my system when it was running (I’m on WinXP SP2 with latest updates).

To elaborate…

When I first ran the executable, there was a one minute and twenty second pause (with the message “Found : LITE-ON DVDRW LH-20A1H”), then my system spontaneously rebooted.

After that, I tried running it again. Again there was a one minute and twenty second pause. The drive is on the primary IDE channel as the slave device, with an IDE hard disk as the master. During this one minute and twenty second pause, the IDE hard disk appears to be unaccessable. This time after the pause, the tool started.

The only two options under the “Change Booktype to” drop-down were “DVD-ROM” and “NORMAL”. The “Write Now!” button stayed disabled the entire time:

I put in a blank DVD+R DL disc, then selected DVD-ROM for “Change Booktype to” and clicked the “Change” button. It said “BookType changed successfully !”. When I clicked the “Query” button again, the “Current Disc Booktype” still said “DVD+R DL”.

Anyway, I tried to start Nero, but before I did, Windows Explorer crashed and my desktop vanished. Explorer restarted but did not bring the desktop back. I tried CTRL-ALT-DEL and logging off then back on again. I was going to try to start the Lite-on tool again, then start Nero and burn an image. I started the Lite-on tool, then again after a one minute and twenty second pause, I got a svchost.exe crash dialog. I clicked OK on that, then the Lite-on tool’s main window came up. I started Nero, but the system hung. I tried a CTRL-ALT-DEL then doing an “end task” on both Nero and the Lite-on tool, but the whole system was still hung up. I tried doing a CTRL-ALT-DEL then logging off again, but the system froze on “executing wlnotify.dll”. I had to do a manual reset on the computer.

After the reboot, I decided to try to start Nero first, then the Lite-on tool. This time, again after a one minute and twenty second pause, I got a spoolsv.exe crash dialog. I clicked OK on that, then selected DVD-ROM for “Change Booktype to”, then clicked the “Change” button. Again I got the “BookType changed successfully !” message. I didn’t click the “Query” button again, I just burned an image using Nero.

After the image burned, I checked the book type setting of the burned disc (using both the Lite-on tool and Nero CD-DVD Speed 4.7.0.0), and found that the book type was successfully set to DVD-ROM.

The Lite-on tool seems to be for burning applications that don’t support bitsetting. Nero supports bitsetting, and even though this tool works, I feel it’s a lot of unnecessary hoops to jump through.

I sent a support request to Lite-on. We’ll see if they reply after the holiday.

Another weird thing…

With this drive, the Nero “Choose Recorder” dialog displays the “SMART-BURN” option twice (you can also see that there is no book type selection drop-down):

That seems more to be a Nero issue though. (I’m using the latest Nero version, 7.5.9.0A.)

Maybe the book type / bitsetting problem is a Nero issue as well? :confused:

That is a different tool than the one available from the Liteonit.com site. Perhaps it would not be as unstable, but unfortunately, you didn’t say what the name of the tool is or where it can be downloaded, so until I know that info, I can’t try it.

Edit - DUH!!! It’s right in the Nero CD-DVD Speed 4.7.0.0 tool! It’s only in the menus though (Extra -> Bitsetting). I’ll give that a try…

Unfortunately, it did not work. As seen in Budman62’s screenshot, the bitsetting function in CD-DVD Speed 4.7.0.0 does not support dual layer discs with the 20A1H, which I use a lot:

Have you tried putting the drive on the secondary IDE channel and set it to master?

OK, I just found out…

It appears the Lite-on Tool only needs to be run one time. I checked the “Save setting” checkbox, I’m not sure if that made a difference, but…

I rebooted the system, started Nero, burned an image, and the book type is still DVD-ROM. So I’m guessing the Lite-on and CD-DVD Speed tools are changing a setting for the drive itself, not the current disc.

So problem solved, I guess. I’d still like the book type drop-down list back in Nero however. :stuck_out_tongue:

0301orih, I have 2 hard discs on the other channel. :stuck_out_tongue:

You run the Liteon tool only once and then the booktype is set for the drive. If you have DVDDecrypter or something similar, you can set the booktype FOR +RW ONLY after the burn. All other discs need to have the booktype set before you burn. And again, you cannot use DVDSpeed or most other tools to determine the drive booktype setting on Liteon drives, only the setting on an already burned disc.

This goes back to the 8XX series at least and probably the 4XX series as well. It comes up so often that maybe we need additional info in the booktype sticky or maybe more people who read the stickies.

liteon drives will only set booktype to on after the next burn after you choose -rom with the booktype utility. I have this same drive and it couldn’t see dvd ram discs set as a slave on pri.ide moved it to sec.master and it works fine now. can’t figure that one out! lightscribe is great. kprobe will set booktype and also hypertuning & over speed.

As I have just found out, you are incorrect. The PDF manual that’s available from liteonit.com is for version 1.0.4, and that doesn’t have the “Save setting” checkbox. Version 1.3.5 does. Mousing over the checkbox with +R/RW/DL media inserted will give the popup “Save setting to EEPROM,” indicating that it does indeed change a permanent setting on the drive:

I’m not 100% sure on optical drives, but on many other devices, the EEPROM and firmware are two different things. I’ve verified that multiple burns will result in DVD-ROM booktype bitsetting. This is good news, since my system becomes very unstable when the Lite-on tool is running. I recommend running it after booting Windows into safe mode, since it only needs to be run once.

I have also found out that the “Write Now !” button is for DVD+RW discs.

Keep in mind that you must insert a DVD+R, DVD+RW, and DVD+R DL disc into the drive before hitting the “Change” button each time; the tool only works if the media for which you want to change the bitsetting is physically in the drive.

That alarmed me, as I have the drive on the primary IDE channel set to slave. I put in a DVD-RAM disc, and it recognized it correctly.

imageburn give the option of bit set for the drive.

http://www.imgburn.com/

@funkychunk

thanks it work for my 18A1H HL05, the liteON Tool don’t work (drive not supported).
If it is realy fix I will see.

Glad It Worked,
Worked For Me With My Liteon LH-18A1H. HL05 And Liteon LH-18A1P.GL0B
And Gave Me Permenent Bitset.
Happy New Year… :slight_smile: