Liteon 1693 and Prolific 3507 enclosure problems

vbimport

#1

I have just purchased a Liteon 1693s, and installed it in a external case that has a Prolific chip set PL-3507 (05114c). Windows XP does not detect the drive, USB or Firewire. I have used the case with a DVD Rom and HDD, no problems. I also install the Liteon 1693 in another computer (internal) and it was detected by XP. I have updated the firmware on the PL-3507 to the latest version 2005.01.07.204 . Has anyone had the same problem, or have a fix for me?


#2

bill84, welcome to cdfreaks :slight_smile:

Try using the PL3507-0907B firmware. I had problems with Liteon drive detection when I tried upgrading to later Prolific firmware than this.


#3

I have just tried reflashing with 0907B no good. So I tried 0422B, 1006B, 1109B and 010705B. I confirmed each was loaded ok with the Read Rom. I have the same problem with all of the FW’s. Any other ideas?


#4

make sure the driver is on master. If you can make it master without any other drivers.


#5

I had problems with my firewire/usb2 external box (Oxford chipset) detecting this drive until I changed the short IDE cable out for a standard 18" one. I don’t know if I broke one or more of the wires in the short cable installing the drive or if this drive is just cranky about cable length.


#6

You really need to try the enclosure on another computer. It’s the only way to eliminate the enclosure or the system.

Also I wonder what the 5 and 12 volt supplies are like in the enclosure. :wink:


#7

I have tried the enclosure on another computer. Same result. I also installed an LG 8083 burner and it was detected ok. I will try using a different ide cable, but
if this cable works with a DVD Rom and Hard drive, it should be good.


#8

Drive set to master, changed IDE cable to 18", voltage checked at DVD-Rw 5.34 volts and 12.24 volts. same results.


#9

Set the jumper to CS (cable select) for all drives in external enclosure!!!


#10

I just got my 1693s drive today…

I got the external unit, and Windows XP recognized it right away…

I would have to say that maybe it’s something in or on you enclosure that is causing a conflict between your drive and XP…


#11

Yes, I’m sure it’s a conflict with the firmware in the enclosure and the liteon 1693. Older units work fine, USB and Firewire.

I also did try CS and it made no difference.

Is there anyone using a liteon 1693s in an external enclosure. Pls let me know what type of enclosure you are using or the chip set.


#12

FYI. I returned the Liteon 1693s and picked up a LG GSA-4163B.
Everything works fine, there must be a compatabilite problem with the prolific chip set and the Liteon 1693.


#13

I don’t know about that.

Could be that the external enclosure you bought isn’t supplying enough voltage to the LiteOn burner, some burners require less, the LiteOn & Plextor require the most (from what I’ve read on The big external enclosures thread).

I’m using the newest Prolific chipset on a Bytecc ME-340U2F (pretty aluminum case), and have had the following drives in perfect working order w/ it…

NEC ND-3540A, Plextor PX-716A, LiteOn 1653s & 1693s.

Only prob I was having, is that the burning speed topped out @ 15.93x, but maybe that isn’t such a bad thing, it only added 8-12 seconds to each 16x burn.

The prolific firmware I’m using is “fw ver.2004.12.09.200”


#14

I have a 1693 in a Firewire that uses the Oxford 911 chipset, works just fine on both my Macs (laptop and desktop) and my PC laptop.


#15

Have you ever burned a disc above 8x using Nero CD-DVD Speed create data disc or used read patched firmware and Nero CD-DVD Speed transfer test to read past 8x?


#16

None of my drives will burn above 8X with my Oxford 911 chipsets. They do seem to rip with no problem (same speed as with IDE). I have found that LG, Liteon, NEC, Pioneer, BenQ and Plextor all function.


#17

Never tried it. I just use the firmware you guys release as is…


#18

bill84, I was just thinking about this and I wondered if you knew what version of the firmware was in the 1693S you had?