Liteon 1653 dying ? can't erase rw media

Since a couple of months i started facing problems with my liteon 1653 dvd writer: it became impossible to erase DVD+RW media, always reporting it as DVD-ROM booktype with media RW.

but today i can’t even erase CD-RW media.

it can ready all media, can write DVD+R, CD-R but not erase.

any ideas?

I am running Nero 7.5.9.0 on WinXP x64

Do you have software with Ignore Media Type installed.

Alcohol have such a function.

ImgBurn can erase many rw, than other programs can’t.

Maybe i found the problem, it has something to do with the current x64 OS, i tried in a fresh install of normal xp and it doesn’t say it can’t erase, but still the x64 windows complains that the dvd+rw are still not empty, while the cdrw is ok.

Ok, I tried to erase an DVD+RW and in the windows 32bit it is said that it is empty, but when i switch back to the other x64 windows, it still reports it is a completely used DVD-ROM disc…

seems to have some driver issues, is there a way to clean drivers/filters?