Liteon 163D MTKFLASH problems

Hey all, im new to these forums :slight_smile: , they seem pretty neat too.

Unfortunatly I upgraded the firmware on my Liteon to GHR6, and that “JLMS” business is really doing my head in. I searched these forums and saw that someone (Mango I think) had a site with the GHR6F.bin file on as well as MTKFLASH.

I downloaded them both, and then used my XP boot disk to boot into dos. Then I put int the floppy with the MTKFLASH.exe and GHR6F.bin file.

I ran MTKFLASH with the command: MTKFLASH 1 W /B GHR6F.BIN

Then I just get a message saying something like “MTKFLASH… Made by J… 1998” (can’t remember the message off the top of my head)

and well thats all it says, i press a key and nothing happens, so I use “ctrl-c” to get me back to the DOS prompt.

Anyone have any ideas why I cant flash my drive with the GHR6F.bin?

Thanks for any help, id really appreciate it.

ps. ive tried the new MTKFLASH 1.48 and the previous version of it, same thing happens with both versions.

Cheers again.

Just another thing, as slave on the Primary I have a liteon CDRW. :slight_smile:

All sorted now :eek: , stupid me - I kept telling MTKFLASH to flash my Primary Master - thats my HDD! Told it to flash my Secondary Master and it worked! :bigsmile: I feel so dumb!

Mtkflash is a gun without safety.
Got to be 200% sure before you press the Enter.
You’re lucky you didn’t fry your cdrw… :wink:

Heh, I really like that MTKFLASH utility. It has saved my 163D a few times already and I know it will continue to do so for others as long as that terrible Windows flash utility continues to exist.

:Z

I posted this in another spot as well, but this seems like the place to post it.

HELP!!
OK, I had some problems with my liteon 163d so I decided to reflash to keep it current. I used the windows utility… It locked up so now windows won’t recogognize it. It tried to use the mtkflash utility, but it won’t work. Here’s what I do:

mtkflash 3 w /b ghr6f.bin

I do this at the A: prompt after booting into pure dos with a boot disk (Win ME) The program does nothing. It just says the name of the program and sits there. I unhooked all the rest of my cd drives so the only thing left is the HD & the liteon 163d. I’ve tried every setting (1-4) even though I know it’s channel 3 (secondary master) The program just sits there. Can someone offer any advice?

Two trivial questions:

Is the bin file on the diskette as well as mtklash? It’s ok to have it somewhere else but mtkflash has to know it.

Is the drive jumpered as a master? CableSelect does not work.

None of the liteon firmware names is 5 digits long…sometimes mtkflash only works if the drive is connected as secondary slave (without master present)

The bin file is on the same disk as Mtkflash. I actually have 2 disks. my DOS boot disk and the 2nd with MTKflash & the bin file. I also tried the drive as primary slave, secondary master & secondary slave with no other drives connected except the hard drive on primary master. the program just sits there & does nothing. It is MTKflash version 1.48. Any other suggestions? How long should it take before I notice the DOS screen doing something?

Also, the file is 5 digits long because its the newest region free file., Is there another I should try first to get the drive working again? If so, where can I find it? It is totally dead… No activity at all…

In this case, try another PC. Sometimes, mtkflash hangs when trying to flash a dead drive only on certain PCs (preferably with some VIA chipsets, but not only)

Alexho:

 Thanks so much for helping me through this. I am making progree, not quite there yet, but..

I tried a different computer & the mtkflash program starts to do something, BUT now it says it can’t access the bin file. Maybe a bad bin? In any case, do you know where I might find another?

Thanks again for everything…

All the binaries are on my site,
feel free to them…

Thanks, thats where I downloaded the ghr6f.bin file from. But, when I run the MTKFLash program it says erasing, programming for a spilt second then it says cannot access bin file.

Is the file write protected? Some programs try to open a file for “generic access” even if only reading is required, and generic access is not granted for read-only files.

Is there any chance that you have the .bin file zipped up on the floppy by mistake? I just downloaded the GHR6F file from digi’s site again and reflashed my 163D without any problems. The file was not checked “Read-only” after unzipping so that should not be the problem.

Thanks for all the help. I don’t know exactly what the problem was but I finally flashed it & i’m using my 163d again… Thanks all…