Liteon 1633 #5 "Bites the dust!

vbimport

#1

Wonder if Liteon visits this forum… My son wanted a 1633 so I put one in. It worked OK (just OK) for two weeks and now it’s recognized by XP but won’t read anything put in it. Returns the message “Drive not ready”… :frowning: :frowning:

Just gotta love Liteon quality… Once again it’s time to update my sig, 4 outta 5 have bit the dust. :a :a KProbe or not, he’s getting a BenQ!

I think Liteon needs to send “Royalty” checks to Karr, without KProbe there’s no reason to buy these damned drives.

Regards


#2

I don’t think you could make a better purchase than to replace a Lite-Off with a BenQ.


#3

Replace with Benq…that’s not very constructive as an advice
Why don’t you return the drive to where you purchased it?


#4

No one was looking for advice…


#5

pcdoc > I know you know your shit when it comes to pc’s and ODD’s etc…so i’d say a your making the right decision :wink:


#6

Hey rolling56:

It’s incrediable what crap this stuff is… I just post these experiences so people don’t blow their bucks on 'em… Maybe I’ll test a few more just for giggles… Think I could get 2 outta 10 that work? :wink: :wink: This last one was branded Sony, bet they’re happy 'bout the impact this stuff has on their rep.

Regards-


#7

You sure power supply is OK. It seems kinda fishy that 5 drives just died, even for crapiest drives one should, accidentaly, work as advertised.


#8

don’t want to turn this into a liteon bashing post, but i tend to agree with pcdoc. if it wasn’t for the end user community, liteon’s dvd drives would be total crap. these users have made second rate drives into something that is workable. i can take any of the other good drives (benq ((my fav)), nec, pioneer), plug them in out of the box and get great burns. i feel liteon dvd drives live on their cd-rw drive rep. bottom line is, if your gonna spend $60.00 on a dvd burner why not get one that produces stellar results instead of one that you have to massage the he11 out of to get average burns. let the flaming begin


#9

It would be a shame for this thread to become a LITEON bashing…

@pcdoc - If it can make you feel any better, what you describe is poor quality control and concerns many of the things sold today on the market. Companies in general (not just liteon) are cutting corners, and production quality is taking a hit ! You can’t blame LITEON, as I have built PCs for many friends and colleagues around me and I have seen similar problems with other burners, yes even plextors. Someone I know with a PLEXTOR and another one with NEC (the drive people praise) have had similar experiences. As to my personal experience, my 811S worked out of the box - I have HAD my share of frustrations, and yes the drive does not produce the best burn strategy however, there are enough tools to make the drive a top drive. I use my 811S in a business and have burnt hundreds of DVDs and have yet to experience ANY problem. It is odd that you have gone through 10 drives :slight_smile: Simply suggestign people to get BenQ in my opinion is not good advice - maybe you should get your son a NEC or PIONEER, maybe you do not have any luck with LITEON, as far as I am concerned they are good drives when using the right media, and since I can get quality media for cheap then I stick to LITEON.

You have a waranty ? Make use of it. In some cases you can go back to your store and exchange it, or call up LITEON and give’em CRAP, tell’em to do a reverse RMA, and send YOU a drive along with a pre-paid box for return, as you don’t have to pay for their bloody mistakes… (better stop here now) :smiley:

The whole point being, you will see users bash Benq, you will see users bash PIONEER, you will see bashing in even the best products. Check your power supply - from experience I have seen poor/failing power supply in people’s systems that killed hard drives and burners… You might want to look at the cause…maybe you did end up with a bad batch of liteys :smiley: :smiley: :smiley: Maybe it’s time to buy a few lottery tickets and use those numbers, maybe you have better luck there.


#10

[/QUOTE]


#11

Rimmer66- You can’t be serious……… Reread the post!

@pcdoc - If it can make you feel any better…
I don’t want or need to feel better, trash is trash. This was a FYI post not someone whining……

Companies in general (not just liteon) are cutting corners, and production quality is taking a hit ! You can’t blame LITEON…
Great! Than who do you blame? Let’s feel sorry for these companies and concede that it’s OK to produce and market crap!

I have built PCs for many friends and colleagues around me and I have seen similar problems with other burners…
My grandmother has also built a few PC’s, what’s the point?

I use my 811S in a business and have burnt hundreds of DVDs and have yet to experience ANY problem…
Hmmm, is it harder for a optical drive to work in a business than other environments? I must have missed something here.

It is odd that you have gone through 10 drives……
Read the post, it doesn’t say I’ve been through ten of them yet! You can check my signature for the on going tally………

Simply suggestign people to get BenQ in my opinion is not good advice-
I never suggested that people buy BenQ, although I should have. I said that’s what I was replacing the 1633 with……… Once again, read the post.

You have a waranty ? Make use of it.
If it’s all the same to you, I’ll just continue to through them in the trash where they belong. I don’t remember anything in my previous post ‘bout warranty, cost, or any other financial consideration! Oh, but thanks for your advice.

Check your power supply - from experience I have seen poor/failing power supply in people’s systems that killed hard drives and burners… You might want to look at the cause…
Gee thanks, next time I need to do a little hardware troubleshooting I’ll send ya a PM……

Incrediable!


#12

@pcdoc
It would seem you have had a bad experience with Liteon and thanks for sharing that experience with us. :slight_smile:

My experience with Liteon has been pretty good. I’ve had two faulty early production 1213S drives out of the seven Liteon hardware based drives, I have had and the two faulty drives functioned but seemed to have incorrect factory calibration. So I think your experience is an extreme one. :wink:

I don’t think there is any benefit in leaving this thread open. :wink: