Lite-On SOHW 1693S doesn't read most DVDs

vbimport

#1

Got this SOHW 1693S DVD-RW off eBay a while ago and the seller told me it had been working fine. The deal is it will read CD-ROMs, and DVD-ROMS, and Region 0 DVDs, and Region 1 DVDs that have DVD-ROM content on them, but not plain old Region 1 movie DVDs. It just claims there’s no disk in there.

I got a DR16KS0B.zip firmware update from somewhere that I installed to no avail. I’ve got the LtnRPC thing, set the drive region to 0 and back to 1, didn’t solve anything. Tried the drive in a different PC just in case there was something about my motherboard it doesn’t like, still the same thing.

I haven’t even tried burning anything with it yet, mostly I just want to watch movies on my computer again. This was supposed to be a replacement for my last DVD-ROM drive (also a Lite-On) that had long time intermittent problems reading DVDs and didn’t like CD-R discs very much.


#2

I hope you didn’t pay more than $24 for it since that’s how much a new LO drive costs nowadays. It sounds like you bought a dying / defective drive, irregardless of what a seller claimed.