Lite-On LTR-52327s help, please!

Bought one of these bad boys at Best Buy this week, since everyone says they’re great, so after running CD speed on my old 48x and 52x (Optorite - so so drive), I run the Lite-On, and it rips audio at avg. 20x and burns (on Imation 48x media) at about 8x!)

I have made sure that I’m on DMA on my IDE channel, that the firmware is up to date (QS0B), and I’m about out of ideas (this is the second drive (I exchanged it today) I’ve gotten from BB that’s this way, so I suppose it should be fixable (or a bad batch of drives).

Any ideas?


maybe try installing motherboard IDE busmaster drivers?

Other than that… I’m having no problems with my drive. I have shipping firmware, though (06).

Need more system details: what’s your IDE device cabling setup, what Windows version, what motherboard chipset?

Thanks for replying, guys… Busmaster drivers are on according to device manager.

Setup is:
XP Pro
P4 1.8 400fsb
Intel 850 chipset
512 MB PC800 RDRAM

Primary IDE 2 WD HDs

Secondary IDE
Master LiteOn 52x
Slave Optorite 52x

(have also tried it as master with no slave)
Optorite 52x and Memorex 48x work flawlessly on this same machine, so I’m very confused.

This problem can’t be just from media (though the recording may be, partially, as newer media worked better with SMARTBURN turned off), as audio ripping is even more problematic. In Musicmatch, I tried ripping the same disc on all 3 drives, the Optorite tops out around 50x, the Memorex ~45x, but the LiteOn at 16x!!!

However, this is the second LiteOn with the same problem…

Thanks for the help!


Try using alternate software (CDex).

Is the drive light solid green when ripping, or blinking on and off? If it’s blinking, then the system is not reading from the drive as fast as the drive can read. Are you CERTAIN that DMA is actually working (does it show Ultra DMA Mode 2 as the Current Transfer Mode in the IDE channel’s advanced settings in Device Manager?)

You must make sure that you are only running a burning software. If your processor is bussy enough, running quite a few programs also, your burner will not reach the max speed by no means.

A signal that could lead you to verify this, is what robman said. Pay attention to it.