Lite-On LTC-48161 won't read some CD-ROMs

It will read my Windows XP CD-ROM fine, but HP LaserJet install CD takes several minutes to be recognized, then when I click on the D: folder, I get the “flashlight from hell” and the system gets all sorts of herky and jerky while it tries to read the disk, I get fed up and eject the CD. The ATI Sapphire installation CD it won’t read at all. Firmware is CO48KH0R. Tried Kprobe on it and burst mode is 33.28 Mb/sec. Checked Device Manager, Device Driver is Microsoft 7/1/2001 5.1.2535.0. Any advice? Buy something different??? I’ve always liked Lite-On but this is disappointing to say the least.

Have you always had this problem?

My 48161H with KH0Q has never done this to me. I have not yet had a chance to try CD-ROMs since flashing to KH0R (been using mostly DVDs).

I recently updated my LITE-ON COMBO LTC-48161’s firmware to KH0R and have been using CD-ROM, CD-R, DVD-ROM, DVD-R, DVD+R, and DVD+RW I haven’t seen anything like what you describe hepmeplees, my drive is old so it is a bit more noisy but nothing like that. Try old firmwares and see if that solves anything.


:bow: .:NEC ND-3500:.

Yes, this problem has existed since I put the system together a few weeks ago. I don’t remember what version of firmware it came with, but I flashed it with the KH0Q firmware when I initially discovered the problem. Then I flashed it with the KH0R just a couple of days ago to see if that helped. So I guess in effect I have used “older firmware”… just not sure how much older… but nothing has worked. One weird observation, every Microsoft CD (Windows, Office, Money) works flawlessly but almost every other CD ranges from “just a little slow” to not even being recognized as inserted.

So it’s a new drive? I thought that the 48161H was phased out a long time ago.

It could be that you got a bad drive; I haven’t observed anything of the sort. :confused:

I guess you could call it “new”… I bought it from Newegg back in March and have been accumulating the pieces since then to build a new PC. I finally built it in early October and ended up with this issue. Guess I should have been a bit more aggresive with the schedule. In any event, I do appreciate your assistance/advice, I suspect I will have to buy another drive and hope for better results.