Lite-On LH-20A1x Error ID: 51

I recently built an new machine for Vista.
As Newegg was out of stock on lite-on drives I ordered two Samsung SH-183L drives.
These constantly gave me an error of:
Event ID: 51
“An error was detected on device \Device\CdRom1 during a paging operation.”

After trying all of the below with the Samsung drives we wrote them off as not compatible with Vista and went to the Hardware compatibility list.

The LH-20A1L was on it and the same spec as the samsung so we ordered two and…
The same thing, same error.

I email Lite-On technical support with the following letter AND called them.
I stumped them.

Microsoft Vista Home Premium Operating System.
Every time I insert blank media (Fuji DVD+R, Maxell DVD-R, TDK CD-R) It generates and error in “Event Viewer”, “Windows Logs”, System" of: “An error was detected on device \Device\CdRom1 during a paging operation.”

On a fresh install of the OS on blank hard drives this problem presents itself with MS Vista provided drivers and all vendor provided iterations.
Mainboard : Gigabyte 965P-DS3
Chipset : Intel P965
Processor : Intel Core 2 Duo E4300 @ 1800 MHz
Physical Memory : 2048 MB (2 x 1024 DDR2-SDRAM )
Video Card : Nvidia Corp GeForce 7900 GS
Hard Disk : ST3160023A (160 GB)
Hard Disk : GRAID (320 GB)
DVD-Rom Drive : LITE-ON DVDRW LH-20A1L ATA Device
DVD-Rom Drive : LITE-ON DVDRW LH-20A1L ATA Device
Network Card : Marvell Semiconductor (Was: Galileo Technology Ltd) Marvell Semiconductor (Was: Galileo Technology Ltd)
Operating System : Windows Vista ™ Home Premium Home Edition 6.00.6000
DirectX : Version 10.00
Windows Performance Index : 4.8

I have updated all drivers from what ships with MS Vista Home Premium 32 to the most current for each chipset, tried the drives on each chipset and checked at each point along the way to see if the error was eliminated. It is not.
I have tried both LH-20A1L drives on the Intel ICH8 SATA Controller, the SiI 3132 controller and the JMicron JMB36X controller with the same effect. This is with both the MS supplied OS drivers and the most current drivers from each manufacturer’s site.

I have tried different SATA cable, Swapped out the power supply and exchanged the Motherboard with no change in status.
If I do make a recording to a DVD+R, DVD-R or CD-R the OS or Nero will report success with the burn but when you attempt to read the drive you get critical errors in the system log of bad blocks or sectors.

The drives will read the same media that fails in these drives on this machine provided that has had a recording made on it on another machine. It will read pre-recorded DVDs (Data and Movies) and CDs (Data and Music)
I have also tried enabling AHCP on/of and PIO native Mode 3 support on/off in each of the four possible configurations on the ICH8 ports to see if that made any difference.
Problem still exists.
Firmware on these drives is BL01
These drives work without error in the same machine with Windows XP-SP2 installed.

I have also tired Firmware F10, F7 and F8 for the mainboard.
I have always used Lite-On drives and have never had an issue until this day with any of them.

Thank you in advance for any assistance you may be able to provide. Should you require additional information or have me take additional action please don’t hesitate to contact me.


Well this afternoon I called Lite-On back to let them know we had found the cause of the issue.

We were testing these drives on similar machines built with Gigabyte, Asus and Abit boards all using the ICH8 or ICH8R chipsets and were getting the same results in all of them.

On one of the hardware swaps we removed the 2GB USB thumb drive from a back USB port on one of the machines. We are using this as part of the build and were going to include them for “Windows Readyboost” support.

Wouldn’t you know it…
No thumb drive, No Readyboost, No problem.

We confirmed this on the other two machines on the bench. Remove the flash device (effectively disabling Readyboost) and the IO errors went away and we could write to the Optical drives without issue. We reinstalled the Samsung drives and the same thing. Without Readyboost enabled the Optical drives operated without issue.

With three difference machines, and three different SATA controller chipsets and two different optical drives the problem was repeatable and directly attributable to having readyboost enabled.

So… I am not saying we found a fix, only a possible cause to an issue.
If you are having problems with your ODDs on Vista and you have a flash device installed with Readyboost enabled, you might want to try disabling Readyboost and seeing if the problem goes away.

Interesting and thank you for posting :clap: First i’ve read this i believe. Do you still have a Samsung S183L there?

Still have both the Samsung SH-183L and the Lite-On LH-20A1L drives here.
Both pairs are working (All four in one box at the moment as a matter of fact)


After a call to MS Technical support:

Computer, “DVD RW Drive (X: )”, Properties, Recording, Global Settings button:
Disabled “Automatically close the current UDF session when the disc is ejected”

Control Panel, System, Advanced System Settings (System Properties>Advanced), Performance > Settings button, Performance Options window, Virtual Memory section, Change Button, Virtual Memory window, Custom size:
Set paging file size to
Initial Size = 1.5Installed memory+ReadyBoost
Maximum Size = 2
Installed memory+ReadyBoost

These two changes did NOT make the warning go away in the Windows System log, BUT…
I am now able to successfully burn a CD or DVD without getting bad sectors.
No explanation was given as to why this would resolve the issue.