Lite-On LH-20A1L-05 not working properly (very slow)...Please help!

hey! im kinda noobish when it comes to installing new hardware and i need some help. i just bought the Lite-On LH-20A1L-05 (SATA, OEM) to replace my SOHW-1633s and i cant seem to get it working properly. My motherboard is ECS KT600A.

First, after i installed the drive, my Windows XP didnt recognize the drive (not in device manager), so my friend helped me go the the ECS website to download this “VIA SATA RAID Controller Driver”. After he installed the driver, the drive showed up in the device manager as “LITE-ON DVDRW LH-20A1L SCSI CdRom Device”. I thought that fixed the problem, but theres another problem…

When I tried to burn some dvd copies, it takes forever! So i did the Nero cd-dvd speed test thing and the max speed was around 2.5x. I was burning on Verbatim DVD-R 16x discs. It all takes around 30 minutes to burn.

Can someone please help me! Did i miss something? Feel free to ask me for my info if that can help you help me solve my problem. I dont feel like RMAing it if someone can help me fix it here. Thanks in advance!

It’s a typical problem for the VIA chipset used on your mobo. In some cases it can be solved by trying out different drivers. First to try would be the VIA Hyperion Pro driver package from viaarena.com. Also make sure your SATA controller isn’t set to RAID operation in the BIOS.

Welcome to cdfreaks.com!

hey, i tried the VIA Hyperion Pro Driver package and nothing really happened. Still burning at around 2.5x and i didnt really see anything about setting SATA controller in BIOS. im thinking this just doesnt work with my motherboard. Any other suggestions before i decide to RMA it?

It’s most likely your BIOS SATA settings. The problem you describe is fairly common with ALL SATA optical drives so RMA-ing the one you have may not be a solution.

Find a “geeky” friend to help you get your BIOS sorted. Basically, you need to find the section of your BIOS that deals with your SATA controller and set it to Legacy IDE mode instead of RAID or AHCI.

As I said, this is a typical problem of the VIA VT8237 SouthBridge’s SATA controller, even if it’s not in RAID mode. There are different revisions/implementations of this chipset and unless you are willing to experiment with different driver versions (without guarantee for success), I think you may be happier with a PATA burner.

Thanks for the help guys, but i decided to exchange it for the E-IDE interface model, LH-20A1H. I just wanted to try out SATA, but didnt want to go through anymore trouble. im sure there isnt too much of a difference besides less clutter with cables. Thanks again!

I have the same problems take a look!

[


added bios info!
Also as you can see when empty it has audio cd, what’s up with that!

Check that crapped disc with nero cd dvd speed > disc info.

I still don’t know what’s wrong, this is what nero infotool says with an empty tray!

Nero InfoTool 5.3.1.0
Drive Information

Drive : LITE-ON DVDRW LH-20A1L
Type : DVD±R/RW DL Recorder
Firmware Version : BL04
Buffer Size : 2 MB
Date : 2007-05-08
Serial Number : n/a
Vendor Specific : 2007/05/08 21:36
Drive Letter : G:
Location : 0:0
Mechanism : Tray
Read Speed : 16.0 , 12.0 , 8.0 , 6.0 , 4.0 , 2.0 , 1.0 X
Write Speed : 18.0 , 16.0 , 12.0 , 8.0 , 6.0 , 4.0 , 2.4 X

Disc Information (G:)

Type : :Audio CD
Capacity : 00:00.01 (0 MB)
Tracks : 0
Sessions : 0
File System : audio
Title : n/a
Artist : n/a
Disc ID : n/a
UPC/EAN code : n/a