Lite-On LH-20A1H UDMA Mode 4 Not Registering Win XP

vbimport

#1

Hi all,

I thought this drive supports Mode 4 but in Win XP it keeps showing DMA Mode 2. Here’s my setup:

-Dell XPS Gen 2 P4 3.2GHZ; 2gig RAM; Win XP Pro SP2
-Intel 875P chipset (which should support up to mode 5/ata133)
-Lite-On burner: Primary IDE channel (master)
-Samsung 182M burner: Secondary IDE channel (master)
-RAID 0 SATA hard drives
-New Vantec 80-pin cables (up to ATA133 support)
-drivers for intel chipset, drive firmware, and bios up to date

I guess not that big of a deal, but wondering why the drive isn’t registering Mode 4 in Win XP. Is it a Dell issue? There is nothing in the Dell bios to select UDMA modes except for “auto” and “off.” I’ve attempted to reinstall the Intel Ultra ATA chipset drivers which state in the readme support mode 4/ata66 but no love. Any other suggestions or is it just not worth bothering??

Thanks as always,
Adam


#2

The LH-20A1H definitely supports UDMA 4; mine runs in it. Have you tried the basic DMA troubleshooting strategies? You say that you’ve reinstalled the ATA chipset drivers, but have you tried uninstalling the primary IDE channel itself, restarting, and letting Windows re-detect/re-install it?


#3

Thanks for the suggestion! When I installed the drive last night, Windows detected it on the primary IDE channel and installed the necessary drivers. Before, only the secondary channel was showing in the device manager. I will try a “clean” install again tonight by removing the primary device drivers.


#4

Full uninstall of primary, secondary, all IDE ATA/ATAPI controllers including the Intel 8201EB storage controller and both DVD/CD-ROM Devices…reboot, XP picked up all devices, reinstalled chipset drivers to support up to ATA100…still in DMA mode 2. Maybe it’s a Dell issue.


#5

Try with another (flat) 80-wire ribbon cable?


#6

Thanks for the suggestion. I purchased new Vantec 80-pin round cables (up to ATA133 support) and switched them last night…still no change. I will try a flat cable as well tonight.


#7

Hi,

you could also try connecting the Litey as Secondary Master and the Samsung as Secondary Slave (or Primary Master). Some controllers indeed treat primary and secondary IDE ports differently.

Michael


#8

You’re right it’s worth a try anyway…easy cable and bios swap. I plan on doing a full system format and clean install of XP by the end of the week as well - maybe it will somehow sort itself out that way :stuck_out_tongue:


#9

Check your bios, make sure your ide controllers are set to auto that could be the issue.


#10

Yup, Bios settings set to “Auto.”


#11

Same drive here, XP only sees it as UDMA 2 - however, I only see it as UDMA 2 at the BIOS level on my Asus P5W DH Deluxe… Ideas anyone? I’m using a flat 80-pin cable. BIOS is flashed to current (there is a newer beta out though)

Ideas?? Driving me crazy :a


#12

Try removing the Samsung drive and leaving the Lite-On as the only drive?


#13

I have the same drive and the same problem… I also have two drives (Pio DVR-111L as slave and Lite-On LH-20A1H as master) on one 80-pin cable and the only avaliable mode is UDMA 2 (for both actually)… In BIOS everything is auto and so on…
I switched the Pio off but nothing changed after that…


#14

Did you physically remove the IDE cable from the Pioneer?


#15

Actually, not… Just unplugged the power supply cable - physically…


#16

Remove the IDE cable and go into your bios and redetect the Lite-On and see if it helps.


#17

I did so… But nothing changed again… Maybe strange but there is no option Ultra DMA 4 (the highest is Ultra DMA 2) for the drive in BIOS… Does it mean that BIOS needs flashing? I’m asking cause if the Pio is alone it runs in UDMA 4 mode (I shall check it now - maybe I’m mistaking…)


#18

You could try flashing but I think you should first try the Lite-On on the same part of the cable that the Pioneer was. If that doesn’t work then it may be something strange (but not serious) wrong with the Lite-On.

I could be wrong though…


#19

OK, I will try to find out what the problem is…
RodLane, thank you very much for your help! =)


#20

No problem…