Lite-On HD-A740GX Hard Disk Upgradable?

[QUOTE=Shaftz;1952916]Hi guys I’m wondering if anyone can help. I got my Lite-On HD-A740GX last xmas, it’s been fine and still is fine, except that it won’t play divx films with up to date codecs. It just says does not recognise audio / video codec - skip file.Does anyone know if the codecs can be upgraded for this model, I’ve tried finding out myself but have had no luck so far.Appreciate any response.ThanksS[/QUOTE]

Well i have been playing back Divx 6.7 no problems, maybe they codecs being used in your files are non standard or the audio is encoded in the wrong format, but their have been no problems on my end for a LiteON 760GX. Try getting a new firmware here

There is firmware dated 20-Oct-2008 available for the Lite-On HD-A740GX at http://www.liteonit.eu/firmware-and-other.html

Re: Lite-On HD-A740GX Hard Disk Upgradable?


Hi guys, this is what I did to upgrade 4 ILO HD04 (little brother of the older Liteon 5045, 80GB and less features). Some of the info is thanks to totoro168’s research, here are the steps I take;

4 ILO HD04s (2 x 250GB, 1 200GB and 1 160GB)

  1. to extract the system files off of the current HDD onto your PC.
  • Back-up all your recordings you want to keep on disc.
  • Do a full erase of your HDD while still in the recorder
  • Remove HDD and plug into your PC and copy the system folder most likely called LITEONFAT, it’s around 5 GB in size, give or take.
  1. to format new HDD
  • Plug new HDD in PC and run FDISK to the largest size, set it “active” and unformated.
  • Download fat32format from http://www.ridgecrop.demon.co.uk/do...fat32format.zip.
  • Unzip and save .exe file on your c drive.
  • Click Start->Run and enter cmd. CD to where you extracted the fat32format.exe file, e.g. by typing CD /D c:\
  • In DOS Prompt, type (respect the spaces) this for 64k cluster size, fat32format -c128 f: (replace f: with your appropriate drive letter) You’ll get a warning notice saying “Warning ALL data on drive ‘f’ will be lost irretrievably, are you sure (y/n)” answer yes (y) and in a flash you will see results similar to these,

Size : 250GB 488392002 sectors
512 Bytes Per Sector, Cluster size bytes (65xxx for 64k cluster)
Volume ID is 1bdb:2c1d
32 Reserved Sectors, 59604 Sectors per FAT, 2 fats
7629261 Total clusters
7629260 Free Clusters
Formatting drive f:…
Clearing out 119304 sectors for Reserved sectors, fats and root cluster…
Wrote 61083648 bytes in 0.988463 seconds, 61796609.106193 bytes/sec
Initialising reserved sectors and FATs…
Done
3- Copy LITEONFAT file onto new HDD and install in the recorder.

Now some more info, because your Liteon is a 160GB recorder, if ever you do a full erase with the larger HDD, it will only reformat 160GB, if that happens you would need to go over this process to get the full size again. That means from now on, erase individual titles and not the whole HDD.

You need to format at the 64K cluster size, if left at the 32K cluster size, the next time that the HDD scans after a power failure, all recordings after the 1GB point will crap out, not playable, this would be at about 15 min. 20 on HQ, 30 min. on SP, 45 min. on LP etc.

If ever in the future, by some sheer bad luck, your HDD completely fails and you have no back-up files, do step 2 (without LITEONFAT) and install in your recorder, do a full erase, this will write the LITEONFAT file on the HDD (but only to 160 GB) but at least you can backup the system files and then repeat steps 2 and 3 to get the full size of your HDD.

Hope this helps.

First, thank you both CrazyCanuck and also totoro168 for all the info you have provided here and elsewhere regarding upgrading to larger sized hard drives in Liteon LVW-5045, HD-A740GX and HD-A760GX. But, for the life of me, I had been able to do this just once about 2 or 3 years ago for upgrading a 5045 to 500GB Seagate HD, but unable to do it ever since, despite many, many multiple tries, and have been pulling my hair out to try to figure out why I cannot get this to work. After following through on steps above, then installing hard drive in 5045 or 760GX, I always get the hard drive error code “Action Failed. Please consult our customer service for recovery. (Error Code: 0x810D0004)”. VERY DISCOURAGING!!! Here’s the process I have been using. First, I erase everything off original 5045 hard drive while in 5045 using erase all command. The 5045 appears to do this by just reformatting to a new 160 GB partition taht it names as LITEONFAT. Then, using my PC (with WinXP Pro Operating System), I format a 500GB hard drive using fat32format.exe c-128 e: which formats hard drive to fat32 with 64K cluster size, then I rename hard drive to LITEONFAT just like the original. I then turn off PC, install the original 5045 hard drive I just erased and reformatted in 5045 into my PC, then turn on and using Windows Explorer I copy all files off the 160GB hard drive onto the 500GB hard drive. I have Windows Explorer set up to show all hidden files plus show operating system files to be sure I get all files copied over from the 5045’s original 160GB hard drive onto the fat32formatted 500 GB hard drive, but no matter. But, after doing all that, when I install the 500 GB hard drive into the 5045, I get that same discouraging error code, and cannot access anything off the 500 GB hard drive until I do an erase in 5045, which then will reset hard drive up with only a 160 GB partition. I have tried using a PC with WinXP Pro set up on a FAT32 partition rather than an NTFS partition, I have tried using HDClone and PartitionMagic 8.0, the former only copies the 160GB partition to the 500 GB drive as a 160 GB partition, while PartitionMagic comes back with Partition Table error for the 500 GB hard drive and won’t let me do anything with it. I have tried doing this with the HD-A760GX with upgrading its 250 GB hard drive to a 500 GB hard drive, and I get the same error codes. One thing I have not seen though, is in step 3 the LITEONFAT system file that’s supposed to be around 5 GB os so, I only see folders named as follows: Audio, HDD_video, LiveTimeShift.vob, Picture, and Video. I copy all these folders over from the 5045 erased & formatted 160 GB hard drive to the fat32formatted 500 GB hard drive, but still get the same dastardly error code no matter what I try. Does anyone have any ideas? My suspicion is that this cannot be done using a PC with Win XP Pro Operating System, but I am not sure of anything. Any guidance is greatly appreciated. Thanks!

Hi sqaprof, since the quoted posting you’ve copied I did get my hands on a 740 and 760, tried exactly the same as you did and got the same error code. I tried formatting a 250GB in the 760 and transplanting it in the 740 and that didn’t work either. It appears that a hardrive needs to be formatted by the unit that it’s going to be used in. Liteon might have adjusted their more recent 5045 firmware file to act the same way as the 740/760.

However, here’s a link where a large HDD hack can be found. The same people that prepared this hack made one for the ILO HD04, the 5045, the 740 and 760 (see last few pages of this thread) http://forum.videohelp.com/topic304006.html.

Here’s the link to the hacked files, http://www.twowheels.force9.co.uk/liteon.htm. Pick your region and download the appropriate files.

These files allow users to replace their HDDs up to 500GB, all that needs to be done is flash the new firmware, install new HDD, the error code will come up, erase the HDD and it’s will reformat and be at full capacity of the HDD. No more need to go through the PC to format etc…

I’ve done this to all of my ILOHD04s (4 of them, they’re Liteon clones) and they all work.

I have one ILO with a 500GB SATA HDD. I needed to get a longer 40 pin cable and a mini SATA/IDE converter and that’s working fine.

I’ve haven’t done my 740 or my 760 yet, just don’t really have the need to yet, but I will eventually.

Good luck.

Thnk you CrazyCanuck, that works! And many thanks to MikeB and anyone else who helped make the larger hard drive firmwares! :cool:

Great stuff, thanks for responding back to the forum with your success. bithead9 is another user that also deserves recognition for his work on these files.