Lite-on dvdrw sohw-1633s, not working

vbimport

#1

First I’m new on these forums so don’t get mad if I am saying something stupid :sad: .

I have Lite-on dvdrw sohw-1633s drive that got messed up BAD. First I installed new firmware, because burned dvds had some sort of write errors ( -->bs41 ) and then this happened: I couldn’t burn any dvds only cds, nero complained something about block adresses or something like that. Then my friend came check it out and said that I have wrong firmware installed ( he says that should have been bsos not bs41, ). So I got panicked :confused: and tried to install that other firmware AND official or any other flasher refused to see that drive ( windows could see it and I could still read disks, programs could see it, but flasher couldn’t )

After fighting something like week with this piece of :a , I reinstalled windows ( it seems that nvidia’s new ide drivers were causing something… ). And later I managed to install that bsos ( on my friend computer ) But there is still some sort of problem… drive can read cds ( sometimes they lock up the computer and drive starts making speeding-up and slowing down sound ) drive can’t read those dvds very well they’ll do the same thing as cds, everytime. And writing dvds ( with nero ) burns R-e-a-l-l-y slow, used read buffer goes to 0% and then goes back 100 % and that buffer level jump all the time from 0 to 100%…

And there are still couple of odd things, first nero infotool says that system aspi is not installed ( but nero aspi is installed ). Another rather odd thing is that if I disable ( or uninstall it ) and enable it windows says found new hardware: Lite-on dvdrw sohw-1663s and then it changes “cd-rom”. It seems that windows handles drive as cdrom drive :eek:

So if can help me with this problem, I would be really thankful . If have you something to ask about situation, just ask. And this will be the last time when I touch those firmware upgrades :slight_smile:


#2

check if you writer channal is UDMA 2 or 4 enable.


#3

current tranfer mode: multi-word dma mode 2 :\

And I forgot to mention that I have tried eeprom’s “reset learnt media” ( I still have backup copy just in case ). I just got an crazy idea, what if my friend could give his drive eeprom (drive is identical) and I just install his eeprom and results would be


#4

@ mixa

Don’t mess with another drives EEPROM. Every drive has a unique programmed EEPROM with calibration for that drive. BS41 was good too, it’s a firmware from LiteOn America, was for a while on their website. There are still people who are happy users.
Normally your drive should be Ultra DMA 2 or 4. I don’t know if multi-word dma is fast enough. Could be the problem what causes slow burning. The best way is to post your Nero Info Tool data as a text attachment.

:smiley: Leo


#5

@ mixa
ldw is right on target, your dma ‘current transfer mode’ needs to be ‘Ultra DMA Mode 2’. You can go into ‘device manager’ and delete/uninstall the IDE controllers and restart your system. That will allow windows to reset your DMA to UDMA2…check after resetting and let us know if that works for you.