Lite-on DVDRW LH 20A1L BL01 - Wont read DVD disc at full speed?

vbimport

#1

Hi, first time poster, i dont usually have problems with burners but this is ridiculous and really pissing me off!.

This is a new computer & brand new drive. The drive worked perfectly for my needs, until i installed some crappy DVD copy software…Anydvd and dvd decrypter.

Apparently one of those changed the drive reading speed for DVD media without ever asking, i dont watch DVD movies with this so i dont need to speed down the drive ever. CDR media works fine i can hear it spin and transfer data as it should (full capacity).

Whenever i stick a DVD in there (including my own data backups), there’s no spin-up and the drive is just dead silent, when copying data i can get 6x if im lucky, it takes 40+ minutes to transfer a full DVD (@ 3600-3700 kbytes). Thinking it was a software related issue i removed both programs without success of course. I tested the drive in safe mode just to be sure, same symptoms.

In last resort i was thinking a firmware update would take care of this, but i’d like to know if someone ever had this problem and how they fixed it.

EDIT: I noticed DMA is turned off on the drive…is this normal?

Thanks for your help.


#2

Welcome to the forum :slight_smile:

DMA should be enabled, and this can be the cause of your problem. Enabling it should solve :slight_smile:


#3

Update the firmware…and turn the DMA on.


#4

Ah that did the trick, thank you!.

XP refused to turn it back on by itself, i found a registry tool to force reset DMA on both channels:
http://winhlp.com/node/10

Many thanks again!.