Lite-On DVD Dual layer 1633S, does not read DVD

vbimport

#1

I just got this DVD Writer about 3 weeks ago. It read a DVD when I first got it, and now it almost locks up the whole computer when I put a DVD in it. I haven’t even tried to burn a DVD yet. It did burn a CD-R. I haven’t tried that lately. I tried to update the firmware. I don’t know if it worked, because after the firmware says 100% completed, it never finishes to the point of closing the program. I have to use Windows Task Manager to close it. It takes a long time to boot if a DVD is in the drive. Anything else seems to work fine. Can’t adjust the DVD region settings. It doesn’t have a region set, but can’t set it to region 1 either.
Can someone Help? I can’t find any cusomer support for this company either.


#2

Usually when flashing the firmware, the utility says 100% complete, but might not be finished till possibly 1 min after that. At that point is says its successfull and closes. Was the LED on your drive still blinking when you force-closed the program…in that case you interupted the upgrading process.


#3

shark2000, welcome to cdfreaks :slight_smile:

Have you checked out the DVD Burner forum FAQs?
http://club.cdfreaks.com/showthread.php?t=118794
http://club.cdfreaks.com/showthread.php?t=109986

You could try removing any burning apps you might have installed and then re-install the latest version. Also remove any packet writing software like InCD and DirectCD. Also MusicMatch Jukebox can cause this kind of problem…


#4

I waited hours after the firmware update with no responce.

I checked the DVD burner FAQs, but did not see what my problem is.

I will try getting rid of the INCD, but for now, the kids are whining about going fishing. I’ll try it later. Thank You for you ideas.


#5

Got rid of InCD and now it works.
Thank You for the help.