Lite-On DH16AHY not recognizing Verbatim DVD +r DL for writing

I have tried both ImgBurn and Nero to write a DVD ISO on this drive. Neither program will recognize that a disk is in the drive. I updated the firmware to the most recent available YH14 and still no change. I have written to HP branded disks in the past but have none currently. After much reading, I spent my last $20 to specifically get these verbatim disks and use ImgBurn. Please someone give me another idea before I have to trash the drive and get a new one.

Thanks in advance.

Sorry for the bad info, it is a DH16AYH. I have since pulled the drive and verified IDE settings on the back were set to master and the drive is on the primary IDE channel for the system board. As the IDE cable used has only one plug, it is obviously set to the correct plug as well. While doing this, I also took the time to clean the laser head with a qtip and alcohol. Still no change. The drive is making an odd sound when trying to read the disk as if it were failing. I think i’m running out of options quickly. Any suggestions?

TIA