Lite-On Burner Stuck in PIO! Please Help!

vbimport

#1

I have been working on this for about 3 hours now. I have tried everything from uninstalling the drive and IDE channel in device manager to registry edits. Nothing seems to fix it. Everytime it is redetected it is set back to PIO mode. I have no idea what to do and it’s really frusterating. When I try to play a cd the sound is like slow motion and when I try to play a dvd it is choppy. Any ideas on what could be causing this or how to fix it?
Thanks


#2

Welcome to the forum :slight_smile:

The next thing I’d try is a brand new IDE cable. :slight_smile:


#3

Here there is a related article

http://users.bigpond.net.au/ninjaduck/itserviceduck/udma_fix/


#4

Ok, I will try another cable. The one I’m using is brand new with the motherboard but it’s worth a shot. I have also tried everything in that article, lol. I will get back as soon as I try a different cable.


#5

[I]Off-topic[/I]
Didn’t you just repeat yourself, [B]Arachne[/B]? :bigsmile:
Nice T02 @16X burn by the way :wink:


#6

Yes, I did. But it’s worth a shot. Hey, if it works…:wink:

(Thanks BTW :bigsmile: )


#7

I have put the drive in my roommate’s top of the line E-machine :slight_smile: ($300) and it recognized it and set it to Ultra DMA 2. So I took the cable from that machine and put it in mine and nothing changed. This is so annoying! Could it be a driver issue? In device manager there are 3 primary and 3 secondary IDE channels but only one of the primary is being used (by my SATA hard drive), and the third secondary is being used by my Cd drive.


#8

http://club.cdfreaks.com/showthread.php?t=101616

Read the above link on all the tricks you have to use to get Win to go to DMA. Also try a different IDE port as well as putting your drive on a cable all by itself. Make certain that the cable is 80 wire, google to see a picture.

Lastly, make sure you are using MS drivers, not old nVidia or VIA.


#9

Ok, I’m pretty sure they are 80 cable. They came with my AB9-Pro, and they look like that. Also, I have used my roommate’s cable that worked with my drive on his computer, but it didn’t work in mine. I have tried everything at both those links. Where can I find good IDE drivers?


#10

http://club.cdfreaks.com/showthread.php?t=124001
http://sniptools.com/tipstricks/getting-back-to-dma-mode-in-windows-xp
http://forum.digital-digest.com/showthread.php?t=61905

Try these. There is an MS link as well, I just cannot find it, as usual.


#11

Those are pretty much the same thing. None of that stuff worked. Could it be an issue with my motherboard? Or maybe I should try some different drivers?


#12

Does anyone have any more ideas? This is killing me! It seems like nothing is fixing it and I don’t know what to do next.


#13

I was just thinking, I also have a virtual drive that I set up with Alcohol 120%. Could that have any effect on this problem?


#14

You must have an old Lite-On burner model if it’s in UDMA2? Anything from 3S-series up runs in UDMA4 on 80-wire cable. If UDMA2 was on 40-wire and you tried with both 40 and 80-wire in your system, then there may well be an incompatibility with your mobo. Try it in all possible combinations as Master/Slave/Cable Select on either connector of the ribbon.


#15

P.S. - Do a Search here for JMicron (your IDE Controller) and its compatibility with optical drives.


#16

You are connected to the motherboard right?


#17

Abit AB9-Pro is one of those new Intel boards without PATA in the chipset. They use a JMicron chip to give one PATA channel.


#18

This is from maineman:

http://winhlp.com/WxDMA.htm

I used it and restored dma.


#19

It’s finally working!! Some guys on another forum pointed me to updated JMicron drivers (http://www.station-drivers.com/page/jmicron.htm) because the ones with my MoBo were outdated. Restarted my computer and my drive is working great! Plays CD’s and DVD’s fine and rips 10 times faster then it used to! The only thing is now my drive isn’t showing up on any IDE channel so I can’t confirm the DMA speed it is running at. Thanks everyone for the help!! :bow: I’m so happy right now! :slight_smile:


#20

Thanks for the follow-up. We are bound to find more and more of these MBs with chipsets that are not setup for optical drives. Your problems are bound to save a lot of other users endless grief.