Lite-On 812 Buffer Underruns

I just recently obtained a Lite-on 812, however so far I’v wasted 6 DVD’s in trying to fix this slight problem where burning something takes around the 3 hours mark.

I’ve already switched my nForce Drivers to the default PCI which comes with MS.

Replaced cabling, switched the Burner from Master to Slave and back again, I’ve checked the windows setting and according to the windows Device Manager it states its running on UDMA, as well as the Nero Info tool.

As it stands, I’ve pretty much tried everything here as suggested on the forums, and still no luck. I even did a check by enabling the speed metre on Nero as well as a the buffer Metre. The buffer never filled or stayed at 20%.

Just to make sure everything was A-Ok I ran the burst interface test on it and it reported a nice 22MB/s burst transfer. Yet the burner still only burns at 500KB/s

My configuration is:
Athlon 2500+
Gigabyte 7N400-L
1GB of DDR RAM
Windows 2000 SP3
IDE 0: (Master) Western Digital 120GB 8MB Cache
(Slave) Maxtor 80GB HDD
IDE 1:(Master) LiteOn 812
(Slave) Pioneer DVD Rom Drive

Note: Yes I am using the default windows Drivers, Yes the BIOS did set the drive to UDMA 33, Yes Windows does report as UDMA being Used. No I havent tried a different OS (I am working on Linux ATM).
No I havent tried XP yet. No the CPU during the Burn was sitting at 1%. Yes the Hard drive lighting up occasionally.
No I havent tried a CD-R burn yet. The Media I was using was the supplied LiteON Media (dead), plus 4 sets of Sony’s DVD+R Media (I would of wasted less but It has no TEST MODE!!!).
Both Nero and Record DX started fine then stalled, ie: after a couple of minutes into the burn it jumped from 9:minutes to 219 minutes.

edit:
Would setting a Region Code make it work? I dont intend to make it play DVD’s why I have the pioneer for.

Is it possible to try the burner in another PC?

Will try on a different PC, however I Just ran it succesfully under Linux, and burnt a DVD at 4x, never did the light blink once.

I used k3b. So this reduces it to a windows problem I think.

Info retrived in hdparm:
root@zarathustra:/usr/bin|#>hdparm -i /dev/hdc

/dev/hdc:

Model=LITE-ON DVDRW SOHW-812S, FwRev=US0F, SerialNo=2004032200044188
Config={ Fixed Removeable DTR<=5Mbs DTR>10Mbs nonMagnetic }
RawCHS=0/0/0, TrkSize=0, SectSize=0, ECCbytes=0
BuffType=unknown, BuffSize=0kB, MaxMultSect=0
(maybe): CurCHS=0/0/0, CurSects=0, LBA=yes, LBAsects=0
IORDY=yes, tPIO={min:227,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio1 pio2 pio3 pio4
DMA modes: mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 *udma2
AdvancedPM=no
Drive conforms to: device does not report version:

  • signifies the current active mode

Although while burning a CD the buffer status was shown… where as while burning a DVD it never mentioned what it was doing.

So now I am stumped, it works under Linux, yet Windows Reports UDMA being used however both Nero and Sonic cause the Burner to underrun.

I am using the standard MS provided Drivers, anybody here use Win2K3 with this type of burner? or should I move upto XP?

Was the pioneer dvd rom drive running on the linux system as well? something rings a bell about a pioneer drive being in the system and being taken out fixing the issue, I’ll try and search and see if I can remember that thread

I am not sure what you mean.

Well both drives are plugged in, the Pioneer was not being accessed at the time… in either OS.

Either which way here’s the dmesg report from Linux:
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
NFORCE2: IDE controller at PCI slot 0000:00:09.0
NFORCE2: chipset revision 162
NFORCE2: not 100% native mode: will probe irqs later
NFORCE2: BIOS didn’t set cable bits correctly. Enabling workaround.
NFORCE2: BIOS didn’t set cable bits correctly. Enabling workaround.
NFORCE2: 0000:00:09.0 (rev a2) UDMA133 controller
ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:DMA, hdb:DMA
ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdc:DMA, hdd:DMA
hda: WDC WD1200JB-00CRA1, ATA DISK drive
hdb: MAXTOR 6L080J4, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hdc: LITE-ON DVDRW SOHW-812S, ATAPI CD/DVD-ROM drive
hdd: Pioneer DVD-ROM ATAPIModel DVD-116 0122, ATAPI CD/DVD-ROM drive
hdc: ATAPI 40X DVD-ROM DVD-R CD-R/RW drive, 2048kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20
hdd: ATAPI 40X DVD-ROM drive, 256kB Cache, UDMA(66)

The HDPARM :/dev/hdc:

Model=LITE-ON DVDRW SOHW-812S, FwRev=US0F, SerialNo=2004032200044188
Config={ Fixed Removeable DTR<=5Mbs DTR>10Mbs nonMagnetic }
RawCHS=0/0/0, TrkSize=0, SectSize=0, ECCbytes=0
BuffType=unknown, BuffSize=0kB, MaxMultSect=0
(maybe): CurCHS=0/0/0, CurSects=0, LBA=yes, LBAsects=0
IORDY=yes, tPIO={min:227,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio1 pio2 pio3 pio4
DMA modes: mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 *udma2
AdvancedPM=no
Drive conforms to: device does not report version:

  • signifies the current active mode M settings on both drives
    root@zarathustra:/home/myrddian|#>hdparm -i /dev/hdd

/dev/hdd:

Model=Pioneer DVD-ROM ATAPIModel DVD-116 0122, FwRev=E1.22, SerialNo=
Config={ Fixed Removeable DTR<=5Mbs DTR>10Mbs nonMagnetic }
RawCHS=0/0/0, TrkSize=0, SectSize=0, ECCbytes=0
BuffType=13395, BuffSize=64kB, MaxMultSect=0
(maybe): CurCHS=0/0/0, CurSects=0, LBA=yes, LBAsects=0
IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio1 pio2 pio3 pio4
DMA modes: sdma0 sdma1 sdma2 mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 udma2 udma3 *udma4
AdvancedPM=no
Drive conforms to: device does not report version:

  • signifies the current active mode
    I am no sure if thats information overload, but thats all I can get at the moment in Linux, whereas Windows all I get is

Device is using UDMA, can it be an ASPI issue? or is it just 2K not liking ATAPI DVD Burners?

http://home.iprimus.com.au/deo/hosted/forceaspi_4.6.zip
will load and tell you if the aspi layer is right, should set everything to 4.6.