Lite-On 1633S BPSA Flashed To Lite-On 1653S CS0T - Having DVD Region Error

vbimport

#1

Hi,

I recently flashed my Lite-On 1633S with Compaq OEM firmware to a 1653S CS0T after reading that the newer firmware had been hacked so that there wouldn’t be any DVD regions.

After flashing the firmware, I ran the LtnRPC tool and made sure the DVD region was disabled. Then when I went into “My Computer” and selected my DVD drive and opened up the hardware properties, I couldn’t see the “DVD Region” tab and therefore I knew that it had been removed and that my drive was now region free.

Now today, I looked at the hardware properties of my DVD drive and I can see the “DVD” region tab and it is telling me I have two changes left and that I haven’t selected a current region.

What has gone wrong? I have definately flashed the firmware correctly as I can see both red/green LEDs when reading/burning.

Please can somebody bring some light to this issue. Thanks in advance.


#2

Firmware doesn t change the region. You need to run LTNRPC program to do that on Liteon drives.


#3

Thanks for replying.

I used the LtnRPC, but the DVD region setting in Windows XP still appears.


#4

Did you put a DVD in the drive? Works best that way.


#5

Thanks for replying.

Yes, I put a region 2 DVD into the DVD drive, it was able to play and then when I looked at the DVD region settings under the DVD drive properties, I was informed that I had only one change left to the DVD regions and the current region selected was region 2.


#6

Put a blank dvd in the drive and run LTNRPC.


#7

Thanks for your reply, I tried inserting a blank disc and running LtnRPC and still nothing has hapenned. DVD regions have been disabled on the drive, however in the operating system the hardware properties tells me that I have two region changes remaining…

I’ll use DVD Region Killer to play any DVDs from now on.

Thanks for your help :slight_smile: