Linux support voor Wireless PCI Card Planet

vbimport

#1

Do WL-3560 and WL-8310 support Linux and FreeBSD system? Where can I find related information?

WL-3560 and WL-8310 are using Atheros solutions. Their Linux drivers are now available on this web page: https://sourceforge.net/projects/madwifi/, and FreeBSD drivers are available on http://www.freebsd.org/.


Dolgelukkig met de melding dat mijn WL-8310 ook Linux ondersteuning had. Geklikt op link van Planet.

Weet alleen niet wat ik met deze site aanmoet. Of kan ik ervanuit gaan dat ik uit de laatste stabiele kernel versie hetzelfde haal? Weet nl niet hoe ik appart een driver zou moeten installeren onder Linux.

Graag wat hulp


#2

http://www.mattfoster.clara.co.uk/madwifi-faq.htm#get


#3

Kort, maar krachtig. Bedankt.

Trouwens, is het mogelijk om Linux in grafische omgeving te configureren en later te kiezen om de tekstmodus als standaard te nemen. Of installeer ik dan onnodig veel wat de prestaties naar beneden helpen. (wil Linux op een pc als webserver gebruiken. al enige malen linux geïnstalleerd om een induk te krijgen. grafische omgeving is tijdens het serveren niet nodig)


#4

Neuh , gewoon X installeren , maar niet automatisch laten opstarten. Dan kun je nog altijd kiezen of je X wilt gebruiken (startx en daarna ctrl-f7 om terug te komen in x) of gewoon een tekstconsole (ctrl-f1 t/m 4 geloof ik). Het kan wel een crime zijn om nVidia opengl drivers er op aan te praat te krijgen.


#5

Je kunt eens naar webmin (www.webmin.com) kijken. Deze webinterface kan haast alle pakketten op een Unix (en dus ook Linux) systeem configureren op een snelle en overzichtelijke manier. Ik gebruik het al jaren en ik ben er erg over te spreken.

De meeste distro’s bieden tegenwoordig aardige setupomgevingen. Redhat heeft Kudzu, SuSe heeft Yast etc etc. Ook de varianten die in textmode lopen zijn goed te bedienen en overzichtelijk!


#6

Blijf nog maar even in deze thread hangen…
Tijdens het installeren van Redhat 9 heb ik gekozen voor een server-installatie. Om alles nog een beetje makelijk te kunnen configureren wilde ik wel de x-omgeving met desktopomgeving geïnstalleerd hebben. Tijdens het instellen van de videokaart kos ik voor S3 Trio64V (4 mb) ipv S3 Trio64V+ (1 mb). Met afsluiten vd installatie gaf ie een aantal kills. Kan iemand mij uitleggen hoe ik in de tekst-omgeving deze fout kan herstellen.

//sorry, te voorbarig. Kon gewoon de x-omgeving starten. Misschien wel niet goed voor de videokaart, maar alles werkt weer.


#7

XF86Config


#8

Nog eentje. Heb dus vrijwel zonder problemen redhat 9 geïnstalleerd. Nieuwe kernel gedownload (linux-2.6.6.tar.bz2) om netwerkkaart en usb-stick aan de praat te krijgen. Veel info opgezocht om een kernel te compileren.
Hierin wordt gezegt dat in /usr/src een symbolic link met als naam linux zou moeten staan. Bij mij staat hier alleen:

  • debug
  • linux-2.4
  • linux-2.4.20-8
  • redhat
    waarvan ik vermoet dat linux-2.4 de zogenoemde symbolic link zou moeten zijn.
    In de omschrijving staat: wis de symbolic link linux met het commando ‘rm linux’ doe ik dus nie zomaar…

Als ik in grub.cfg kijk zie ik:


#boot=/dev/hda
default=0
timeout=10
splashimage=(hd0,0)/grub/splash.xpm.gz
title Red Hat Linux (2.4.20-8)
root (hd0,0)
kernel /vmlinuz-2.4.20.8 ro root=LABEL=/
initrd /initrd-2.4.20-8.img


#9

Het is zo’n beetje de conventie om een symlink, genaamd “linux” naar je kernelversie te maken. Dit kan dus best goed zijn dat dit /usr/src/linux-2.4.20-8 is. Helaas worden deze conventies niet altijd gehanteerd, waardoor deze simlink wel eens afwezig kan zijn. Als deze er niet is, hoef je deze ook niet te verwijderen :). Indien er niets is dat linux heet (in de /usr/src dir) dan kun je dat ook niet verwijderen he?

Je grub.cfg ziet er prima uit hoor. Je kernel is vmlinuz-2.4.20.8 en deze wordt geboot nadaat de initial ramdrive (initrd) geladen is. Niets bijzonders aan :slight_smile:


#10

Ok ben nu verder. DWZ

cd /usr/src/linux-2.6.6
make xconfig

–>

  • Unable to find the QT installation. Please make sure that the
  • QT development package is correctly installed and the QTDIR
  • environment variable is set to the correct location.

Komt dit doordat ik geen pakketten van “x-softwareontwikkeling” heb geïnstalleerd? Pakketten van “kernelontwikkeling” heb ik wel geïnstalleerd.

//laat maar. Was vergeten de KDE-ontwikkeling te installeren. Hier zit QT-devel ook bij.


#11

Ja, ik blijf bezig

wanneer ik commando make xconfig geef wordt er na veel gedoe qconf gestart. Hoe komt dit?


#12

Hmm ik heb nooit handmatig mijn x-server geinstalleerd (is voor mij nooit nodig geweest), maar ik denk dat dit komt omdat je de QT libraries niet had geinstalleerd…

Wat heb je gedownload? Over het algemeen kun je je heel erg veel werk besparen door RPMs voor je Redhat systeem te downloaden!


#13

Sorry, was nie helemaal duidelijk.

Commando ‘make xconfig’ vanuit de kernelsource zou het xconfig menu moeten starten waarin ik grafisch mijn kernelonderdelen bijelkaar zou moeten kunnen zoeken. Dat er een qconf werd gestart als reactie op mijn voorgaande commando begrijp ik niet helemaal. In deze qconf kan ik overigens ook alles wel vinden hoor.

Nog een vraag. Tijdens de nieuwe kernel samenstellen komen er zo verschrikkelijk veel onderdelen langs waar ik nog nooit van gehoord heb.

  • Is er ook een site oid waar alle onderdelen wat verder uitgelegt worden.
  • Is het mogelijk om de basisconfiguratie van mijn huidige kernel (de standaard bij Redhat 9), over te nemen en hier de rommel bij te zetten die ik nodig acht (WiFi en USB).

#14

edit is nergens te vinden. Vandaar nieuwe reply…

Qconf is de nieuwe kernel config tool en de vervanger van xconfig. Las zojuist dat deze vanaf linux-2.5 inzit


#15

Als ik het me goed herriner kun je een opdracht “make oldconfig” geven. Dan wordt 2.6 gecompileerd met de settings van je 2.4 kernel en wordt voor ieder nieuw item gevraagd of je het wel of niet mee wilt compileren (zei het embedded in de kernel of als module).


#16

Na het configureren van mijn nieuwe kernel heb ik het commando ‘make bzImage’ gegeven.

In de console komen nu alle onderdelen langs geloof ik…

opeens zie ik tussen de rij hetvolgende:

CC  drivers/video/fbmem.o
drivers/video/fbmem.c: In function `fb_cursor':
drivers/video/fbmem.c917: warning: doorgeven van argument 1 van `copy_from_user' laat qualifiers van doeltype van pointer vallen

Wat betekend dit?


#17

In niet programmeurstaal: er staat mogelijk een fout in de programmacode van fbmem.c

Dit is echter slechts een warning. Alhoewel iedere programmeur geleerd krijgt dat je software zonder een enkele warning moet compileren, komt het in de praktijk echter zelden voor dat software ZONDER warning compileert. Simpelweg gezegd: negeren die hap :slight_smile:


#18

Harstikke leuk. Mijn eerste kernel geconfigureerd, gecompileerd en hij start nog op ook…
Welliswaar met veel … [mislukt] regels. Hierover dan ook de volgende vraag. Is er een file oid waarin dit staat samengevat, zodat ik 'm kan herconfigureren. Ik heb de System.map ook naar m’n /boot gekopieerd. Weet alleen niet hoe dat ie werkt.

Ook mijn netwerkkaart wordt nog niet herkend. Dwz mijn kaart staat er niet bij. Kan iemand mij vertellen hoe ik een patch moet installeren. Geloof nl dat ik die wel kan vinden voor mijn kaart.


#19

Hmm ik weet niet of er standaard een logboek van de kernel compilatie bij wordt gehouden. Zoals altijd zal ook dit weer eens afhankelijk zijn van de distro die je gebruikt. Je kunt eventueel ervoor zorgen dat alle output die tijdens het compileren gegenereerd wordt, niet naar het beeld maar naar een txt bestand wordt gestuurd. Als ik me goed herriner gaat dat op dezelfde manier als onder dos: commando >bestand.txt
System.map hoef je niet perse naar je /boot te kopieren, maar het is wel netjes. Dit zorgt er namelijk voor dat allerhande cryptische namen omgezet worden in strings die je als mens zijnde wel kunt begrijpen. Well done :).

Een patch voor je netwerkkaart? Bedoel je een echte source code patch voor je kernel, of bedoel je een additionele module? Een patch voor je kernel voer je in middels het commando “patch”, terwijl je een module kunt laden net “insmod”.


#20

't is nog erger.
Kernel doet eigenlijk helemaal niet zoveel. De map /boot bestaat helemaal niet meer, dwz hij stond vol met allerlei files en nu enkel een kernel.h of zoiets. Kan dit komen doordat ik niet alles juist in grub.conf heb ingevoerd?

...
title Red Hat Linux (2.4.20-8) 
root (hd0,0) 
kernel /vmlinuz-2.4.20.8 ro root=LABEL=/ 
initrd /initrd-2.4.20-8.img

title Red Hat Linux (2.6.6-eigen)
root (hd0,0)
kernel /vmlinuz-2.6.6

moet hier ook nog die initrd bij ofzo, of had die root er niet mogen staan.?.>??