Linux Install to Striped Raid Array

vbimport

#1

This might be a bit of an obvious thing to all the Linux Gods, but since I’ve only used linux for a few hours in my life, I’m practically a linux newbie.

I’ve been trying to install a new Debian3 (current distro) to a striped array, but when I try to get it recognise the raid array, it doesn’t seem to recognise the drivers on the disc.

I have two files ITERAID.O & ITERAID.SMP (from the manufacturers Debian driver set) which are in the root directory of an MSDOS formatted disc.

Instructions indicate that they should be in the root directory, but it doesn’t specify whether Linux has a proprietary Floppy disc format, or is compatible with dos/fat16 format floppy discs.

I have 20GB of unpartitioned space with Linux’s name on it, well not really, but it will when I can get Linux to find the array.

What can you suggest?

I’d install Linux to a standalone disc, but I’d like a performance comparison between windows and linux, and installing Linux on a standalone, and windows on striped raid, it just wouldn’t be fair :wink:
Besides the standalone has approx 80GB of downloads/mp3/movies/etc on a secondary partition which I use for storage, and I only have a 2GB partition which could be used for linux, severely limiting what I can do with it.

Any sensible suggestions?


#2

This link - http://www.james.rcpt.to/programs/debian/raid1/ - details how someone else finally got software raid support into an older version of debian. He installed debian first, then added RAID support later.

linux does not have propietary floppies :smiley:


#3

Unfortunately I did find that link before, but it details software raid, not hardware raid.
Also, the guide needs to be Raid 0 (striping) rather than Raid 1, although from a hardware perspective, the matter is trivial.

I’m certainly glad that Linux Floppy disks don’t have a proprietary format :slight_smile:
Pity that Linux can’t be installed directly to fat16/Fat32 partitions, I’d know where I was with those, and could easily make suitable partitions directly :slight_smile:


#4

Perhaps a more newbie friendly distribution would be in order? dee ehn will probably have some input on your solution, though :smiley:

i also found this - http://www.ram.org/computing/linux/dpt_raid.html


#5

Yeah, I suppose you’re right :wink:

Maybe RedHat :expressionless:

I was thinking more a stable release, rather than leading edge / newbie friendly approach, as I’m used to steep learning curves and not afraid at diving in at the deep end :wink: You don’t learn much about the ocean by dipping your toe into it :wink:

It’s frustrating being defeated before the first step, IDE/RAID (hardware recognition), especially when you apparently have everything you need :frowning: Drivers on floppy, Unallocated HD space (allocated for linux) all the drivers / proggies I expect to want to use straight away, which aren’t part of the distro. Lololololol!

Might just see I can scavenge a smaller 13GB HD out one of the other PC’s to play around with Debian with that before going the full hog with a raid 0 install :wink:


#6

Hmmm what kernel version is your Debian installer using? I remember using Woody (3.01) about a year ago and it was still equipped with kernel 2.2.x. Since the 2.4 series the ATARAID kernel drivers have been improved immensively. I don’t know for sure, but I wouldn’t be wondered if kernel 2.4.20 and up could resolve this issue… without any need for third party drivers.

Linux 2.6? That may give some problems once again. Quite some drivers have been deleted from the kernel (as for my RAID controller as well :() and the manufacturers of ‘cheap’ RAID controllers take their time to develop suitable drivers… if they develop any at all…


#7

Since then it doesn’t seem like Debian have an updated distro -
Woody has kernel 2.2 as the default (vanilla) installation but I can try the 2.4 install if you recommend :wink:
Note that Debian is geard towards stable/proven/mature releases rather than bleeding edge ( or at least their packagers are soo far behind it’s embarassing;)

I have the drivers from the manufacturer for debian linux (and a bunch of other distros), but the installer checks for the debian raid driver but doesn’t recognise them :confused: on the floppy’s root directory.
Do I need to mount the floppy before I start the installer? Or does the installer package automatically mount the floppy when required? Since windows mounts + unmounts automatically, I’m just a tad :confused:

Being a Linux Newbie, I’m like wtf?

Since I have 20GB set aside for Linux on the array, it’d be nice if I could install directly to the raid array, rather than newbiely attempt to port to the raid array from another HD :expressionless: Just asking for trouble that :wink:

Still wondering, if K2.4 doesn’t recognise the raid chip, how to get the installer to recognise iteraid.o & iteraid.smp as the required driver files at install time.


#8

Is it onboard raid or a PCI-card? Manufactorer of the chip?
//Danne


#9

Onboard raid/IDE, but I’ve tested the windows reference drivers, and they work fine with winxp. I’d expect the same for linux.

Manufacturer: ITE (chip model IT8212/f)
http://www.ite.com.tw
Drivers http://www.ite.com.tw/pc/LinuxDriver_it8212_092005-09.zip
The driver set for linux is pretty much comprehensive. Whether they work is a completely different matter.


#10

You most likely need to modify the boot floppies to load the ITE driver in order to make the installer detect the stripe.
//Danne


#11

That’s gonna be interesting. :confused:
It’s a fresh install from debian Distro CD’s to a striped array?

update
I now have it recognising the driver on the floppy, it takes about 10secs to read the driver from floppy and sits thinking for about 4 minutes, but doesn’t recognise the disk array as a storage device after loading the driver. Do I need to mount the array somehow? And how do I do this?


#12

The installer should be able to see the array after you’ve loaded the module.
According to this guide (link) it should be enough.
//Danne


#13

If you are using a software RAID (such as Highpoint, yes it is a physical chip, but is really a SoftRAID) you cannot install Linux if the kernel version is 2.6.x. Kernel 2.6.x does not support any software type RAID devices. I had this problem when changing from SuSE 8.2 to 9.1. I’m not sure if this is your problem but thats my 2 cents. :slight_smile:


#14

Um, software raid and softraid differ slightly. Lets call hardware based softwareraid as Firmraid.

I can be relatively assured that the IT8212 is definately a firmware raid device as it would significantly lower costs for the hardware manufacturer (just like winmodems :z).

When you say that firmraid is not supported does this mean that the 2.6 kernel will refuse to operate this hardware, even if drivers supporting kernel 2.6 are available:confused:? Or does the kernel just not include drivers directly for firmraid devices?

If 1), that’s just plain stupid, as many consumer level linux users will be incredibly miffed. It really wouldn’t make sense to force users NOT to use these devices.
if 2), Np since the installers do ask for drivers before installation, although it doesn’t even notice my striped array :Z

I have since given up trying to install directly to the raid array and have almost completed moving almost 80GB of data from my single disk to the striped raid array with the intention to free up the secondary partition ( current 90GB storage logical drive+ secondary partition will be replaced with a primary partition ) so I can partition the drive as per recomendation for linux (lots of logical drives/etc).

I will then move the /usr and the /swap to the striped raid array later, after I have linux detecting the array correctly.

I hate doing this though, as it relies on 2 disk volumes, rather than a single volume solution (I consider a single disk as an volume, and also multiple disks as an volume where they are used as a single storage device) meaning I can’t pick up the standalone disk and use it somewhere else, while keeping the raid volume operating (not talking about hot-swap here either).

Reduces my computers flexibility :frowning:


#15

I’ve been doing some reading on the soft(ware) raid part of Linux 2.6.x and it seems that this is still under contstruction. New drivers should enable the feature again, but for now you’re “stuck” with the 2.4 kernel branch. Luckily enough, the 2.4 is quite mature and still maintained. I’m just using 2.6 on one system; all the other systems still run on the latest 2.4 and that works just fine.


#16

Okies, I’ve installed Linux (Debian with Kernel 2.4) and it detects the raid array fine.
I do however have a niggling little problem!

I can’t seem to configure the Xterm for my mouse :frowning:
Linux has some ways to go before it becomes streamlined for desktop distribution :wink:

Methinks I might try the standard “microsoft protocol” :wink:


#17

What is the problem with your mouse? Did you properly configure the XF86Config file?


#18

Yes, about 5 times :frowning: Unfortunately, each time, I also have to reconfigure the monitor parameters, and alot of other stuff as well :o

I tried 2 button mouse, 3 button mouse (without 3rd button emulation) 3 button mouse (with emulation), and intellimouse (as recommended by some internet guides) and logitech (which is for classic logitech mice).

Methinks the next try I will just use “Microsoft mouse” (sigh).

Xwindows starts up, I have a criss/cross screen, and the mouse works, then it dumps me back to the prompt with an error complaining about the mouse :eek:
More information later, when I’m at home!


#19

It starts to load device drivers on KDE then dumps back to Command line with message:
"(EE) xf86openserial: Cannot open device /dev/input/mouse
No such device.
(EE) Generic Mouse: Cannot open device “Generic Mouse”
(EE) Preinit failed for input device “Generic Mouse”


Fatal Server Error:
Caught. Signal 11. Server aborting.
"

My mouse is configured as /dev/psaux, and as various PS2/microsoft/mouseman/intellimouse/etc.

I’ve cat’d the /dev/psaux and verified it as the input (lots of weird crap on the screen).
I’ve logged in as “su” and run xf86config and confirgured everything.

Then I’ve saved the XF86Config file to /etc/X11 as is specified.
Logged out of root, back into my main account and run startx !
I’ve run startx under su, nothing works!

And it just keeps spitting out the same error!

Why is it still checking /dev/input/mouse? rather than the /dev/psaux as configured?

Help!

/me am not laughing anymore!
/me is losing patience with linux!


#20

Is /dev/input/mouse mentioned anywhere in XFree86’s config?
//Danne