Linux/CDROM problem

vbimport

#1

I have a small home server. This server runs on Gentoo Linux 2004 with kernel 2.6.9-r6. On this server I use Samba, ProFTPD, MySQL, Apache, PHP etc. Also, there’s VMWare Workstation 4.5.2 installed.

Here’s the problem: In VMWare I’ve got a Windows 2000 pro machine running. Whenever my IDE CDROM (old Aopen 32x) is attached to the system, the VM crashes after a few days because the / filesystem (hda5) has no free space left. Turning my computer off and on again fixes this problem (I can’t do a reboot, because my harddrive isn’t recognized anymore). After the reboot hda5 has regained all the free space it should have and it all works fine for a while. Also, I see all kinds of errors on /dev/hdb (that’s the primary slave, the cdrom is on that channel) in the kernel logs.
When the CDROM is detached from the system, everything works just fine like it should: no leaks, no crashes or whatsoever.

One’d think that this CDROM is just faulty, but I find it hard to believe, because it always worked fine on this system. I pulled it out and tried it on two other systems (Win XP and Ubuntu Linux) and I can’t find a single problem, it just works alright.
I tried all the logical things: exchange IDE cables, alternating IDE configuration etc etc but that all doesn’t yield me anything.

Does perhaps anybody have an idea what’s going on here? It’s not that big of an issue as I hardly/never use the CDROM on my server, but I’m really curious what this issue could be.


#2

Not that I use Linux but have you tried a kernel upgrade?
//Danne


#3

I have two other kernels on the system and I know it does the same with a somewhat older 2.6 version. Thing is that this isn’t that much of an issue and compiling a new kernel means I have to do quite some work on the VMWare installation (because of the devfs), so I’d rather not do that, unless it’s really neccesary.


#4

Can you post the errors you get?
//Danne


#5

Sure… VMWare doesn’t usually give me an error (it just crashes and that’s it), but here’s the error from the kernel’s log (/var/log/messages):


Feb  6 11:55:22 tuxserver hdb: status error: status=0x7f { DriveReady DeviceFault SeekComplete DataRequest CorrectedError Index Error }
Feb  6 11:55:22 tuxserver hdb: status error: error=0x7fIllegalLengthIndication EndOfMedia Aborted Command MediaChangeRequested LastFailedSense 0x07
Feb  6 11:55:22 tuxserver hdb: DMA disabled
Feb  6 11:55:22 tuxserver hdb: drive not ready for command
Feb  6 11:55:23 tuxserver hdb: ATAPI reset complete

Note that these 5 lines are repated a gazillion times; it’s always the same error.

BTW: it doesn’t matter wether my VM is equipped with a (virtual linked) ATAPI drive or not.


#6

Looks like a dodgy IDE/ATAPI driver or a bad drive.
//Danne


#7

Well yes that was my conclusion as well, but

  • I installed the right driver (it’s compiled into the kernel) and it works fine with all three harddrives on it (hda, hdc and hdd)
  • The drive works fine on other system and it worked fine on this system for ages… this problem started a few weeks back without any clue (didn’t install any new software, no updates etc etc).

Strange huh?