Limited 2x Read Speed w/PX-760A

OK, I can’t figure out what to do in order to correct this problem with my new PX-760A…

When ripping a DVD to my HDD w/DVD Decrypter using the default settings, it only reads at 2x!!! :rolleyes: I have installed, re-installed, everything else I can think of - and can’t get it to rip at faster than 2x… any suggestions!!! :confused: I never had this issue with my PX-716A which was on the same setup using the same settings…

SpeedRead. Either use PTP to enable SpeedRead or do it manually…with the tray closed and empty, hold the eject button down until the LED blinks green three times, then release. Load the disc, and it should take off for ya. Manual works until you eject the disc…then it resets to disabled.

:doh: Just put a check mark there in PlexTools Professional XL 3.09, recycled, and then restarted the entire process - BIG thanks bob11879! :clap:

Can you do that with Plextools Professional free version, doe that have that setting? I think its version 232.a. My XL will not reinstall because I reformatted my HD.

Hi Alan
RE XL. If you saved your key before reformatting you can re-install XL. Failing that, a phone call to Plextor and they will supply you with a new ID

Thanks Dee, now I have to find the phone number for Plextools maybe its in the box somewhere. Yes, I was impatient and forgot to save the key. I even have a special little book where I save all my key numbers and serials and passowords etc. and I just overlooked it.

Support numbers are here http://www.plextor.be/technicalservices/support/contact_support.asp?choice=Contact%20support

Info on keys here http://www.plextor.be/technicalservices/support/faq/faq.asp?choice=FAQ,%20tips%20and%20tricks

Here’s a tip from their European homepage on how to back up the licence file and avoid this inconvenience in the future :slight_smile: .

Heh, too late! You can delete this, Dee :slight_smile:

Thanks to you both Dee and Cressida, you have both been very helpful, I have e-mailed them with my problem and I included the serial number of my drive so they can verify it. I hope they respond. For some reason, I think my drive ( from Newegg.com) Retail, just came with a trial version of Plextools XL, I may be wrong, I know Plextools Professional 2.32a is a free program, but the XL has to be bought after the trial even if you bought the drive. I may be wrong.

That’s right, alan1476, the bundled XL is a trial. The full version requires activation with Plextor, that’s why it doesn’t survive a format or installation on a new system. I would expect that Speedread can be enabled in the free version as well (don’t have it handy right now).

Gosh, Cressida, I just noticed you are from Belgium. Thats where Plextors main facilty is for PlextoolsXL, I believe. Somehow I think Plextools is whole different company than Plextors drive business. Just a guess.

Plextools and PlexTools XL are licensed sw from Plextor Europe. The business units are independent. I understand Plextor America even has to pay royalties to Plextor Europe on their “free” version…

I had that feeling but wasn’t sure.

Plextools read test ( Got it all worked out, thanks to everyone)http://club.cdfreaks.com/attachment.php?attachmentid=81297&stc=1


Great burst rate:

http://club.cdfreaks.com/attachment.php?attachmentid=81332&stc=1


I’m having the same issue with my Plextor 760A. However, DVD5s rip just fine, but DVD9s only rip at 2x, no matter what I do. I’ve tried the manual 3 light blink method as well as using the plextortools (updated to 2.35) speedread option. Neither seems to have had any effect whatsoever. Please help!

~DNBGTakeda

ps, I also have the newest firmware, 1.03

update Ah, there we go. Very odd, I changed the ide channel options to Ultra DMA 66 and suddenly it worked. Funny thing is, it was set to auto before and was already on Ultra DMA 66. In any event, all is well with 760 now. Cheers!

Auto does not mean it will automatically use the fastest settings but that Windows will decide itself. Personally i’d rather not trust any MS Softwares decision making capabilities :disagree:

k, for some reason it’s back to limiting the speed to 2x when reading dvd videos. I’ve reinstalled the plextools software and checked the speedread option and have even tried doing the manual bit holding for 3 secs, however nothing seems to be working. Is my drive broken? or is there any firmware that I can use to just remove the stupid speedlimit thing all together? Help!

Many thanks!!

~DNBGTakeda

In the hardware-manager, uninstall the IDE channel the drive is connected to and reboot.

okay, just tried that. still not working, unfortunately. :sad: For some reason, I can rip my old DVDs that are on DVD5s fine, but double layer dvd roms are limited to 2x, even with the manual method as well as the speedread option in the plextools.

The drive will be reading quickly, but when I do the read test in the plextools on a DVD9, I hear stuttering in the drive, then it starts to go at 1.5x-2x. And I’ve tried a few different dvd9s too, so I don’t think it’s just that my dvds are scratched or anything.

:confused: :confused: :confused: :confused: