Liggy's ND-3550 bitsetting firmware

Liggy, your 1.04bt firmware works properly for bitsetting but the 1.05bt does not. Booktype stay’s @ +R after the burn with 1.05bt. Hopefully you can take a look at it. I intend to flash this 3550 to 4550 as soon as you release the tools but for now I patiently wait. It would be nice to get 1.05bt working in the meantime.

FYI from ImgBurn:

_NEC DVD_RW ND-3550A 1.05 (USB)
Current Profile: DVD+R

Disc Information:
Status: Complete
Erasable: No
Sessions: 1
Sectors: 1,668,992
Size: 3,418,095,616 bytes
Time: 370:55:17 (MM:SS:FF)
Supported Write Speeds: 2.4x, 4x, 6x, 8x

Physical Format Information (ADIP):
Disc ID: MCC-003-00
Book Type: DVD+R
Part Version: 1
Disc Size: 120mm
Maximum Read Rate: Not Specified
Number of Layers: 1
Track Path: Parallel Track Path (PTP)
Linear Density: 0.267 um/bit
Track Density: 0.74 um/track
First Physical Sector of Data Area: 196,608
Last Physical Sector of Data Area: 2,491,711
Last Physical Sector in Layer 0: 0

Physical Format Information (Last Recorded):
Disc ID: MCC-003-00
Book Type: DVD+R
Part Version: 1
Disc Size: 120mm
Maximum Read Rate: Not Specified
Number of Layers: 1
Track Path: Parallel Track Path (PTP)
Linear Density: 0.267 um/bit
Track Density: 0.74 um/track
First Physical Sector of Data Area: 196,608
Last Physical Sector of Data Area: 1,865,599
Last Physical Sector in Layer 0: 0

Noticed the same thing on new 3550A:

  • 105bt_rpc1 loaded
  • BinFlash v1.22 in DOS mode
  • set and confirmed bitset for +RW, +R and +R DL - (see screenie)
  • NeroSpeed v4.10 benchmark - (see screenie, next post)


NeroSpeed v4.10


OK. I’ll be looking into this. If I understood you right, changing and displaying the settings is possible, but they are not applied when writing a disc.

That is correct.

Just uploaded a new modified 3550 bitsetting firmware 1.05
I forgot to call the new routine, but that should be fixed now. Sorry for any inconveniences. It would be nice if someone reports whether it’s working again or not.

I just flashed my 3550 with the “fixed” 1.05 firmware and the bitsetting now works. Thanks for the quick fix.

Thanks, Liggy!

  • installed new 1.05bt-RPC1, dated: 11/20/05 6:20pm
  • reissued -setbt command for all +R media
  • verified all +R media set to ROM; perm with -querybt
  • tested with +RW, Ritek 008, x8 media
  • full format/erase prior to creating “data disk” with NeroSpeed v4.10
  • did NOT set to ROM

will test with +R media next and report back

I only tested with a +R SL. Guess I should have mentioned that.

I just tested it with a +RW using the “create a data disk” test on Nero CD/DVD Speed and it booktyped mine to DVD-ROM.

Well I would like to test it but can’t get to your page at the moment. Will try again later.

O.K. I got it. That has fixed it Liggy. Thanks…

I recall I readed that you’ve to use a completely new +RW disk the first time… Maybe the disk you’re using was formatted before? Seems that once you’ve formatted one new +RW disk, then it will set the ROM type on the others +RW disks…

Weeeee!

  • +R set to ROM correctly
  • had to use 832 to set previous +RW disc to ROM
  • used 3550/1.05bt_RPC1 with NeroSpeed v4.10 to erase/format and +RW disc stayed at ROM
  • new/fresh +RW disc set to ROM sucessfully

Much thanks, Liggy!

(ps: if you still need testers for 3550->4550, let me know…)
(Wes suggested I ask you via post)

Yeah, same for me…Would like to be able to take advantage of 4550 1.X2 since I am not too impressed with the 3550 write quality so far. Perhaps we’ll get a modified firmware for the 3550…

LMAO! - having loads of fun with original +RW disk and BS (Ritek 008 +RW x8)

  • new +RW disk, format/erased on 3550 with original 105bt_RPC1 and NeroSpeed v4.10
  • created “data disk;” ROM did not set
  • loaded corrected 105bt_RPC1 FW and could not set to ROM
  • used 832 to set ROM
  • checked ROM status with 3550/105bt+RPC1 fixed version, ROM is set
  • did erase/format with NeroSpeed v4.10 and ROM still set
  • created “data disk” and disk set back to DVD-RW “wtf?”
  • tried three times, erase/format with different apps, disk remained DVD-RW
  • used 832 to set back to ROM and did full erase/format again
  • disk back to ROM
  • tired to check status with A08XL and disk would not read
  • put disk in 3550 and disk would not read
  • put disk in 832, disk reads
  • performing full erase with 832, then same in A08XL and see what happens

too dang funny! - reminds me of days, two years ago, when x4 +RW media first became available.

  • will keep plodding along, 'till I toss the disk or fix it

Finally!

  • original +RW disk fixed
  • took 3 full erases, behaves normally on all drives and remains set to ROM

(its all Wesociety’s fault)

This bichi guy is trouble!
Keep your RW’s away from him!

/me hides all Rewriteable discs

Just a quick newb question:
If I change the bitsetting for my DVD-RW disk, will the burner still recognise it as a rewritable disk? Will I still be able to format/erase the disk? Can I change the bitsetting back to DVD-RW if needed?

The burner will always be able to detect the real mediatype. DVD-ROM drives usually do not recognize this.