Liggy & Dee's Optiarc AD-5170A Modified Firmware 1.O2 Results & Support Thread

LD5170 1.O2 (Liggy & Dee Optiarc AD-5170A firmware)

Two Versions available
Version Release Date 12/10/2006
Binflash + LD5170 1.O2 Original Firmware
Binflash + LD5170 1.O2 RPC1 Firmware
The firmware packages can be used with Windows, DOS, Linux or MAC. (see minifaq)

NOTE
Special FLASHING instructions.

Boot your PC into Windows Safe Mode before attempting to flash. Trying to flash when in normal Windows XP mode may result in a checksum error.

Please make sure you read the documentation included in the package.

Visit our website for all the latest firmware news

NOTES
LD5170 1.O2 Orig
Media speedups, strategy tweaks, full bitsetting.

LD5170 1.O2 RPC1
RPC1, media speedups, strategy tweaks, full bitsetting.

The AD-5170A is not RIPLOCKED, so pressed DVD-VIDEO discs will RIP at 16x SL and 12x DL

Change log
1.O2
Added OPTODISC008 -R media at 12x
Improved the write quality of the following media.
YUDEN000T03
RICOH JPNR03
MCC03RG20
TYG03

1.O1
All new firmware

LD Firmware Mini FAQ

Q: Which NEC firmware is this firmware based on?
A: This firmware is based on 1.11 Bitsetting firmware with version and name string changed to 1.O2.

Q: How do i flash my drive with this firmware?
A: The firmware is now bundled with Liggys Binflash Unzip then run the package, now click on the FLASH button. The firmware will now be uploaded onto your drive, when completed you will be prompted to restart your PC.

To Flash a drive in DOS, LINUX or MAC. Use a current version of Binflash. Run Binflash with the commands necessary to load the firmware package. Binflash will accept either a .BIN or a .EXE file and flash your drive.

Q: What are the risks of flashing my drive with this firmware?
A: Great care has been taken to make sure your drive is not damaged in any way by using this firmware. However, you flash your drive with this firmware at your own risk. Neither I, Liggy, or cdfreaks will be held responsible if your drive or media is damaged in any way.

Q: Will flashing my drive with this firmware void my guarantee?
A: Yes, flashing your drive with any unofficial firmware will null your guarantee. If something should go wrong with your drive, you should buy a new one and not RMA the drive.

Q: Do I need special IDE drivers when running this firmware on my drive?
A Like all optical drives. It has been proven they work best when using Microsoft’s default IDE drivers. This is a must for this firmware.

Q: Why do i not get good results when i burn media on the modified media list at MAX speed?
A: This is largely down to the quality of your media. If the speedups don’t give you good results. Set the burn speed lower. This firmware will give good results at the stated stock firmware speed, without having to flash back to a stock firmware.

Q: What about media not on the modified media list?
A: All media both SL and DL not listed in the modified media table use the default NEC STOCK write strategies and speeds. If you don’t get the results you expect with media not in the modified list, this is a limitation of the media or drive, not this firmware.

Q: How do i set SL bitsetting for +R media?
A: Use CD Speed or WinBtype to set booktype to DVD-ROM This setting is remembered by the drive and only needs set once. Make sure no disc is in the drive.

Q: How do i use DL +R bitsetting?
A: Use CD Speed or WinBtype to set booktype to DVD-ROM This setting is remembered by the drive and only needs set once. Make sure no disc is in the drive.

Q: How do i use DVD+RW bitsetting?
A: Use CD Speed or WinBtype to set booktype to DVD-ROM This setting is remembered by the drive and only needs set once. Make sure no disc is in the drive.

Note

Q: Does this firmware support the LabelFlash labelling system?
A No

Submitting test results
Please state the LD firmware version used for the burn, the media type (MID code) and the burn speed.

If possible burn a disc with NERO CD-DVD Speed (create data disc) and save the burn screenshot by clicking on the disc icon at the top of the window.

Also submit a (data transfer test) using a NEC or Optiarc 16x drive.

Disc Quality scans can be submitted with NEC Drives using CD-Speed with scan speed set at 5X or 8X
Note Version 3.75 or higher is required for PI/PIF scanning on the NEC drives.

Below is some additional info from the author of CD-Speed.

(Liteon drives) using K-Probe @4X scan speed or CD-DVD Speed (disc quality) @4X scan speed.

If scanning with a Benq drive. use CD-DVD Speed (disc Quality) @8X scan speed.

DOWNLOAD LINKS
NOTE We do not allow offsite linking to these files. You may also have to temporarily switch off any firewall or similar software you are running.

All our firmwares for all NEC series drives are now stored on our new website

Note
We do NOT offer support for previous versions

PS: Before posting in this thread, please read the documentation supplied

Media Speedups
DVD-R
Ritek G04 8x
SONY04D1 8x
Ritek M02 8x
MXL RG02 8x
FUJIFILM02 8x
Prodisc S03 8x
CMC MAG Ae1 12x
Daxon 016S 18x
Daxon 016 18x
CMC MAG AM3 18x
MBI 01RG40 18x
Prodisc S05 18x
RITEK F1 18x
RITEK M16 18x
OPTODISC 008 12x

DVD+R
Yuden 000T02 18x
Ricoh JPNR03 18x
CMC MAG M01 18x
Prodisc R04 18x
MBI PG101R05 18x
Prodisc R05 18x
Daxon AZ3 18x
Ritek P16 18x
MCC003 12x
Prodisc R02 8x
MBIPG101R04 12x
CMC MAG E01 12x
Maxell 002 12x

Thanks Dee and Liggy for this firmware :bow:

i would like to add my thanks as well, uploaded and working fine.

so whats the deal with this drive? is it the same as the 7170?

its easier to find over here.

Drives have the same hardware, but 5170 is unable to write DVD-RAM

well i went and bought this drive.
i hope it burns just aswell as the 7170 :slight_smile:

just one more question:

i dvd ram disabled on this drive, like labelflash i disabled on the 7170?

iow would it be technically possible to flah it to a 7173?

Unable to flash my brand new 5170, get checksum error every time. Have tried on 3 diffrent computers, with microsoft ide drivers installed, and in safemode. get checksum error what ever i do. Never had any problems flashing my older burners, but thisone i can’t get flashed. got any tips or ideas what more i can try? Been using binfash 1.33 to flash. By the way, my drive says it’s 1.11 out of the box, is that why i can’t flash since “version and name string is changed to 1.O1” if that’s the case what do i do then? Have tried both Dee’s AD5170 1.O1 Modified Firmware and Liggy’s AD5170 Bitsetting Firmware 1.11 firmware, same problem.

Thanks

Goggen

Welcome to the forum
Safe mode has to be plain safemode. In other words, selecting safemode with Network support wont work. The name/version string change wont prevent the drive being flashed.

An alternative way to make it work is by switching your drive to PIO mode in the device manager

anyone got a 8x burn?

Thanks alot for the reply, yes dee i have used plain safe mode. i’ll try swithing to pio mode and try again.

Thanks again.
Goggen

Yesss… Pio mode did it, flashed without problems in normal windows mode. thanks alot,now i can enjoy your great firmwares. But it does make me wonder why? Newer had this problem with my older nec burners(2500,2510,3500,3520). Is it something with the new drive or is it the software? And is the problem present with the orginal nec firmware to? Reason i ask is that my new motherboard only have 1 ide channel on a JMicron controller, and it emulates SCSI so no way to set PIO-mode. So i have to move my drive to another computer to flash. But that’s a small price to pay, as long as i can use your firmware, just makes me wonder, can it be fixed? Thanks for your great work. It’s the reason i buy NEC.

Goggen.

Optiarc seem to have a bug in their bootcode. At least they do not support UDMA4 mode.

Sorry. Don’t want to be a nuisance, but i discovered a new problem. When i use a used DVD+RW disc in my 5170 and try to erase it with nero i get message: This disc is not rewritable disc therfore cannot be erased. If i open disc info in nero it says: DVD-session DVD-ROM, Capacity in use 4,475MB. If i try burning on it i get the message that the disc is the wrong type. If i use it in my 3520 i can burn and erase the disc without problem and get in Disc info: DVD-session DVD+RW, ‘Booktype’ DVD-Rom used capacity 0MB free space 4,483MB. I am able to erase the disc in alcohol 120% if i tick “ignore illigal TOC” but still unable to use the disk in the 5170, but works fine in the the 3520. Is there something wrong with the firmware (discovered this after flashing with your firmware, did not test this with orginal firmware) or is the drive faulty? no other problems with the drive, and it works if i insert a brand new DVD-RW disc. Tried full erase with alcohol 120 on 5170 and nero on 3520, same problem. Any ideas ??? BTW, the discs are verbatim 4x DVD+RW.

Thanks

Goggen

nm

okay. flashed back to orginal firmware, same problem so it’s a NEC problem. seems that the 5170 is unable to detect DVD+RW booktyped as DVD-ROM correctly. That’s to bad because my DVD-Recorder set booktype DVD-Rom on them and they then become unusable for my 5170, that must be a frimware bug?? Hope nec fixes thatone. Noticed another thing. I can flash my Orginal firmware and Dee’s AD5170 1.O1 Modified Firmware when i set PIO-mode, but is unable to flash Liggy’s AD5170 Bitsetting Firmware 1.11 even with PIO-mode and safe-mode, get checksum error every time. Any idea why??

Thanks

Goggen

I just redownloaded the files (orig and rpc1) and calculated the checksums but the files were already correct.

[B]Version 1.O2 released.[/B]
For full details see the included documentation or read the first post in this thread.
You can grab it [B]here[/B]

I just got a 5170 and flashed it with 1.O2. Burned my 16x rated Philips dvd+R (MBIPG101R05) at 18x which is great.

It refused my Traxdata 8x +RW discs though (Disc ID: RITEK-008-00) and ImgBurn gave me the following error:

I 16:03:44 Writing LeadIn…
W 16:03:44 Failed to Write Sectors 0 - 31 - Cannot Write Medium - Incompatible Format

Can it be that this media is not supported at all by this drive? Thus far, my BenQ 1640 is the only one that burns this media fine. My BenQ 1655 locks up when burning this media, my NEC 4551 burns them with horrible results and now this Optiarc 5170 doesn’t even want to burn them…