Lieon 1635s+ITE Controller DMA Driver Error

vbimport

#1

My 1635s (YS0W) is hooked up to an ITE 8212 controller via an 80 wire cable. Everything was OK, but suddenly it stopped burning CDRs at 8x (strangely it worked fine at 12x) and recently it stopped buring DVDs whatsoever. I am only able to record small files, up to 30megs, without the drive showing the DMA driver error, CRC error. I’m using Nero 7.0.8.2. The same thing happened with version 7.0.1.4. It also worked fine with 7.0.1.4. Things are the same after a fresh install of Win XP SP2.
Could you suggest something?


#2

Could you suggest something?

Move the optical drive to a MB IDE channel and move hard drive(s) to the PCI card.


#3

Yes. PCI IDE controllers rarely work well for optical devices & don’t allocate DMA properly.

If you do as suggested then you’ll probably have to go into the BIOS & change the boot sequence to SCSI first as that’s how a PCI IDE controller is often seen within the Bios.


#4

My 16H5S is working with both of my IDE controllers. SiliconImage A0680 and ITE 8212F.
The only problem is that on SilA0680 the reading is max 14x, but writing is ok at 16x.
The strange thing is that 1693S is working fine on both controllers.


#5

Pete, you might want to try reflashing the drive as well. A new version (YS0Y) is available here:
http://www.liteonit.com/DOWNLOADS/ODD/SHW-1635S/firmware/DR16YS0Y.zip

It might pay to do this on the MB IDE as well, just to be safe. :wink:


#6

Thanks all of you guys. I’ll have some free time tomorrow to do the cable/controller swapping. I’ll let you know.


#7

Flashing the drive to YS0Y didn’t help. The strange thing is that I can add a session to a multisession CDR at 8x, but whenever I want to burn a whole CDR, say at 8x, it starts writing then stops after about 30 seconds with a DMA Driver Error, CRC Error screen.
By the way, are HyperTuning and Overspeed supposed to work with a 1635s on YS0Y?


#8

In the meantime I had to RMA my 1635s and got a brand-new 165P6S as a replacement. The 165P6S also gave me the ‘DMA Driver Error’ screen. As suggested, I moved my good ol’ Teac W524E to the ITE controller and the Litey to the mobo controller. Everything works fine now. It seems my ITE 8212 controller likes older drives better.


Liteon 165P6S MS0P, Benq 1640 BSRB, Teac W524E 1.0E


#9

If your ITE card has a flashable chip, then you can try older BIOS’s for the chipset. engine has posted almost all the BIOS’s here.

Here are some other threads you can read up on.
Here
Here


#10

:slight_smile: Thank you for the links. I’ll do that.


#11

I guess the problems I had were connected to the UDMA thing. The 1635s which I RMA’ed was connected via an 80-wire cable and showed as UDMA 4. It didn’t work well that way. The same thing happened with my new 165P6S. Now that the 165P6S is connected to the mobo controller via a 40-wire cable, it works flawlessly in UDMA2 mode. So does the Teac which is hooked up with an 80-wire cable to the ITE controller and shows as UDMA2.


#12

Liteon and Sony should be UDMA 4 !!! If your 80 wire cable is not good, that’s something else. But again, your liteon should be UDMA 4 .
I have connected my 1693s to a Sil 0680 card, and it works perfectly as UDMA 4.


#13

Hi,

That’s right. But it is not impossible, that some PCI IDE controllers - these are mostly designed to work with HDDs and not ODDs - behave erratic if an ODD that uses a high transfer mode is connected. In that case, reducing the transfer mode to UDMA2 might really help.

Michael