LH20A1l and new sata pci card blues

vbimport

#1

I just purchased a LH20A1L burner and a Rosewill RC-209-EX four port sata 150 card. My motherboard is an Asus P4G8X deluxe with a Sil3112 sata controller with two 160G HD’s in a RAID 0. My new Rosewill is a Sil3114 and all thats on it will be the LH20A1L. After installing the card I tried sataraid5 driver with Boot disk failure and I tried it without (uninstalling sataraid5). I then disconnect power to the LH20A1L and reboot fine. What driver do I use? I don’t see just a sata driver only sataraid drivers, is that the problem?


#2

Hi :slight_smile:
Find Bios here:
http://www.siliconimage.com/support/supportsearchresults.aspx?pid=28&cid=15&ctid=2&osid=0&
Find drivers here:
http://www.siliconimage.com/support/index.aspx?pid=28&cid=3&
Note: Select an OS (stage 3) & click go.
You will find a specific ODD driver here.


#3

I used both links but I’m still having problems. When I boot up the first Sil 3112a Bios version 4.2.47 appears showing 0 maxtor 6y160mo and 1 maxtor 6y160mo striped set then the second Sil 3114 Bios version 5.4.03 appears showing 1 lite-on dvdrw LH-20a. Next it shows "No valid device! Press any key to continue or F4 to enter RAID utility. Next is “Disk boot failure, insert system disk and press enter”. When I enter the 3114 RAID utility it says I have no RAID sets on that card, I thought thats the way the dvd should be. As soon as I disconnect power the dvd the pc boots fine with just the sata card no dvd?


#4

Hi,

do you have any SATA HDD at hand?
If so, then conntect this to your 3114 and see if you can boot up your system. Then install BASE Bios for the card - and the non-RAID drivers when prompted after reboot.
Next step would be to remove the HDD and re-connect your burner.

No idea if that works, but it is worth a try.

Michael


#5

The DVD drive has to be set up as SATA not RAID.


#6

"After installing the card I tried sataraid5 driver " I loaded the wrong sata utility (sataraid5) first and now it always sees the card as a sataraid5. It won’t load new driver. I’ve removed the card and reinstalled it but it still sees it as sataraid5. Any ideas? Sorry to be such a newbie on this.


#7

Hi,

at first, connect a HDD (since opticals don’t work at the moment). Load Windows and get BASE Bios and drivers for your controller chip from silicon image website.

Follow these instructions to turn your RAID version into a non-RAID, that supports optical drives:
http://club.cdfreaks.com/f34/sata-ide-converter-235682/#post1972211

Then you might disconnect the HDD and re-connect your burner.

Michael


#8

I connected a Sata HDD to the Sil3114 it booted and the pc automatically install the SataRaid5 setup with no hardware prompt. I read the other post

Double click to see the properties screen in device manager*. There should be a "Flash BIOS" tab present. 
Now browse for the correct BIOS file (filename starts with b like b4384.bin) and press the "program flash" button. 
The flashing process will then start after confirmation. 
Reboot and let Windows install the non-RAID drivers the same way as described above.

(* there might also be a control panel applet installed, that offers updating the card BIOS, too.) 

I can’t seem to find where to flash bios, theres no tab in properties/device manager. I’ve downloaded the base bios and won’t make the mistake of loading the RAID5 bios again.


#9

Hi :slight_smile:
I originally assumed that the OS allowed the bios flash.
However have since learned it is the mobo that allows this.
If you don’t get the tab, then flash via the DOS or Windows utility.

[B][U]DOS[/U][/B]:

[B][U]Windows[/U][/B]:

Once the BASE BIOS has been flashed.
You shouldn’t get any problems loading the correct driver.


#10

Zee I used your link to the windows utility, saved it , unzipped it , it opened up and closed a dos prompt so fast I could see anything. No choice of anything. What am I doing wrong? I did check, it still said SataRaid5 and wouldn’t take the base driver.


#11

Hi :slight_smile:
In truth I have not used either.
There are some folk on this forum who have.
I guess you might need to try the DOS one.
But through DOS rather than Windows.
If I get time, I will have a go myself.


#12

Use updflash.exe in pure dos mode.


#13

Thanks, I’m not sure what you mean by “pure dos mode”. Will a command prompt do?


#14

Hi :slight_smile:
Pure DOS.
Make a ‘rescue disk’ (floppy).
Boot from floppy in to DOS.
Have the flasher & BASE BIOS on another floppy.
Flash from that.


#15

[quote=soothsayer;2052012]I connected a Sata HDD to the Sil3114 it booted and the pc automatically install the SataRaid5 setup with no hardware prompt. [/quote]Is there any short message like “Press Fx for configuration” before Windows gets loaded?

Another idea would be this:
Since you mentioned that Windows installed the card automatically, I assume it is run by Windows built-in drivers, that don’t allow advanced options. Install the latest Raid drivers from Silicon Image website, reboot and see if the “flash firmware” tab is present now.

Michael


#16

Michael there is F4 that bets me into the RAID setup but nothing that let’s me flash the bios. I tried your second suggestion but still no tab in device manager. I emailed tech support for Rosewill but no response yet. I also emailed Silicon Image, who suggested I try Rosewill.


#17

Dude!!!
Download updflash and the correct bios from SIl site. Put them on a blank floppy. Make an XP recovery disk or use a windows 98 boot disk, available from bootdisk.com.
Boot with the windows 98 boot disk. After it is loaded, take the disk out and install the other floppy with updflash and bios. At the dos prompt type in updflash.exe /filename of bios and answer prompts and walla…you updated your bios!


#18

[quote=soothsayer;2053010]Michael there is F4 that bets me into the RAID setup but nothing that let’s me flash the bios.[/quote]You might change the Raid setup to JBOD or something like this. Then retry with the further steps I mentioned above. Maybe this helps.

Michael


#19

I booted into dos and at the prompt went into updflash, selected the right chip from the list (had to pull the card and read it from the chip) and then it asked “STARTING FLASH MEMORY (0-7FFFF (hex))” and I didn’t know what to do at that point.


#20

Hi :slight_smile:
In the download is (or should be) a text file.
This should give you all the info you need.
Either print this out, or write it down.