LH-20A1S burning Problems

I’ve been trying to figure this out for 2 months now. I have a Sata lite-on dvd burner (LH-20A1S) up to date firmware. Its brand new and I actualy thought it was bad so I bought another one (exact same model) just in case. I can burn CD’s and DVD files from the computer but any DVD’s with copyright protection on it will not burn. It starts to read the disc but hangs at different points on different discs. I’ve tried 5 or 6 different programs to burn with and even rip. I’ve used anydvd with clonedvd2, DVD Decrypter, Dvd-cloner IV, Nero, and a few more. I’ve made sure all of the programs were up to date, I reinstalled windows xp pro (SP2) 2 times. Each program will read part of the disc and then hang, at that point restarting the computer wont work (takes hours), opening another program takes a very long time, ending the burning program through task manager will close the program but its still in the task manager under processes tab.

I have an AMD Athlon 64 x2 dual core 6000+ 3.01 GHz, 2 GB ram with plenty of hard drive space. Mobo is an ASUS M2N-X.
My bios are up to date. All windows updates are current. I’ve uninstalled the device through the Device Manager, made sure that all IDE channels have Transfer mode set at DMA if Available.
Searching google turned up very little about this type of problem. I dont know anything about ASPI, but downloaded Adaptec Aspi v4.71.2 and installed it after reading about a similar problem someone was having (still no luck).
here is the filter driver load order for my burner:


Filter Driver Load Order http://www.bustrace.com

Upper Device Filter: redbook
Device Object: LITE-ON DVDRW LH-20A1S
Lower Class Filter: ElbyDelay
Lower Class Filter: PxHelp20
Lower Class Filter: Afc
Lower Device Filter: imapi

     Driver Name:  redbook.sys
   File Location:  c:\windows\system32\drivers
File Description:  Redbook Audio Filter Driver
    File Version:  5.1.2600.2180 (xpsp_sp2_rtm.040803-2158) [5.1.2600.2180]
    Product Name:  Microsoft® Windows® Operating System
 Product Version:  5.1.2600.2180 [5.1.2600.2180]
    Company Name:  Microsoft Corporation

     Driver Name:  elbydelay.sys
   File Location:  c:\windows\system32\drivers
File Description:  Elby Delay Lower Filter Driver
    File Version:  5, 1, 0, 1 [5.1.0.1]
    Product Name:  CDRTools
 Product Version:  5, 1, 0, 1 [5.1.0.1]
    Company Name:  Elaborate Bytes AG

     Driver Name:  pxhelp20.sys
   File Location:  c:\windows\system32\drivers
File Description:  Px Engine Device Driver for Windows 2000/XP
    File Version:  3.00.56a [3.0.56.0]
    Product Name:  PxHelp20
 Product Version:   [2.0.0.0]
    Company Name:  Sonic Solutions

     Driver Name:  afc.sys
   File Location:  c:\windows\system32\drivers
File Description:  Arcsoft(R) ASPI Shell
    File Version:  1, 0, 0, 2 [1.0.0.2]
    Product Name:  Arcsoft(R) ASPI Shell
 Product Version:  1, 0, 0, 2 [1.0.0.2]
    Company Name:  Arcsoft, Inc.

     Driver Name:  imapi.sys
   File Location:  c:\windows\system32\drivers
File Description:  IMAPI Kernel Driver
    File Version:  5.1.2600.2180 (xpsp_sp2_rtm.040803-2158) [5.1.2600.2180]
    Product Name:  Microsoft® Windows® Operating System
 Product Version:  5.1.2600.2180 [5.1.2600.2180]
    Company Name:  Microsoft Corporation

Anything else that I would need to include, just let me know. I really apreciate any help and even anyone just reading this and giving it a shot. I’m so stuck I have no clue what to do next. Thanks alot.

Which DMA mode is it on?

Welcome to cdfreaks [I]tattootrash[/I] :slight_smile:

tattootrash, make sure you have [I]nForce520[/I] chipset drivers installed. SATA channel your Litey is connected to should run in compability, (or IDE compatibility mode).
Get rid of ASPI.

BTW, your drive is installed on SATA bus, so talking about “IDE” channels is not that meaningful. DMA mode doesn’t exist either when it comes to SATA channels, this is just a M$ windoze thingy.

Thank you both for replying. I really apreciate the help. And thanks for the warm welcome too. :slight_smile:

chef ,
Both the Primarys are on Ultra DMA Mode 5 and the secondarys are reading not applicable.

pinto2,
I’ve downloaded the nForce520 chipset drivers and will install right now as well as getting rid of the ASPI that I installed. I really need to read up on SATA since I know very little about it.

I’ll try to back up a dvd right after this and hopefully all will go well.

:sad: unfortunately it didn’t work. I tried the same DVD with 2 different programs and they hung while reading but at different points. dvd-decryptor failed at 13% while trying to rip and DVD-cloner4 faild to copy at 17%.

What I cant understand is that the drive can burn mp3s and it can burn movie files but anything copyrighted fails. Almost like something is installed that stops the backing up of DVDs, but I reinstalled xp 2 times.

does anyone else have this problem? Or, is there anything else I can try to fix this.
I built the computer a few months ago and I’m so frustrated that I cant back up my DVDs.

Anything else I can try I would apreciate so much.

DVD Decrypter is outdated and may not handle some newer movies. DVD-Cloner, I have no idea - doesn’t seem to be used a lot around here. Try DVD Fab HD Decrypter if it’s a newer DVD.

Thanks, I’ll give it a shot.
Apreciate the help. :slight_smile:

RipIt4Me, but uncheck check for updates at startup in preferences, because there won’t be any.

Well, it seems no matter what program I use, I get the same result. Every program will hang while in the “reading mode” (only on copyrighted dvds) and eventualy just freeze up.

Is there any program that I can download that will give me some info on whats going on, or any settings that I can mess with?

Did you set the drive’s Region code yet? Also, different SATA settings in the BIOS might be worth a try, even a BIOS update if available.

Did you set the drive’s Region code yet? Also, different SATA settings in the BIOS might be worth a try, even a BIOS update if available.

Yeah, I have the region set at 1
The bios are up to date, but I’ll definatly look through the SATA settings again and see if theres anything I can change. Thanks alot.

Or even another SATA cable while you’re at it. I remember from another thread that nVidia use their own implementation of NCQ (Native Command Queing) for SATA2 HDD, without having AHCI (Advanced Host Controller Interface), so there’s no option to switch off AHCI and select IDE compatibility or legacy mode (which would be preferable for ODD). If you can’t get it right, you may have to use a SATA PCI-Card (or revert to a PATA ODD).

Yeah, I tried another cable and another sata slot but its all the same.
I didn’t realize that the vid card had anything to do with burning. Shows how much I know.
Would switching to Raid Mode be any help for this problem? I switched over last night but didn’t have the right drivers and and the dvd burner didn’t show up. I was thinking of downloading the drivers and trying it again, but didn’t know if I would be screwing things up. The only SATA device I have is the burner.

If all else fails, maybe I’ll just get rid of one of my hard drives and use that ide cable for my old burner.

The video card is not involved, but your mobo has an nVidia chipset, which controls the SATA channels, amongst other things. Please do not use RAID mode, nor install RAID drivers as this will only make matters worse. If there’s no other SATA options in the BIOS, then leave it alone. If you’re sure your Windows installation is clean (a fresh install can do wonders sometimes) and you’ve tested both the native Microsoft and nVidia SATA drivers, you’ll probably be looking at alternate solutions yes.

Ahh… I see. This is all new to me but little by little im learning. Again, thank you for the help and the info.
I did do a fresh install of windows twice with no luck. I hate to reinstall again and have to hear my wife complain about all her programs gone so im trying not to go that route.

One more question, maybe stupid but, How would I test the drivers?

When installing XP (in non-AHCI mode) you get a generic Microsoft SATA driver on your system. This can be verified in Device Manger under the appropriate IDE Channel, Properties, Driver tab, which will show “Driver Provider: Microsoft”. You can either be happy with that or install the proprietary SATA driver as provided by the chipset manufacturer of your mobo instead (nVidia in this case). You can get the latter from the Asus support site, but better is to check for the latest at nVidia.com: http://www.nvidia.com/object/nforce_520_winxp2k_12.15.html . The SATA driver is part of the nForce chipset driver package. Driver Provider will now become nVidia obviously. You can then alternate between nVidia and Microsoft SATA drivers in Device Manager for testing as required.

Cressida ,

Maybe testing the 2 drivers out and or switching will do the trick. I’ll try it out and see… if not I’ll go with the SATA card or the good old ide. Thank you very much. I apreciate you sticking with me here and answering all these questions. You guys and gals all do a great job here at cdfreaks.

Tattootrash,
Which chipset driver you’ve installation? I have problem in dvd burning with latest nv chipset driver installed for both writers lg h62n and liteon 20a1s. So I reinstall the 9.19 driver supplied by Asus and it works perfectly. My mb is Asus M2n-e.
Not all the program,exp. nero could burn the region restricted dvd disc. I prefer to use the dvdfab platinum.

Actualy last night after reading Cressidas post, I downloaded the nForce520 chipset again from this link that was provided in the post:

http://www.nvidia.com/object/nforce_520_winxp2k_12.15.html

I reinstalled the drivers again and this morning I actualy burned a DVD. The first one hung but a few mins later it picked right back up and finished. The second dvd went all the way through without hanging at all.

So im thinking that installing the 520 drivers again fixed everything. Maybe I had an older version? I just googled “nForce520 chipset” and grabbed the first one I saw.
But, the thing is that the Primary IDE channels still say the drivers are provided by microsoft even after installing nVidia drivers again.

Its working now so I problably shouldnt touch anything. The next move was to burry the dvd burner in the back yard. Now I can burn again :clap: