LH-20A1S Burn Problems

vbimport

#1

I’m having some problems while burning dvds on my LiteON LH-20A1S Drive. When i burn with 16x media it is taking 18-19 minutes to complete the dvd, the speed ranges between 2.5x and 2.7x. I have an MSI KT6 Delta-LSR which has a VT8237 southbridge (SATA Controller). I have installed the latest bios update to my motherboard (which includes an update to the serial ata rom) and i also have the latest firmware updates for the drive. The drive is running in Ultra DMA Mode 5, and it is connected to the channel 1, with channel 0 having a 160gb seagate harddrive, which is working just fine. I have an athlon xp 2000+ with 1 GB of ram. I have tried several driver versions for my VIA SATA controller…including the original sata driver that came with the mobo, and VIA PATA/SATA IDE Driver packages 1.40a and 1.60a…all having the same problem.I have tried switching the channels, and running with just the dvd burner connected to sata, and still the same problem. During writes the cpu usage is extremely high throughout the burn, and the write buffer constantly cycles from about 4% to 97% about every 5-10 seconds. I have also tried running with smart burn and hypertuning disabled and enabled, all still giving me the same problem. I’m thinking that this optical drive just isn’t compatible with my sata controller…if anyone knows how to fix the problem please enlighten me. also, if anyone knows of a pci sata controller (for under $60) which is compatible with the liteon lh-201a1s, please let me know. thanks


#2

You should be able to get it working with the latest VIA drivers (with the burner only at least). Let us know :slight_smile: .

http://club.cdfreaks.com/showthread.php?t=204919
http://club.cdfreaks.com/showthread.php?t=213239


#3

ok well nothing helped from those links…followed the directions of what supposedliy works…but i have a different problem…those are the simple issue of how to proplerly instal the vt8237 sata controller driver so that it will detect the drive…i’m not having any problem with the controller setting up, or detecting the drive…it seems to be reading fine also…
its just burning.
it maxes out at 2.8x…averages about 2.5x or about 21 minutes to make a dvd.
i’ve tried several different types of 16x media…all the same issue.
i was reading somewhere that you have to disable the raid controller in the bios…the only thing about sata in my bios says something like “VIA Serial ATA IDE Controller: enable/disable”…and from what i understand the serial ata ide controller is what i want…but when i boot into windows it tells me that i have a serial ata raid controller…i’ve tried installing every driver onthe via website to try to workaround installing the serial ata raid controller…so that can’t be the problem.
So the write buffer constantly cycles from 98% to 3%(kind of like its having buffer underruns every 10 seconds), but there is no other program running…and as stated earlier cpu usage is extremely high.

I’ve come to the conclusion that I’m sure the drive is fine…and i’m looking for recommendations on a good, cheap, reliable SATA PCI Controller card…i only have pci slots so i know i can’t get full speed out of sata II if i get a sata II pci card(~266 max instead of 300)…so NCQ for my hard drive is the only option i would get out of that…not sure if its worth it…or if this is the right place to talk about that…but if anyone has input about a good cheap SATA controller card (SATA I or II: maybe give your input on if its worth it to get SATA II for Native command queing). I bought the drive online and I don’t have mail delivered to where i live(on college campuS)…so i have to get it delievered to a friends place…which makes it very inconvenient if i want to RMA items…if i could i’d just trade the SATA Drive for a regular PATA…but that would be a major pain in the rear in my situation…not to mention the fact that i’ve updated my firmware (Official Lite on firmware)…but still if they notice that they may not fully refund me when i send it back)
In conclusion if you are having the same problem or a similar one with slow writes and write buffer going nuts…let me know what you did about it.
AND SATA PCI CONTROLLER card recommendations (that work with optical drives obviously) please~! thanks


#4

Well I didn’t look at all the links above but normally the onboard raid controller has an option for IDE mode or normal mode, if the controller is in raid mode I am not suprised it doesn’t work. If you can’t get it working a PCI controller with a Silicon Image chip 3112 normally work well.:slight_smile:


#5

Hi,

It seems as if the Sata controller is running in RAID mode then. Normally you should have the options “Disable/Sata/RAID” in BIOS setup. Have you tried if a motherboard BIOS update helps?

Michael


#6

Hi Michael!

Does your Samsung work on VIA SATA in Win2K?

Thanks,