LH-20A1S and LH-20A1H are crap with YUDEN000-T02-00?

So i bought 2 100pks of 8x DVD+R Printable Hub Taiyo Yuden’s that i’ve had nothing but problems with. I’ve tried them on a Lite-On LH-20A1S and LH-20A1H and both times i keep getting a “Retry Failed - Power Calibration Area Error”. Sometimes it will come through and burn. But fuck this is annoying. Is it that these drives are just crap or what? I bought both of them from Newegg…

Some steps i’ve tried to make sure it WASNT the drive was…

  1. Buying a new Power Supply (600w Kingwin).
  2. Only DVD drive is connected to power cable.
  3. Took PCI cards out to take stress on power supply.
  4. Upgraded firmware on LH-20A1S to 9L08 from http://forum.rpc1.org/dl_result.php?kaj=1&isces=LH-20A1S but that ended up bricking the drive. Now it won’t read anything i put in it. Should have known better since http://us.liteonit.com/us/index.php?option=com_wrapper&Itemid=153 only has firmware up to 9L02. :doh:

So any help would be greatly appreciated as to why this crap keeps happening.

Liteon Firmware must be downloaded from global site, every other site has old firmware.
I’ve got a 20A1S and 20A1H, only the S has de Codekings firmware, and it’s by far better than stock firmware.