LH-20A1L-05 burning coasters :(

Sorry to barge in here. I’m not sure where to turn, I seem to be the only person with a LiteOn LH-20A1L-05 that makes nothing but coasters. That or my google skills aren’t as good as I thought.

I bought the drive from newegg and installed it yesterday. My computer already had an IDE harddrive and CD burner. Luckily, the motherboard also has two SATA ports, and I pluged this DVD burner into the one marked SATA1.

I’m using Fedora 7 and the drive works fine if you’re reading data or playing a DVD. I’m using k3b as my burning program. I’ve tried a number of options (different write speeds, muti-session/non-multi-session, DOS compatable files system/Windows/LinuxOnlyFileSystem, etc). yet all I’m able to burn are coasters. I’ve tried a 3 different brands of DVD+R’s (Maxell, TDK, noname) from 3 different stores (CompUSA, BestBuy, local computer store). I’ve tried varying the amount of data I’m trying to burn, from just over 2GB to a few MB.

All I have to show for my efforts are about 30 coasters. I’ve tried reading them on my box and on a WinXP laptop and in both cases it looks like I have a finalized disk with no data on it.

Did I just get a bad drive and need to send it back, or am I doing something wrong?

upgrade to windows… :smiley:

the drive works fine for me on xp.

Welcome to the forum :slight_smile:

The most probable cause is that you are using cheap media. Try to use better quality discs like Verbatim or Taiyo Yuden: this should solve.

Another thing you can do is upgrade firmware to latest version. Check here. Too bad, the original flashers are for windows only, so I don’t know the procedure to upgrade firmware in linux, sorry :frowning:

Finally, try to update k3b to latest version.

A lot of Linux users here would not see Windows as an “upgrade” :bigsmile:

The type of mobo/chipset or SATA-controller used would be good to know. Does it read/burn at proper speed like 16X?

[I]Slightly off topic[/I]

For sure not. :iagree:
But we still have Wine for Linux.

I have same problem…reading dvds is fine but can’t burn any more. When I try to burn, it starts to burn and usually gets to either 7% or 30ish and continues to burn indefinitely and staying at that percentage. I’m using WinXP Pro and I have two of the same exact burners…LH-20A1L-05. They both used to work fine for anything I would burn but one day it just stopped working a few months back. And unless theres an 3rd party firmware/driver, I don’t see firmware for the LH-20A1L series…just the H, HX, P, PU, PX, and S but no L. And I’ve tried using Verbatim CD-Rs(light scribe color and normal light scribe), Verbatim DVD+Rs(light scribe), Verbatim DVD-R, Verbatim DVD-RWs and then Dynex CD-R. I’m using 2 sata II drives in raid 0 and then the two sata burners. I’ve tried changing sata mobo slots and tried plugging in the burners both individually in different slots and same results. I’ve uninstalled the burners from device manager more than once and then reinstalled them when windows boots but same result. I’ve tried burning using latest Nero 7 Ultra Edition, latest Itunes, and Alcohol 120. I’ve also tried all sorts of burn speeds and using different files and disk types (Data dvd, video dvd, audio cd…etc) as well.

Update: Found the BL04 firmware in a diff thread here and updated to that with a reboot and now instead of doing an indefinite burn it gives error saying burn process fail (one drive did it at 7% and the other was at 37%) In the Nero burn event log it says Invalid write state, Could not perform EndTrack, and Burn process failed at 48x. Here is the Nero error log:

Windows XP 5.1
IA32
WinAspi: -

NT-SPTI used
Nero Version: 7.10.1.0
Internal Version: 7, 10, 1, 0
(Nero Express)
Recorder: <LITE-ON DVDRW LH-20A1L> Version: BL04 - HA 1 TA 0 - 7.10.1.0
Adapter driver: <IDE> HA 1
Drive buffer : 2048kB
Bus Type : default (0) -> ATAPI, detected: ?
CD-ROM: <VH5400T JBQ833R >Version: 1.0 - HA 1 TA 2 - 7.10.1.0
Adapter driver: <SCSI> HA 1

=== Scsi-Device-Map ===
DiskPeripheral : NVIDIA STRIPE 467.52G nvraid Port 0 ID 1 DMA: Off
CdRomPeripheral : LITE-ON DVDRW LH-20A1L nvatabus Port 2 ID 0 DMA: Off
CdRomPeripheral : LITE-ON DVDRW LH-20A1L nvatabus Port 2 ID 2 DMA: Off
DiskPeripheral : Maxtor 6L250S0 nvatabus Port 3 ID 0 DMA: Off
DiskPeripheral : Maxtor 6L250S0 nvatabus Port 3 ID 2 DMA: Off
CdRomPeripheral : VH5400T JBQ833R 1.0 ajiotr3f Port 4 ID 0 DMA: Off
CdRomPeripheral : VH5400T JBQ833R 1.0 ajiotr3f Port 4 ID 1 DMA: Off

=== CDRom-Device-Map ===
LITE-ON DVDRW LH-20A1L D: CdRom0
LITE-ON DVDRW LH-20A1L E: CdRom1
VH5400T JBQ833R F: CdRom2
VH5400T JBQ833R G: CdRom3

AutoRun : 1
Excluded drive IDs:
WriteBufferSize: 83886080 (0) Byte
BUFE : 0
Physical memory : 2046MB (2095520kB)
Free physical memory: 1412MB (1446768kB)
Memory in use : 30 %
Uncached PFiles: 0x0
Use Inquiry : 1
Global Bus Type: default (0)
Check supported media : Disabled (0)

6.8.2007
CD-ROM (ISO)
5:45:51 PM #1 Text 0 File SCSIPTICommands.cpp, Line 424
LockMCN - completed sucessfully for IOCTL_STORAGE_MCN_CONTROL

5:45:52 PM #2 Text 0 File Isodoc.cpp, Line 6666
Iso document burn settings
------------------------------------------
Determine maximum speed : FALSE
Simulate : FALSE
Write : TRUE
Finalize CD : TRUE
Multisession : FALSE
Burning mode : TAO
Mode : 1
ISO Level : 1 (Max. of 11 = 8 + 3 char)
Character set : ISO 9660
Joliet : TRUE
Allow pathdepth more than 8 directories : TRUE
Allow more than 255 characters in path : TRUE
Write ISO9660 ;1 file extensions : TRUE

5:45:52 PM #3 Text 0 File Burncd.cpp, Line 3196
LITE-ON DVDRW LH-20A1L
SMART-BURN activated

5:45:52 PM #4 ISO9660GEN -11 File Geniso.cpp, Line 3343
First writeable address = 0 (0x00000000)

5:45:52 PM #5 Text 0 File Burncd.cpp, Line 3508
Turn on Track-At-Once, using CD-R/RW media

5:45:52 PM #6 Text 0 File DlgWaitCD.cpp, Line 307
Last possible write address on media: 359844 ( 79:59.69)
Last address to be written: 12928 ( 2:54.28)

5:45:52 PM #7 Text 0 File DlgWaitCD.cpp, Line 319
Write in overburning mode: NO (enabled: CD)

5:45:52 PM #8 Text 0 File DlgWaitCD.cpp, Line 2972
Recorder: LITE-ON DVDRW LH-20A1L;
CDR code: 00 97 15 17; OSJ entry from: Ritek Co.
ATIP Data:
Special Info [hex] 1: C0 00 90, 2: 61 0F 11 (LI 97:15.17), 3: 4F 3B 46 (LO 79:59.70)
Additional Info [hex] 1: 00 00 80 (invalid), 2: 00 80 00 (invalid), 3: 00 80 80 (invalid)

5:45:52 PM #9 Text 0 File DlgWaitCD.cpp, Line 493
>>> Protocol of DlgWaitCD activities: <<<
=========================================

5:45:52 PM #10 Text 0 File ThreadedTransferInterface.cpp, Line 793
Setup items (after recorder preparation)
0: TRM_DATA_MODE1 ()
2 indices, index0 (150) not provided
original disc pos #0 + 12929 (12929) = #12929/2:52.29
relocatable, disc pos for caching/writing not required/ required
-> TRM_DATA_MODE1, 2048, config 0, wanted index0 0 blocks, length 12927 blocks [D: LITE-ON DVDRW LH-20A1L]
--------------------------------------------------------------

5:45:52 PM #11 Text 0 File ThreadedTransferInterface.cpp, Line 995
Prepare [D: LITE-ON DVDRW LH-20A1L] for write in TAO
DAO infos:
==========
MCN: ""
TOCType: 0x00; Session Closed, disc fixated
Tracks 1 to 1: Idx 0 Idx 1 Next Trk
1: TRM_DATA_MODE1, 2048/0x00, FilePos 0 307200 26785792, ISRC ""
DAO layout:
===========
__Start|___Track|Idx|CtrlAdr|Size|NWA|RecDep
-150 | lead-in | 0 | 0x41 | 0 | 0 | 0x00
-150 | 1 | 0 | 0x41 | 0 | 0 | 0x00
0 | 1 | 1 | 0x41 | 12929 | 0 | 0x00
12929 | lead-out | 1 | 0x41 | 0 | 0 | 0x00

5:45:52 PM #12 Text 0 File ThreadedTransferInterface.cpp, Line 1066
Removed 2 run-out blocks from end of track 1. Length: 12929 -> 12927.

5:45:52 PM #13 Text 0 File SCSIPTICommands.cpp, Line 215
SPTILockVolume - completed successfully for FSCTL_LOCK_VOLUME

5:45:52 PM #14 Text 0 File Burncd.cpp, Line 4294
Caching options: cache CDRom or Network-Yes, small files-Yes (<64KB)

5:45:52 PM #15 Phase 24 File dlgbrnst.cpp, Line 1762
Caching of files started

5:45:52 PM #16 Text 0 File Burncd.cpp, Line 4413
Cache writing successful.

5:45:52 PM #17 Phase 25 File dlgbrnst.cpp, Line 1762
Caching of files completed

5:45:52 PM #18 Phase 36 File dlgbrnst.cpp, Line 1762
Burn process started at 48x (7,200 KB/s)

5:45:52 PM #19 Text 0 File ThreadedTransferInterface.cpp, Line 2721
Verifying disc position of item 0 (relocatable, disc pos, no patch infos, orig at #0): write at #0

5:45:52 PM #20 Text 0 File MMC.cpp, Line 22363
Set BUFE: SMART-BURN -> ON , SMART-BURN : ON

5:45:52 PM #21 Text 0 File ThreadedTransfer.cpp, Line 269
Pipe memory size 83836800

5:46:04 PM #22 SPTI -1502 File SCSIPassThrough.cpp, Line 179
CdRom0: SCSIStatus(x02) WinError(0) NeroError(-1502)
Sense Key: 0x04 (KEY_HARDWARE_ERROR)
Sense Code: 0x08
Sense Qual: 0x03
CDB Data: 0x2A 00 00 00 00 00 00 00 20 00 00 00
Sense Area: 0x70 00 04 00 00 00 00 0A 00 00 00 00 08 03
Buffer x00000000: Len x10000
0x00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
0x00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
0x00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

5:46:04 PM #23 CDR -1502 File Writer.cpp, Line 303
DMA-driver error, CRC error
D: LITE-ON DVDRW LH-20A1L

5:46:08 PM #24 CDR -201 File WriterStatus.cpp, Line 195
Invalid write state
D: LITE-ON DVDRW LH-20A1L

5:46:08 PM #25 TRANSFER -18 File WriterStatus.cpp, Line 195
Could not perform EndTrack

5:46:08 PM #26 Text 0 File MMC.cpp, Line 17131
<LITE-ON DVDRW LH-20A1L > start Close Session

5:46:24 PM #27 Phase 38 File dlgbrnst.cpp, Line 1762
Burn process failed at 48x (7,200 KB/s)

5:46:24 PM #28 Text 0 File SCSIPTICommands.cpp, Line 261
SPTIDismountVolume - completed successfully for FSCTL_DISMOUNT_VOLUME

5:46:30 PM #29 Text 0 File Cdrdrv.cpp, Line 11185
DriveLocker: UnLockVolume completed

5:46:30 PM #30 Text 0 File SCSIPTICommands.cpp, Line 424
UnLockMCN - completed sucessfully for IOCTL_STORAGE_MCN_CONTROL

Existing drivers:

Registry Keys:
HKLM\Software\Microsoft\Windows NT\CurrentVersion\WinLogon\AllocateCDROMs : 0 (Security Option)

Well… I got my drives to burn by going into the controller properties and removing the checkmark to “Let BIOS select transfer mode” AND by setting it to PIO Mode instead of Serial ATA …now PIO mode isn’t the best…but atleast it works for now. So if anyone has any idea why I can’t burn using sata mode let me know.