LH-20A1H - help explain why it cannot read

vbimport

#1

I read around and noticed that some drives’ burns just do not work well in others but this still seems a bit weird to me. I currently have an “old” NEC 3550A, and just got a new LH-20A1H. They are both on the same ide cable, 20A1H is the master and my 3550A is the slave. The only test media I have at the moment is some SONY08D1 8x dvd-r and I use cd-dvd speed to scan.
All media burned from my LH-20A1H will read and scan in my 3550A, though the 3550A will throw exuberant amounts of PO errors on some disks when my 20A1H does not (like 200+ in some small clusters -not spikes- when the 20A1H didn’t go above 5 anywhere), and yes I know this is normal between different drives).

The problem is that its hit and miss when reading my 3550A burns with my 20A1H. If they work, they work great. Scans show about the same as my 3550A and they read fine. Yet some disks will consistently not work. Not only can I not copy any large data off the disk (it does read the “index”, just takes a bit longer then normal) without a I/O device error. If I try and run a scan it will throw an error initializing every time. When put in my NEC the disk works fine and scans fine. Here is a quick summary of a scan of a disk that will not read in my 20A1H. The errors were consistent throughout (no crazy spikes) with a slightly higher cluster in the beginning of the scan.
PI errors
Maximum: 145
Average: 59.64
Total: 755702
PI failures
Maximum: 6
Average: 0.09
Total: 619

I would just assume the disks that fail in my 20A1H are just bad burns (especially because I only have one kind of media at the moment), but if that is the case wouldn’t it show up in a high error rate when scanning? I am just paranoid testing my new dvd burner because I do not want to get stuck with something that will give me problems and not be able to RMA it.
I apologize in advance for my newbness. Just thought that the PI/PO was the indication of a bad burn. If someone could clarify whats going on here I would greatly appreciate it.


#2

Update - I found I can scan all disks with my 20A1H using kprobe. Unfortunately I still get the Error Initializing in CD-DVD (newest version) when disk quality scanning those select disks (which so far even include the quake 4 retail dvd I tried…). Weird thing is, on a scan of one of those “unreadable” dvds using my 20A1H, I got a great PI/PO scan
PI: 29 Average, 92 max
PIF: 0.07 average, 2 max
no errors

yet I still cannot copy and 10meg+ files off of it and it takes forever to even get a “index” read (some small files I can get to).

Does anyone have a idea as to what is going on?


#3

Ok this threads topic should be changed to “Another newb doesn’t believe the 40pin ide is the problem”. Pulled that sucker out and replaced with a 80pin and all of my problems are solved. Everything is faster to respond along with being able to read disks with no problems whatsoever. No wonder I didnt understand why the 3550A is so popular, I had newbed its performance lol.


#4

The IDE may no longer be using DMA mode 4. If your controller is using a Microsoft driver you can check that with Device Manager. Otherwise you may have to examine the BIOS at powerup.

If so, you can find how to fix it somewhere at this site. I think you need to uninstall the IDE controller driver and re-boot.

You can also use CDspeed to see the burst rate or do a transfer rate test.