LH-20A1H Can't Read Bought DVD Movie?

vbimport

#1

Hi all

I just tried to insert one of my Lord of the Rings - Two Towers DVDs into this drive, just to see how fast it can rip, and it won’t even read the disk. Is this normal? It’s the second disk in the Special Extended Edition. I tried a few other DVD’s I had lying around, and it read these fine. It will even read Disks 1, 3 and 4, but not disk 2. I re-inserted the disk several times with the same results.

I’m using LL07.

Disk 2 plays just fine in my DVD-ROM drive (also a lite-on).

What could cause this?


#2

Hi,

I have the same drive and have the same problem.
So far the only two it can’t read are Borat and The Devil and Daniel Johnston.
I have the latest firmware.
I would certainly like to find the remedy.


#3

Try the LL0A, that’s the latest firmware.


#4

Did Sony produce LOTR? If they did, it’s likely that they used their strange copy-protection scheme in addition to CSS. When trying to simply rip, the reader will encounter read errors due to the, quite frankly, fucked up navigation structure and protected (re: bad) sectors of the disc. I’ve found this protection on All The King’s Men, Talladega Nights, Employee of the Month, and a few others so far.

The solution is to use RipIt4Me combined with FixVTS, DVD Decrypter, and optionally DVD Shrink. FixVTS creates a protected sectors list so that DVD Decrypter can identify these sectors and insert “dummy” sectors. While the copy protection has been compromised rather easily, it still makes a rip take 2-3x as long, depending on how many of these annoying sectors Sony decided to insert.

Props to Sony for merely postponing the inevitable once again.


#5

If u use the Anydvd, it will work as well.


#6

I don’t think so and AnyDVD will heal it.


#7

AnyDVD is the answer.

Btw, my liteon sucks ass at reading discs. Even with anydvd it sometimes spazzez out but ALL my other drives NEVER do that. This is also the second liteon I have had which doesn’t read half the protected movies I throw at it. Pathetic.


#8

Thank you! LLOA solved the problem.


#9

How old I check on the liteon site on the US side but don’t see any mention or link to the latest firmware LL0A at all. Does anyone one know about why that is?


#10

Check at Lite-On Global site. :slight_smile:
Direct link.


#11

I did find it and download and it updated no problem but how come the american site doesn’t give link or help on such firmware unlik the global site? What is so different from the US to global site that we in the US don’t have or know about ?>?